summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2011-11-08 22:47:02 +0000
committerAlin Năstac <mrness@gentoo.org>2011-11-08 22:47:02 +0000
commitba1c8536069d0bd8be8615e5a663b4f38df71498 (patch)
treec80260a609d245e5a60b34a0bf6226e379ffb4d6 /net-analyzer/ntop
parentVersion bump to latest releases. Update gnutls-2.12.14 to use EAPI 4 and add ... (diff)
downloadgentoo-2-ba1c8536069d0bd8be8615e5a663b4f38df71498.tar.gz
gentoo-2-ba1c8536069d0bd8be8615e5a663b4f38df71498.tar.bz2
gentoo-2-ba1c8536069d0bd8be8615e5a663b4f38df71498.zip
Version bump with added snmp support (#378333).
Drop ipv6 USE flag (no longer possible to disable IPv6 support). Remove static libraries (#382093). (Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/ntop')
-rw-r--r--net-analyzer/ntop/ChangeLog9
-rw-r--r--net-analyzer/ntop/files/ntop-4.1.0-gentoo.patch244
-rw-r--r--net-analyzer/ntop/ntop-4.1.0.ebuild102
3 files changed, 354 insertions, 1 deletions
diff --git a/net-analyzer/ntop/ChangeLog b/net-analyzer/ntop/ChangeLog
index 54c1e5e474de..f09e9e940aef 100644
--- a/net-analyzer/ntop/ChangeLog
+++ b/net-analyzer/ntop/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/ntop
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.108 2011/10/11 17:43:20 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.109 2011/11/08 22:47:02 mrness Exp $
+
+*ntop-4.1.0 (08 Nov 2011)
+
+ 08 Nov 2011; Alin Năstac <mrness@gentoo.org> +ntop-4.1.0.ebuild,
+ +files/ntop-4.1.0-gentoo.patch:
+ Version bump with added snmp support (#378333). Drop ipv6 USE flag (no longer
+ possible to disable IPv6 support). Remove static libraries (#382093).
11 Oct 2011; Jeroen Roovers <jer@gentoo.org> ntop-4.0.3.ebuild:
Stable for HPPA (bug #382091).
diff --git a/net-analyzer/ntop/files/ntop-4.1.0-gentoo.patch b/net-analyzer/ntop/files/ntop-4.1.0-gentoo.patch
new file mode 100644
index 000000000000..45d73be16486
--- /dev/null
+++ b/net-analyzer/ntop/files/ntop-4.1.0-gentoo.patch
@@ -0,0 +1,244 @@
+diff -Nru ntop-4.1.0.orig//configure.in ntop-4.1.0/configure.in
+--- ntop-4.1.0.orig//configure.in 2011-08-15 10:34:28.000000000 +0200
++++ ntop-4.1.0/configure.in 2011-11-08 23:22:13.000000000 +0100
+@@ -469,11 +469,6 @@
+ LOCALEDIR="/usr/lib/locale"
+ fi
+
+-dnl> Add /usr/local/ /opt/local
+-CFLAGS="${CFLAGS} -I/usr/local/include -I/opt/local/include"
+-CPPFLAGS="${CPPFLAGS} -I/usr/local/include -I/opt/local/include"
+-LDFLAGS="${LDFLAGS} -L/usr/local/lib -L/opt/local/lib"
+-
+ PWD=`pwd`
+
+ echo
+@@ -1716,18 +1711,6 @@
+ if test ".${ac_cv_lib_GeoIP_GeoIP_record_by_ipnum}" = ".yes"; then
+ LIBS="$LIBS -lGeoIP"
+
+-if test -f "GeoLiteCity.dat"; then
+- echo "GeoLiteCity.dat already present"
+-else
+- if test -f "3rd_party/GeoLiteCity.dat.gz"; then
+- cp 3rd_party/GeoLiteCity.dat.gz .
+- else
+- wget http://www.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
+- fi
+-
+- gunzip GeoLiteCity.dat.gz
+-fi
+-
+ dnl> --------
+
+ if test -f "GeoIPASNum.dat"; then
+@@ -1746,8 +1729,11 @@
+ exit 1
+ fi
+
+-cp "3rd_party/oui.txt.gz" .
+-cp "3rd_party/specialMAC.txt.gz" .
++gunzip 3rd_party/GeoLiteCity.dat.gz &&
++mv "3rd_party/etter.finger.os.gz" . &&
++mv "3rd_party/oui.txt.gz" . &&
++mv "3rd_party/specialMAC.txt.gz" . ||
++ exit 1
+
+ if test -d ./configureextra; then
+
+@@ -1908,7 +1894,6 @@
+ AC_SUBST(SO_VERSION_PATCH)
+ AC_SUBST(RRD_LIB)
+ AC_SUBST(RRD_INC)
+-AC_SUBST(GEO_DIR)
+ AC_SUBST(GETOPT_H)
+ AC_SUBST(GETOPT_C)
+
+diff -Nru ntop-4.1.0.orig//globals-core.c ntop-4.1.0/globals-core.c
+--- ntop-4.1.0.orig//globals-core.c 2011-03-03 22:00:04.000000000 +0100
++++ ntop-4.1.0/globals-core.c 2011-11-08 23:22:13.000000000 +0100
+@@ -367,7 +367,7 @@
+ _mtuSize[DLT_ATM_RFC1483] = 9180 /* LLC/SNAP encapsulated atm */;
+ _headerSize[DLT_ATM_RFC1483] = 0;
+
+- /* _mtuSize[DLT_RAW] = ? raw IP */
++ _mtuSize[DLT_RAW] = 1500; /* raw IP */
+ _headerSize[DLT_RAW] = 0;
+
+ /* Others defined in bpf.h at tcpdump.org as of the resync - it would be NICE
+@@ -461,19 +461,18 @@
+ struct stat statbuf;
+
+ /* Initialize GeoIP databases */
+- for(i=0; myGlobals.configFileDirs[i] != NULL; i++) {
++ {
+ char path[256];
+
+ safe_snprintf(__FILE__, __LINE__, path, sizeof(path),
+ "%s%c%s",
+- myGlobals.configFileDirs[i],
++ myGlobals.dbPath,
+ CONST_PATH_SEP, GEO_IP_FILE);
+ revertSlashIfWIN32(path, 0);
+
+ if(stat(path, &statbuf) == 0) {
+ if((myGlobals.geo_ip_db = GeoIP_open(path, GEOIP_CHECK_CACHE)) != NULL) {
+ traceEvent(CONST_TRACE_INFO, "GeoIP: loaded config file %s", path);
+- break;
+ }
+ }
+ }
+@@ -482,20 +481,18 @@
+ traceEvent(CONST_TRACE_ERROR, "GeoIP: unable to load file %s", GEO_IP_FILE);
+
+ /* *************************** */
+-
+- for(i=0; myGlobals.configFileDirs[i] != NULL; i++) {
++ {
+ char path[256];
+
+ safe_snprintf(__FILE__, __LINE__, path, sizeof(path),
+ "%s%c%s",
+- myGlobals.configFileDirs[i],
++ myGlobals.dbPath,
+ CONST_PATH_SEP, GEO_IP_ASN_FILE);
+ revertSlashIfWIN32(path, 0);
+
+ if(stat(path, &statbuf) == 0) {
+ if((myGlobals.geo_ip_asn_db = GeoIP_open(path, GEOIP_CHECK_CACHE)) != NULL) {
+ traceEvent(CONST_TRACE_INFO, "GeoIP: loaded ASN config file %s", path);
+- break;
+ }
+ }
+ }
+diff -Nru ntop-4.1.0.orig//Makefile.am ntop-4.1.0/Makefile.am
+--- ntop-4.1.0.orig//Makefile.am 2011-03-03 14:44:59.000000000 +0100
++++ ntop-4.1.0/Makefile.am 2011-11-08 23:22:42.000000000 +0100
+@@ -36,7 +36,6 @@
+
+ #AM_CFLAGS =
+ #AM_LDFLAGS=
+-ACLOCAL_AMFLAGS=-I m4
+
+ DISTCLEANFILES = trivialcompilemessage *.db #* *~ *.log
+ CLEANFILES = $(DISTCLEANFILES) stamp-h1
+@@ -67,9 +66,7 @@
+ NTOPDATA = ntop-cert.pem \
+ $(ETTER_PASSIVE) \
+ oui.txt.gz \
+- specialMAC.txt.gz \
+- GeoIPASNum.dat \
+- GeoLiteCity.dat
++ specialMAC.txt.gz
+
+ NTOPHTML = html html/*.js html/*.html html/*.gif html/*.jpg html/*.ico html/*.png \
+ html/*.css html/*.dtd \
+@@ -130,7 +127,7 @@
+
+ libntop_la_DEPENDENCIES = config.h
+ libntop_la_LIBADD = $(BASE_LIBS)
+-libntop_la_LDFLAGS = $(AM_LDFLAGS) -release $(VERSION) -export-dynamic @DYN_FLAGS@
++libntop_la_LDFLAGS = $(AM_LDFLAGS) -release $(VERSION) -export-dynamic -shared @DYN_FLAGS@
+
+ # Archive for http representation, or the 'viewer'
+ libntopreport_la_SOURCES = emitter.c globals-report.c graph.c \
+@@ -142,7 +139,7 @@
+
+ libntopreport_la_DEPENDENCIES = libntop.la
+ libntopreport_la_LIBADD = libntop.la $(BASE_LIBS)
+-libntopreport_la_LDFLAGS = $(AM_LDFLAGS) -release $(VERSION) -export-dynamic @DYN_FLAGS@
++libntopreport_la_LDFLAGS = $(AM_LDFLAGS) -release $(VERSION) -export-dynamic -shared @DYN_FLAGS@
+
+ man_MANS = ntop.8
+
+@@ -362,30 +359,7 @@
+
+ # download the vendor information table
+ dnvt:
+- @echo ""
+- @echo ""
+- @echo -n "Preparing "
+- @if test -f oui.txt; then \
+- rm -rf oui.txt; \
+- fi
+- @if test -f oui.txt.gz.old; then \
+- rm -rf oui.txt.gz.old; \
+- fi;
+- @mv oui.txt.gz oui.txt.gz.old
+- @echo "(old oui.txt.gz file is now oui.txt.gz.old)"
+- @echo ""
+- @wget -c http://standards.ieee.org/regauth/oui/oui.txt
+- @gzip oui.txt
+- @echo ""
+- @echo ""
+- @echo -n "Old file lines were: "
+- @gunzip -c oui.txt.gz.old | wc -l
+- @echo -n "New file lines are: "
+- @gunzip -c oui.txt.gz | wc -l
+- @echo ""
+- @echo ""
+- @echo "New file is:"
+- @ls -l oui.txt.gz
++ @echo "Use included oui.txt.gz"
+
+ # download the Novell SAP Protocol information table
+ #dnsapt:
+@@ -393,45 +367,7 @@
+
+ # download the passive ethernet fingerprint database
+ dnetter:
+- @echo ""
+- @echo ""
+- @echo "Preparing "
+- @echo ""
+-
+- @if test -f $(ETTER_PASSIVE).old; then \
+- echo "...Deleting prior file, $(ETTER_PASSIVE).old..."; \
+- rm -rf $(ETTER_PASSIVE).old; \
+- fi;
+- @if test -f $(ETTER_PASSIVE); then \
+- echo "...Moving current $(ETTER_PASSIVE) to $(ETTER_PASSIVE).old"; \
+- mv $(ETTER_PASSIVE) $(ETTER_PASSIVE).old; \
+- fi;
+- @for file in $(ETTER_PASSIVE) $(ETTER_PASSIVE).gz \
+- $(ETTER_PASSIVE_FILE) $(ETTER_PASSIVE_FILE).gz; do \
+- if test -f $$file; then \
+- echo "...Deleting prior file, $$file..."; \
+- rm -rf $$file; \
+- fi; \
+- done
+- @echo ""
+- @echo "...Downloading new file..."
+- @wget -O $(ETTER_PASSIVE_FILE) \
+- $(ETTER_PASSIVE_DOWNLOAD_FROM)/$(ETTER_PASSIVE_FILE)?$(ETTER_PASSIVE_DOWNLOAD_PARMS)
+- @echo ""
+- @echo "gziping downloaded file..."
+- @gzip $(ETTER_PASSIVE_FILE)
+- @echo ""
+- @echo ""
+- @if test -f $(ETTER_PASSIVE).old; then \
+- echo -n "Old file lines were: "; \
+- gunzip -c $(ETTER_PASSIVE).old | wc -l; \
+- fi;
+- @echo -n "New file lines are: "
+- @gunzip -c $(ETTER_PASSIVE) | wc -l
+- @echo ""
+- @echo ""
+- @echo "New file is:"
+- @ls -l $(ETTER_PASSIVE)
++ @echo "Use included $(ETTER_PASSIVE)"
+
+ # ntop census
+ census-fail:
+diff -Nru ntop-4.1.0.orig//report.c ntop-4.1.0/report.c
+--- ntop-4.1.0.orig//report.c 2011-06-29 18:29:46.000000000 +0200
++++ ntop-4.1.0/report.c 2011-11-08 23:22:13.000000000 +0100
+@@ -2091,7 +2091,7 @@
+ if(fetchPrefsValue("dot.path", buf, sizeof(buf)) != -1) {
+ snprintf(dotPath, sizeof(dotPath), "%s", buf);
+ } else {
+- snprintf(dotPath, sizeof(dotPath), "/usr/local/bin/dot");
++ snprintf(dotPath, sizeof(dotPath), "/usr/bin/dot");
+ storePrefsValue("dot.path", dotPath); /* Set the default */
+ }
+
diff --git a/net-analyzer/ntop/ntop-4.1.0.ebuild b/net-analyzer/ntop/ntop-4.1.0.ebuild
new file mode 100644
index 000000000000..18be286d3a20
--- /dev/null
+++ b/net-analyzer/ntop/ntop-4.1.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-4.1.0.ebuild,v 1.1 2011/11/08 22:47:02 mrness Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="Network traffic analyzer with web interface"
+HOMEPAGE="http://www.ntop.org/products/ntop/"
+SRC_URI="mirror://sourceforge/ntop/ntop/Stable/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="snmp ssl"
+
+COMMON_DEPEND="
+ sys-apps/gawk
+ dev-lang/perl
+ sys-libs/gdbm
+ dev-libs/libevent
+ net-libs/libpcap
+ media-libs/gd
+ media-libs/libpng
+ net-analyzer/rrdtool
+ ssl? ( dev-libs/openssl )
+ sys-libs/zlib
+ dev-libs/geoip
+ dev-lang/lua
+ snmp? ( net-analyzer/net-snmp[ipv6] )"
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/libtool-1.5.26"
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/corefonts
+ media-gfx/graphviz
+ net-misc/wget
+ app-arch/gzip
+ !arm? ( dev-libs/gdome2 )
+ dev-libs/glib:2"
+
+pkg_setup() {
+ enewgroup ntop
+ enewuser ntop -1 -1 /var/lib/ntop ntop
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ cp /usr/share/aclocal/libtool.m4 libtool.m4.in
+ cat acinclude.m4.in libtool.m4.in acinclude.m4.ntop > acinclude.m4
+ eautoreconf
+}
+
+src_configure() {
+ export \
+ ac_cv_header_glib_h=no \
+ ac_cv_header_glibconfig_h=no \
+ ac_cv_header_gdome_h=no \
+ ac_cv_lib_glib_g_date_julian=no \
+ ac_cv_lib_xml2_xmlCheckVersion=no \
+ ac_cv_lib_gdome_gdome_di_saveDocToFile=no
+
+ econf \
+ $(use_enable snmp) \
+ $(use_with ssl) \
+ --with-rrd-home=/usr/lib \
+ || die "configure problem"
+}
+
+src_install() {
+ LC_ALL=C # apparently doesn't work with some locales (#191576 and #205382)
+ emake DESTDIR="${D}" install || die "install problem"
+
+ keepdir /var/lib/ntop &&
+ fowners ntop:ntop /var/lib/ntop &&
+ fperms 750 /var/lib/ntop ||
+ die "failed to prepare /var/lib/ntop dir"
+ insinto /var/lib/ntop
+ gunzip 3rd_party/GeoIPASNum.dat.gz
+ local f
+ for f in GeoIPASNum.dat GeoLiteCity.dat; do
+ # Don't install included GeoIP files if newer versions are available
+ [ -f "${ROOT}/var/lib/ntop/${f}" ] ||
+ doins "3rd_party/${f}" ||
+ die "failed to install ${f}"
+ done
+
+ dodoc AUTHORS CONTENTS ChangeLog MANIFESTO NEWS
+ dodoc PORTING README SUPPORT_NTOP.txt THANKS $(find docs -type f)
+
+ newinitd "${FILESDIR}"/ntop-initd ntop
+ newconfd "${FILESDIR}"/ntop-confd ntop
+
+ exeinto /etc/cron.monthly
+ doexe "${FILESDIR}"/ntop-update-geoip-db
+}
+
+pkg_postinst() {
+ elog "If this is the first time you install ntop, you need to run"
+ elog "following command before starting ntop service:"
+ elog " ntop --set-admin-password"
+}