summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2015-05-12 16:06:37 +0000
committerRick Farina <zerochaos@gentoo.org>2015-05-12 16:06:37 +0000
commit4fea35c76c93423ac94a699c3664fcf9c648ccc8 (patch)
treeb2eca9d4be53529503d02eebab04a3d1a86704fc /net-analyzer/nmap
parentversion bump (diff)
downloadgentoo-2-4fea35c76c93423ac94a699c3664fcf9c648ccc8.tar.gz
gentoo-2-4fea35c76c93423ac94a699c3664fcf9c648ccc8.tar.bz2
gentoo-2-4fea35c76c93423ac94a699c3664fcf9c648ccc8.zip
fix build for 9999, rename lua->nse (9999 only for now) bug #529688, fix ambiguous openssl slot dep
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'net-analyzer/nmap')
-rw-r--r--net-analyzer/nmap/ChangeLog8
-rw-r--r--net-analyzer/nmap/files/nmap-9999-no-FORTIFY_SOURCE.patch77
-rw-r--r--net-analyzer/nmap/metadata.xml1
-rw-r--r--net-analyzer/nmap/nmap-6.47-r1.ebuild6
-rw-r--r--net-analyzer/nmap/nmap-6.47-r2.ebuild4
-rw-r--r--net-analyzer/nmap/nmap-9999.ebuild32
6 files changed, 110 insertions, 18 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index 9e77e9caee5d..38a4beb4e63b 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nmap
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.334 2015/01/26 12:08:35 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.335 2015/05/12 16:06:37 zerochaos Exp $
+
+ 12 May 2015; Rick Farina <zerochaos@gentoo.org>
+ +files/nmap-9999-no-FORTIFY_SOURCE.patch, metadata.xml, nmap-6.47-r1.ebuild,
+ nmap-6.47-r2.ebuild, nmap-9999.ebuild:
+ fix build for 9999, rename lua->nse (9999 only for now) bug #529688, fix
+ ambiguous openssl slot dep
*nmap-6.47-r2 (26 Jan 2015)
diff --git a/net-analyzer/nmap/files/nmap-9999-no-FORTIFY_SOURCE.patch b/net-analyzer/nmap/files/nmap-9999-no-FORTIFY_SOURCE.patch
new file mode 100644
index 000000000000..5f79238d19a3
--- /dev/null
+++ b/net-analyzer/nmap/files/nmap-9999-no-FORTIFY_SOURCE.patch
@@ -0,0 +1,77 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -40,7 +40,7 @@
+ # http://gcc.gnu.org/ml/gcc-patches/2004-09/msg02055.html
+ # Level 1 only makes changes that don't affect "conforming" programs,
+ # while level 2 enforces additional restrictions.
+-DEFS += -D_FORTIFY_SOURCE=2
++#DEFS += -D_FORTIFY_SOURCE=2
+ # For mtrace debugging -- see MTRACE define in main.cc for instructions
+ # Should only be enabled during debugging and not in any real release.
+ # DEFS += -DMTRACE=1
+--- a/nsock/src/Makefile.in
++++ b/nsock/src/Makefile.in
+@@ -13,7 +13,7 @@
+ CCOPT =
+ DEFS = @DEFS@ -DNSOCK_VERSION=\"$(NSOCK_VERSION)\"
+ # With GCC, add extra security checks to source code.
+-DEFS += -D_FORTIFY_SOURCE=2
++#DEFS += -D_FORTIFY_SOURCE=2
+ INCLS = -I../include
+ CFLAGS = @CFLAGS@ $(CCOPT)
+ # CFLAGS = -g -Wall $(DEFS) $(INCLS)
+--- a/nping/Makefile.in
++++ b/nping/Makefile.in
+@@ -37,7 +37,7 @@
+ # http://gcc.gnu.org/ml/gcc-patches/2004-09/msg02055.html
+ # Level 1 only makes changes that don't affect "conforming" programs,
+ # while level 2 enforces additional restrictions.
+-DEFS += -D_FORTIFY_SOURCE=2
++#DEFS += -D_FORTIFY_SOURCE=2
+ # For mtrace debugging -- see MTRACE define in main.cc for instructions
+ # Should only be enabled during debugging and not in any real release.
+ # DEFS += -DMTRACE=1
+--- a/libnetutil/Makefile.in
++++ b/libnetutil/Makefile.in
+@@ -5,7 +5,7 @@
+ CXXFLAGS = @CXXFLAGS@
+ CPPFLAGS = @CPPFLAGS@ $(DEFS)
+ DEFS = @DEFS@
+-DEFS += -D_FORTIFY_SOURCE=2
++#DEFS += -D_FORTIFY_SOURCE=2
+ AR = ar
+ RANLIB = @RANLIB@
+
+--- a/ncat/Makefile.in
++++ b/ncat/Makefile.in
+@@ -52,7 +52,7 @@
+ LIBS = @LIBS@
+ DEFS = @DEFS@ -DNCAT_DATADIR="\"$(pkgdatadir)\""
+ # With GCC, add extra security checks to source code.
+-DEFS += -D_FORTIFY_SOURCE=2
++#DEFS += -D_FORTIFY_SOURCE=2
+ INCLS = -I. -I.. -I../nsock/include/ -I$(NBASEDIR)
+ RM = rm -f
+ STRIP = @STRIP@
+--- a/nbase/Makefile.in
++++ b/nbase/Makefile.in
+@@ -11,7 +11,7 @@
+ CCOPT =
+ DEFS = @DEFS@
+ # With GCC, add extra security checks to source code.
+-DEFS += -D_FORTIFY_SOURCE=2
++#DEFS += -D_FORTIFY_SOURCE=2
+ CPPFLAGS = @CPPFLAGS@
+ CFLAGS = @CFLAGS@ $(CCOPT) $(GLIB_CFLAGS) $(DEFS) $(INCLS)
+ STATIC =
+--- a/nmap-update/Makefile.in
++++ b/nmap-update/Makefile.in
+@@ -10,7 +10,7 @@
+ CPPFLAGS = @CPPFLAGS@ $(DEFS) -I$(NBASEDIR)
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@ $(NBASELIB)
+-DEFS = @DEFS@ -D_FORTIFY_SOURCE=2
++DEFS = @DEFS@
+ APR_LIBS = @APR_LIBS@
+ SVN_LIBS = @SVN_LIBS@
+
diff --git a/net-analyzer/nmap/metadata.xml b/net-analyzer/nmap/metadata.xml
index e72fe434072d..ff34d48df46e 100644
--- a/net-analyzer/nmap/metadata.xml
+++ b/net-analyzer/nmap/metadata.xml
@@ -9,6 +9,7 @@
<flag name="ndiff">Install the ndiff utility</flag>
<flag name="nmap-update">Install nmap-update, which uses <pkg>dev-vcs/subversion</pkg> to update nmap scripts in your home directory</flag>
<flag name="nping">Install the nping utility</flag>
+<flag name="nse">Include support for the Nmap Scripting Engine (NSE)</flag>
<flag name="zenmap">Install the GTK+ based nmap GUI, zenmap</flag>
</use>
</pkgmetadata>
diff --git a/net-analyzer/nmap/nmap-6.47-r1.ebuild b/net-analyzer/nmap/nmap-6.47-r1.ebuild
index 600163ac9267..498d9a9164ae 100644
--- a/net-analyzer/nmap/nmap-6.47-r1.ebuild
+++ b/net-analyzer/nmap/nmap-6.47-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-6.47-r1.ebuild,v 1.13 2014/12/03 09:57:43 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-6.47-r1.ebuild,v 1.14 2015/05/12 16:06:37 zerochaos Exp $
EAPI=5
@@ -43,7 +43,7 @@ RDEPEND="
ndiff? ( ${PYTHON_DEPS} )
nls? ( virtual/libintl )
nmap-update? ( dev-libs/apr dev-vcs/subversion )
- ssl? ( dev-libs/openssl )
+ ssl? ( dev-libs/openssl:0= )
"
DEPEND="
${RDEPEND}
diff --git a/net-analyzer/nmap/nmap-6.47-r2.ebuild b/net-analyzer/nmap/nmap-6.47-r2.ebuild
index ac0a854c9c4e..4a1f4e31b8e6 100644
--- a/net-analyzer/nmap/nmap-6.47-r2.ebuild
+++ b/net-analyzer/nmap/nmap-6.47-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-6.47-r2.ebuild,v 1.1 2015/01/26 12:08:35 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-6.47-r2.ebuild,v 1.2 2015/05/12 16:06:37 zerochaos Exp $
EAPI=5
@@ -43,7 +43,7 @@ RDEPEND="
ndiff? ( ${PYTHON_DEPS} )
nls? ( virtual/libintl )
nmap-update? ( dev-libs/apr dev-vcs/subversion )
- ssl? ( dev-libs/openssl )
+ ssl? ( dev-libs/openssl:0= )
"
DEPEND="
${RDEPEND}
diff --git a/net-analyzer/nmap/nmap-9999.ebuild b/net-analyzer/nmap/nmap-9999.ebuild
index f624fb91e2c5..5b6fe5f24f5f 100644
--- a/net-analyzer/nmap/nmap-9999.ebuild
+++ b/net-analyzer/nmap/nmap-9999.ebuild
@@ -1,32 +1,40 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-9999.ebuild,v 1.2 2015/01/26 12:08:35 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-9999.ebuild,v 1.3 2015/05/12 16:06:37 zerochaos Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="sqlite,xml"
-inherit eutils flag-o-matic python-single-r1 subversion toolchain-funcs
+inherit eutils flag-o-matic python-single-r1 toolchain-funcs
MY_P=${P/_beta/BETA}
DESCRIPTION="A utility for network exploration or security auditing"
HOMEPAGE="http://nmap.org/"
-ESVN_REPO_URI="https://svn.nmap.org/nmap"
-SRC_URI="
- http://dev.gentoo.org/~jer/nmap-logo-64.png
-"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit subversion
+ ESVN_REPO_URI="https://svn.nmap.org/nmap"
+ SRC_URI="http://dev.gentoo.org/~jer/nmap-logo-64.png"
+ KEYWORDS=""
+else
+ SRC_URI="
+ http://nmap.org/dist/${MY_P}.tar.bz2
+ http://dev.gentoo.org/~jer/nmap-logo-64.png
+ "
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+fi
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
-IUSE="ipv6 +lua system-lua ncat ndiff nls nmap-update nping ssl zenmap"
+IUSE="ipv6 +nse system-lua ncat ndiff nls nmap-update nping ssl zenmap"
NMAP_LINGUAS=( de fr hr it ja pl pt_BR ru zh )
IUSE+=" ${NMAP_LINGUAS[@]/#/linguas_}"
REQUIRED_USE="
- system-lua? ( lua )
+ system-lua? ( nse )
ndiff? ( ${PYTHON_REQUIRED_USE} )
zenmap? ( ${PYTHON_REQUIRED_USE} )
"
@@ -43,7 +51,7 @@ RDEPEND="
ndiff? ( ${PYTHON_DEPS} )
nls? ( virtual/libintl )
nmap-update? ( dev-libs/apr dev-vcs/subversion )
- ssl? ( dev-libs/openssl )
+ ssl? ( dev-libs/openssl:0= )
"
DEPEND="
${RDEPEND}
@@ -67,7 +75,7 @@ src_prepare() {
"${FILESDIR}"/${PN}-6.25-liblua-ar.patch \
"${FILESDIR}"/${PN}-6.46-uninstaller.patch \
"${FILESDIR}"/${PN}-6.47-no-libnl.patch \
- "${FILESDIR}"/${PN}-6.47-no-FORTIFY_SOURCE.patch
+ "${FILESDIR}"/${PN}-9999-no-FORTIFY_SOURCE.patch
if use nls; then
local lingua=''
@@ -106,7 +114,7 @@ src_configure() {
$(use_enable ipv6) \
$(use_enable nls) \
$(use_with zenmap) \
- $(usex lua --with-liblua=$(usex system-lua /usr included '' '') --without-liblua) \
+ $(usex nse --with-liblua=$(usex system-lua /usr included '' '') --without-liblua) \
$(use_with ncat) \
$(use_with ndiff) \
$(use_with nmap-update) \