summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-12-30 10:04:22 +0000
committerPeter Volkov <pva@gentoo.org>2008-12-30 10:04:22 +0000
commit6c46f8a0ec04dd4d5154980a7fd32564a56326e4 (patch)
tree3fff0ee1ff4e5d1c19410ce47d6fccc6331055de /net-analyzer/iptraf
parentUpdate homepage (diff)
downloadgentoo-2-6c46f8a0ec04dd4d5154980a7fd32564a56326e4.tar.gz
gentoo-2-6c46f8a0ec04dd4d5154980a7fd32564a56326e4.tar.bz2
gentoo-2-6c46f8a0ec04dd4d5154980a7fd32564a56326e4.zip
Fixed build issue with uclibc, bug #252874, thank Tom Lloyd for report.
(Portage version: 2.2_rc20/cvs/Linux 2.6.26-openvz.git-89451f9 i686)
Diffstat (limited to 'net-analyzer/iptraf')
-rw-r--r--net-analyzer/iptraf/ChangeLog6
-rw-r--r--net-analyzer/iptraf/files/iptraf-3.0.0-ipv6-glibc24-updated.patch40
-rw-r--r--net-analyzer/iptraf/iptraf-3.0.0-r5.ebuild12
3 files changed, 49 insertions, 9 deletions
diff --git a/net-analyzer/iptraf/ChangeLog b/net-analyzer/iptraf/ChangeLog
index 704bbc909077..4adf9828042f 100644
--- a/net-analyzer/iptraf/ChangeLog
+++ b/net-analyzer/iptraf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/iptraf
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptraf/ChangeLog,v 1.69 2008/10/27 14:41:54 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptraf/ChangeLog,v 1.70 2008/12/30 10:04:22 pva Exp $
+
+ 30 Dec 2008; Peter Volkov <pva@gentoo.org>
+ +files/iptraf-3.0.0-ipv6-glibc24-updated.patch, iptraf-3.0.0-r5.ebuild:
+ Fixed build issue with uclibc, bug #252874, thank Tom Lloyd for report.
27 Oct 2008; Peter Volkov <pva@gentoo.org> iptraf-3.0.0-r5.ebuild:
~mips keyworded, bug #237773
diff --git a/net-analyzer/iptraf/files/iptraf-3.0.0-ipv6-glibc24-updated.patch b/net-analyzer/iptraf/files/iptraf-3.0.0-ipv6-glibc24-updated.patch
new file mode 100644
index 000000000000..52747e063e2f
--- /dev/null
+++ b/net-analyzer/iptraf/files/iptraf-3.0.0-ipv6-glibc24-updated.patch
@@ -0,0 +1,40 @@
+=== modified file 'src/othptab.c'
+--- src/othptab.c 2008-12-30 09:54:16 +0000
++++ src/othptab.c 2008-12-30 09:57:18 +0000
+@@ -561,8 +561,13 @@
+ case ICMP6_DST_UNREACH_ADMIN:
+ strcpy(additional, "admin");
+ break;
++#ifdef ICMP6_DST_UNREACH_NOTNEIGHBOR
+ case ICMP6_DST_UNREACH_NOTNEIGHBOR:
+ strcpy(additional, "not neigh");
++#else
++ case ICMP6_DST_UNREACH_BEYONDSCOPE:
++ strcpy(additional, "beyondscope");
++#endif
+ break;
+ case ICMP6_DST_UNREACH_ADDR:
+ strcpy(additional, "unreach addr");
+@@ -593,15 +598,21 @@
+ case ND_ROUTER_ADVERT:
+ strcpy(description, "router adv");
+ break;
++#ifdef ICMP6_MEMBERSHIP_QUERY
+ case ICMP6_MEMBERSHIP_QUERY:
+ strcpy(description, "mbrship query");
+ break;
++#endif
++#ifdef ICMP6_MEMBERSHIP_REPORT
+ case ICMP6_MEMBERSHIP_REPORT:
+ strcpy(description, "mbrship report");
+ break;
++#endif
++#ifdef ICMP6_MEMBERSHIP_REDUCTION
+ case ICMP6_MEMBERSHIP_REDUCTION:
+ strcpy(description, "mbrship reduc");
+ break;
++#endif
+ case ND_NEIGHBOR_SOLICIT:
+ strcpy(description, "neigh sol");
+ break;
+
diff --git a/net-analyzer/iptraf/iptraf-3.0.0-r5.ebuild b/net-analyzer/iptraf/iptraf-3.0.0-r5.ebuild
index 192c92b99781..9a984fe7e26e 100644
--- a/net-analyzer/iptraf/iptraf-3.0.0-r5.ebuild
+++ b/net-analyzer/iptraf/iptraf-3.0.0-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptraf/iptraf-3.0.0-r5.ebuild,v 1.3 2008/11/06 02:34:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptraf/iptraf-3.0.0-r5.ebuild,v 1.4 2008/12/30 10:04:22 pva Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -44,13 +44,9 @@ src_unpack() {
if use ipv6 ; then
epatch "${DISTDIR}"/${P}-ipv6.patch.bz2
- # bug 126479
- if has_version '>=sys-libs/glibc-2.4' ; then
- epatch "${FILESDIR}"/${P}-ipv6-glibc24.patch
- fi
-
- # bug 128965
- epatch "${FILESDIR}"/${P}-ipv6-headerfix.patch
+ # bug #126479 and bug #252874
+ epatch "${FILESDIR}"/${P}-ipv6-glibc24-updated.patch
+ epatch "${FILESDIR}"/${P}-ipv6-headerfix.patch #128965
fi
}