summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-10-09 09:09:01 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-10-09 09:09:01 +0000
commit62a9e03c0cfeeaa236e54c251abccc3dc881f80f (patch)
tree39aaa9bf2555ceb108ff3c741255d775f624a7f8 /net-analyzer/fragroute
parentVersion bump. (diff)
downloadgentoo-2-62a9e03c0cfeeaa236e54c251abccc3dc881f80f.tar.gz
gentoo-2-62a9e03c0cfeeaa236e54c251abccc3dc881f80f.tar.bz2
gentoo-2-62a9e03c0cfeeaa236e54c251abccc3dc881f80f.zip
Revision bump
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/fragroute')
-rw-r--r--net-analyzer/fragroute/ChangeLog11
-rw-r--r--net-analyzer/fragroute/fragroute-1.2-r4.ebuild43
2 files changed, 52 insertions, 2 deletions
diff --git a/net-analyzer/fragroute/ChangeLog b/net-analyzer/fragroute/ChangeLog
index 0764b3bda48b..89d2ee3b5392 100644
--- a/net-analyzer/fragroute/ChangeLog
+++ b/net-analyzer/fragroute/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/fragroute
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fragroute/ChangeLog,v 1.23 2011/10/23 20:22:56 radhermit Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fragroute/ChangeLog,v 1.24 2012/10/09 09:09:01 pinkbyte Exp $
+
+*fragroute-1.2-r4 (09 Oct 2012)
+
+ 09 Oct 2012; Sergey Popov <pinkbyte@gentoo.org> +fragroute-1.2-r4.ebuild:
+ Revision bump: bump to EAPI 4, use default src_install, utilize patches
+ through base eclass,
+ add missing awk dependency and remove automagic on libpcap
23 Oct 2011; Tim Harder <radhermit@gentoo.org> -fragroute-1.2-r1.ebuild:
Remove old.
diff --git a/net-analyzer/fragroute/fragroute-1.2-r4.ebuild b/net-analyzer/fragroute/fragroute-1.2-r4.ebuild
new file mode 100644
index 000000000000..bee5717fdc9e
--- /dev/null
+++ b/net-analyzer/fragroute/fragroute-1.2-r4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fragroute/fragroute-1.2-r4.ebuild,v 1.1 2012/10/09 09:09:01 pinkbyte Exp $
+
+EAPI="4"
+
+inherit base eutils toolchain-funcs
+
+DESCRIPTION="Testing of network intrusion detection systems, firewalls and TCP/IP stacks"
+HOMEPAGE="http://www.monkey.org/~dugsong/fragroute/"
+SRC_URI="http://www.monkey.org/~dugsong/fragroute/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libevent
+ net-libs/libpcap
+ >=dev-libs/libdnet-1.4
+"
+DEPEND="${RDEPEND}
+ virtual/awk"
+
+DOCS="INSTALL README TODO"
+
+PATCHES=( "${FILESDIR}"/${PV}-libevent.patch )
+
+src_prepare() {
+ base_src_prepare
+ sed -i configure \
+ -e 's|libevent.a|libevent.so|g' \
+ || die "sed configure.in"
+ tc-export CC
+}
+
+src_configure() {
+ econf \
+ --with-libevent="${EPREFIX}"/usr \
+ --with-libdnet="${EPREFIX}"/usr \
+ --with-pcap="${EPREFIX}"/usr
+}