summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-06-15 09:21:26 +0000
committerZac Medico <zmedico@gentoo.org>2008-06-15 09:21:26 +0000
commit885ed09883644947b9868b5ddad1c54c41e797d9 (patch)
treece109c1b4535ceb171d16d3ca4e47738a322d3d0 /net-analyzer/fail2ban
parentVersion bump for #221197 (diff)
downloadgentoo-2-885ed09883644947b9868b5ddad1c54c41e797d9.tar.gz
gentoo-2-885ed09883644947b9868b5ddad1c54c41e797d9.tar.bz2
gentoo-2-885ed09883644947b9868b5ddad1c54c41e797d9.zip
Bug #226505 - For compatibility with phase execution order in
>=portage-2.1.5, call has_version inside pkg_preinst instead of pkg_postinst. (Portage version: 2.2_pre10652/cvs/Linux 2.6.25-0518-x86-64 i686)
Diffstat (limited to 'net-analyzer/fail2ban')
-rw-r--r--net-analyzer/fail2ban/ChangeLog8
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.8.0-r1.ebuild11
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.8.1.ebuild9
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.8.2.ebuild9
4 files changed, 29 insertions, 8 deletions
diff --git a/net-analyzer/fail2ban/ChangeLog b/net-analyzer/fail2ban/ChangeLog
index 136ea14a96f1..8f15a95b69fc 100644
--- a/net-analyzer/fail2ban/ChangeLog
+++ b/net-analyzer/fail2ban/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/fail2ban
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.41 2008/03/18 19:09:33 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.42 2008/06/15 09:21:26 zmedico Exp $
+
+ 15 Jun 2008; Zac Medico <zmedico@gentoo.org> fail2ban-0.8.0-r1.ebuild,
+ fail2ban-0.8.1.ebuild, fail2ban-0.8.2.ebuild:
+ Bug #226505 - For compatibility with phase execution order in
+ >=portage-2.1.5, call has_version inside pkg_preinst instead of
+ pkg_postinst.
18 Mar 2008; Jeroen Roovers <jer@gentoo.org> fail2ban-0.8.2.ebuild:
Commit the changes proposed in bug #213796.
diff --git a/net-analyzer/fail2ban/fail2ban-0.8.0-r1.ebuild b/net-analyzer/fail2ban/fail2ban-0.8.0-r1.ebuild
index c347f3239888..dbce3e8940ec 100644
--- a/net-analyzer/fail2ban/fail2ban-0.8.0-r1.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-0.8.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.0-r1.ebuild,v 1.6 2007/07/05 22:49:55 falco Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.0-r1.ebuild,v 1.7 2008/06/15 09:21:26 zmedico Exp $
inherit distutils
@@ -31,8 +31,13 @@ src_install() {
doman man/*.1 || die "doman failed"
}
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.7"
+ previous_less_than_0_7=$?
+}
+
pkg_postinst() {
- if has_version '<net-analyzer/fail2ban-0.7' ; then
+ if [[ $previous_less_than_0_7 = 0 ]] ; then
elog
elog "Configuration files are now in /etc/fail2ban/"
elog "You probably have to manually update your configuration"
diff --git a/net-analyzer/fail2ban/fail2ban-0.8.1.ebuild b/net-analyzer/fail2ban/fail2ban-0.8.1.ebuild
index 64a06c1bfcf6..664b35edd45f 100644
--- a/net-analyzer/fail2ban/fail2ban-0.8.1.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-0.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.1.ebuild,v 1.4 2008/02/27 20:34:37 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.1.ebuild,v 1.5 2008/06/15 09:21:26 zmedico Exp $
inherit distutils
@@ -31,8 +31,13 @@ src_install() {
newins "${FILESDIR}"/${PN}-logrotate ${PN} || die
}
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.7"
+ previous_less_than_0_7=$?
+}
+
pkg_postinst() {
- if has_version '<net-analyzer/fail2ban-0.7' ; then
+ if [[ $previous_less_than_0_7 = 0 ]] ; then
elog
elog "Configuration files are now in /etc/fail2ban/"
elog "You probably have to manually update your configuration"
diff --git a/net-analyzer/fail2ban/fail2ban-0.8.2.ebuild b/net-analyzer/fail2ban/fail2ban-0.8.2.ebuild
index 30c2a0ac9048..3b50282e505d 100644
--- a/net-analyzer/fail2ban/fail2ban-0.8.2.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-0.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.2.ebuild,v 1.2 2008/03/18 19:09:33 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.2.ebuild,v 1.3 2008/06/15 09:21:26 zmedico Exp $
inherit distutils
@@ -35,8 +35,13 @@ src_install() {
newins "${FILESDIR}"/${PN}-logrotate ${PN} || die
}
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.7"
+ previous_less_than_0_7=$?
+}
+
pkg_postinst() {
- if has_version '<net-analyzer/fail2ban-0.7' ; then
+ if [[ $previous_less_than_0_7 = 0 ]] ; then
elog
elog "Configuration files are now in /etc/fail2ban/"
elog "You probably have to manually update your configuration"