summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-04-26 17:50:56 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-04-26 17:50:56 +0000
commit80afb1e5c838c54d32df9815c0b2bf8642fe73c9 (patch)
tree8f7b2d6c2aa63463678966640fa4a80aaaef15dc /net-analyzer/bsnmp
parentremove usemasks depending on bsnmp (diff)
downloadgentoo-2-80afb1e5c838c54d32df9815c0b2bf8642fe73c9.tar.gz
gentoo-2-80afb1e5c838c54d32df9815c0b2bf8642fe73c9.tar.bz2
gentoo-2-80afb1e5c838c54d32df9815c0b2bf8642fe73c9.zip
version bump, do not build with werror, keyword ~amd64-fbsd
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/bsnmp')
-rw-r--r--net-analyzer/bsnmp/ChangeLog10
-rw-r--r--net-analyzer/bsnmp/bsnmp-1.12.ebuild45
-rw-r--r--net-analyzer/bsnmp/files/werror.patch11
3 files changed, 64 insertions, 2 deletions
diff --git a/net-analyzer/bsnmp/ChangeLog b/net-analyzer/bsnmp/ChangeLog
index d96a00a7d9f8..d204b934c2df 100644
--- a/net-analyzer/bsnmp/ChangeLog
+++ b/net-analyzer/bsnmp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/bsnmp
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bsnmp/ChangeLog,v 1.2 2006/05/23 16:40:10 flameeyes Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bsnmp/ChangeLog,v 1.3 2012/04/26 17:50:56 aballier Exp $
+
+*bsnmp-1.12 (26 Apr 2012)
+
+ 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> +bsnmp-1.12.ebuild,
+ +files/werror.patch:
+ version bump, do not build with werror, keyword ~amd64-fbsd
23 May 2006; Diego Pettenò <flameeyes@gentoo.org> bsnmp-1.11a.ebuild:
Fix quoting.
diff --git a/net-analyzer/bsnmp/bsnmp-1.12.ebuild b/net-analyzer/bsnmp/bsnmp-1.12.ebuild
new file mode 100644
index 000000000000..1ed6f3497d4e
--- /dev/null
+++ b/net-analyzer/bsnmp/bsnmp-1.12.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bsnmp/bsnmp-1.12.ebuild,v 1.1 2012/04/26 17:50:56 aballier Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Mini-SNMP Daemon and Library"
+HOMEPAGE="http://people.freebsd.org/~harti/"
+SRC_URI="http://people.freebsd.org/~harti/bsnmp/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64-fbsd ~x86-fbsd"
+IUSE="tcpd"
+
+DEPEND="dev-libs/libbegemot
+ tcpd? ( sys-apps/tcp-wrappers )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.10-gcc34.patch"
+ epatch "${FILESDIR}/werror.patch"
+}
+
+src_compile() {
+ if use elibc_glibc; then
+ # bsnmp is bsd-based, without this it will fail
+ append-flags "-D_BSD_SOURCE"
+ fi
+
+ filter-flags -fno-inline
+
+ econf \
+ --with-libbegemot=/usr \
+ $(use_with tcpd tcpwrappers) \
+ || die "econf failed"
+
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ einstall || die "make install failed"
+}
diff --git a/net-analyzer/bsnmp/files/werror.patch b/net-analyzer/bsnmp/files/werror.patch
new file mode 100644
index 000000000000..7a0968e84441
--- /dev/null
+++ b/net-analyzer/bsnmp/files/werror.patch
@@ -0,0 +1,11 @@
+--- bsnmp-1.12/config/Makefile.pre.old 2012-04-26 10:45:58.000000000 -0400
++++ bsnmp-1.12/config/Makefile.pre 2012-04-26 10:46:11.000000000 -0400
+@@ -53,7 +53,7 @@
+ # Assume a Posix-ish make that passes MAKEFLAGS in the environment.
+ SUBMAKE= $(MAKE) --no-print-directory
+
+-WARNS= -Wsystem-headers -Werror -Wall -Wno-format-y2k -W \
++WARNS= -Wsystem-headers -Wall -Wno-format-y2k -W \
+ -Wstrict-prototypes -Wmissing-prototypes \
+ -Wpointer-arith -Wreturn-type -Wcast-qual \
+ -Wwrite-strings -Wswitch -Wshadow -Wcast-align \