summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-05-23 13:10:45 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-05-23 13:10:45 +0000
commitf4c1c997e337e8a87c320837e978669292464547 (patch)
tree2fce25dd6fec879f34e8209be207075744824aae /media-video
parentAdd tabs support in kadu per request from Qlawy on irc (diff)
downloadgentoo-2-f4c1c997e337e8a87c320837e978669292464547.tar.gz
gentoo-2-f4c1c997e337e8a87c320837e978669292464547.tar.bz2
gentoo-2-f4c1c997e337e8a87c320837e978669292464547.zip
Bump to 0.31. Fix build with -no-undefined, segfaults and waveform creation.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/subtitleeditor/ChangeLog9
-rw-r--r--media-video/subtitleeditor/subtitleeditor-0.31.0.ebuild54
2 files changed, 62 insertions, 1 deletions
diff --git a/media-video/subtitleeditor/ChangeLog b/media-video/subtitleeditor/ChangeLog
index 0b64e6731d89..adbb70718c52 100644
--- a/media-video/subtitleeditor/ChangeLog
+++ b/media-video/subtitleeditor/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/subtitleeditor
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/ChangeLog,v 1.1 2009/02/01 10:47:24 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/ChangeLog,v 1.2 2009/05/23 13:10:45 eva Exp $
+
+*subtitleeditor-0.31.0 (23 May 2009)
+
+ 23 May 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +subtitleeditor-0.31.0.ebuild:
+ Bump to 0.31. Fix build with -no-undefined, segfaults and waveform
+ creation.
*subtitleeditor-0.30.0 (01 Feb 2009)
diff --git a/media-video/subtitleeditor/subtitleeditor-0.31.0.ebuild b/media-video/subtitleeditor/subtitleeditor-0.31.0.ebuild
new file mode 100644
index 000000000000..4d4030ab3902
--- /dev/null
+++ b/media-video/subtitleeditor/subtitleeditor-0.31.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/subtitleeditor-0.31.0.ebuild,v 1.1 2009/05/23 13:10:45 eva Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="GTK+2 subtitle editing tool."
+HOMEPAGE="http://home.gna.org/subtitleeditor/"
+SRC_URI="http://download.gna.org/${PN}/${PV%.*}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug opengl"
+
+RDEPEND=">=x11-libs/gtk+-2.12
+ >=dev-cpp/gtkmm-2.12
+ >=dev-cpp/glibmm-2.16.3
+ >=dev-cpp/libglademm-2.4
+ >=dev-cpp/libxmlpp-2.10
+ >=app-text/enchant-1.1.0
+ opengl? ( >=dev-cpp/gtkglextmm-1.2 )
+ >=media-libs/gstreamer-0.10
+ >=media-libs/gst-plugins-good-0.10
+ >=media-plugins/gst-plugins-meta-0.10-r2:0.10
+ app-text/iso-codes"
+#>=media-plugins/gst-plugins-pango-0.10
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig"
+
+src_configure() {
+ export GST_REGISTRY="${T}/home/registry.cache.xml"
+
+ # USE="debug" seems to turn on some debug path
+ econf \
+ $(use_enable debug) \
+ $(use_enable opengl gl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If ${PN} doesn't play some video format, please check your"
+ ewarn "USE flags on media-plugins/gst-plugins-meta"
+ ewarn
+}