summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-07-06 14:04:26 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-07-06 14:04:26 +0000
commitb4c289d87e9e9fb1f1b9d3dbafbcfbb7ff79275f (patch)
tree09492dd26d9ac6bdf26ab455bc64ae59036d822c /media-video
parentFix building against glibc-2.16 by Martin Jansa (bug #425026). (diff)
downloadgentoo-2-b4c289d87e9e9fb1f1b9d3dbafbcfbb7ff79275f.tar.gz
gentoo-2-b4c289d87e9e9fb1f1b9d3dbafbcfbb7ff79275f.tar.bz2
gentoo-2-b4c289d87e9e9fb1f1b9d3dbafbcfbb7ff79275f.zip
add iec61883 useflag
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ChangeLog6
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild14
-rw-r--r--media-video/ffmpeg/metadata.xml1
3 files changed, 15 insertions, 6 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index 1057402683db..46fb6cea9a54 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.566 2012/06/23 17:10:06 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.567 2012/07/06 14:04:26 aballier Exp $
+
+ 06 Jul 2012; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999.ebuild,
+ metadata.xml:
+ add iec61883 useflag
23 Jun 2012; Raúl Porcel <armin76@gentoo.org> ffmpeg-0.10.3.ebuild:
alpha/ia64/sparc stable wrt #420305
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 69c502532bf8..f522c1a228ba 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.96 2012/06/17 04:56:29 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.97 2012/07/06 14:04:26 aballier Exp $
EAPI="4"
@@ -31,9 +31,10 @@ fi
IUSE="
aac aacplus alsa amr avresample bindist bluray +bzip2 cdio celt
cpudetection debug doc +encode faac fontconfig frei0r gnutls gsm
- +hardcoded-tables ieee1394 jack jpeg2k libass libv4l modplug mp3 network
- openal openssl oss pic pulseaudio rtmp schroedinger sdl speex static-libs
- test theora threads truetype v4l vaapi vdpau vorbis vpx X x264 xvid +zlib
+ +hardcoded-tables iec61883 ieee1394 jack jpeg2k libass libv4l modplug mp3
+ network openal openssl oss pic pulseaudio rtmp schroedinger sdl speex
+ static-libs test theora threads truetype v4l vaapi vdpau vorbis vpx X x264
+ xvid +zlib
"
# String for CPU features in the useflag[:configure_option] form
@@ -71,6 +72,7 @@ RDEPEND="
frei0r? ( media-plugins/frei0r-plugins )
gnutls? ( >=net-libs/gnutls-2.12.16 )
gsm? ( >=media-sound/gsm-1.0.12-r1 )
+ iec61883? ( media-libs/libiec61883 sys-libs/libraw1394 sys-libs/libavc1394 )
ieee1394? ( media-libs/libdc1394 sys-libs/libraw1394 )
jack? ( media-sound/jack-audio-connection-kit )
jpeg2k? ( >=media-libs/openjpeg-1.3-r2 )
@@ -156,7 +158,9 @@ src_configure() {
fi
# libavdevice options
- use cdio && myconf="${myconf} --enable-libcdio"
+ for i in cdio iec61883 ; do
+ use ${i} && myconf="${myconf} --enable-lib${i}"
+ done
use ieee1394 && myconf="${myconf} --enable-libdc1394"
use openal && myconf="${myconf} --enable-openal"
# Indevs
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index b203bb34f42d..51e8381d02a8 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -23,6 +23,7 @@
<flag name="faac">Use external faac library for AAC encoding</flag>
<flag name="frei0r">Enable frei0r wrapping in libavfilter</flag>
<flag name="hardcoded-tables">Use pre-calculated tables rather than calculating them on the fly.</flag>
+ <flag name="iec61883"> Support for FireWire DV/HDV input device using <pkg>media-libs/libiec61883</pkg>.</flag>
<flag name="libv4l">Uses <pkg>media-libs/libv4l</pkg> for video4linux instead of direct calls. Adds support for more devices via the userspace library.</flag>
<flag name="mmxext">Enables mmx2 support</flag>
<flag name="network">Enables network streaming support</flag>