summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Jackson <iggy@gentoo.org>2003-10-18 19:30:29 +0000
committerBrian Jackson <iggy@gentoo.org>2003-10-18 19:30:29 +0000
commitb020d35058722b8206c6cd50b098ad3f3b8b6046 (patch)
tree00a1dbf4224dfef43eaee492ef3f2aecf6756254 /media-video
parentversion bump, keep it from trying to include X11/Xlib.h (diff)
downloadgentoo-2-b020d35058722b8206c6cd50b098ad3f3b8b6046.tar.gz
gentoo-2-b020d35058722b8206c6cd50b098ad3f3b8b6046.tar.bz2
gentoo-2-b020d35058722b8206c6cd50b098ad3f3b8b6046.zip
version bump, keep it from trying to include X11/Xlib.h
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ChangeLog8
-rw-r--r--media-video/ffmpeg/Manifest4
-rw-r--r--media-video/ffmpeg/ffmpeg-0.4.8.ebuild81
-rw-r--r--media-video/ffmpeg/files/digest-ffmpeg-0.4.81
4 files changed, 91 insertions, 3 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index 9c542901f439..0afd23a41553 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/ffmpeg
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.21 2003/09/07 22:40:55 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.22 2003/10/18 19:30:27 iggy Exp $
+
+*ffmpeg-0.4.8 (18 Oct 2003)
+
+ 18 Oct 2003; <iggy@gentoo.org> ffmpeg-0.4.8.ebuild:
+ version bump, fix a bug where it was trying to include X11/Xlib.h for no
+ apparent reason
*ffmpeg-0.4.7 (09 Sep 2003)
diff --git a/media-video/ffmpeg/Manifest b/media-video/ffmpeg/Manifest
index de3e12735b57..c023101b6c24 100644
--- a/media-video/ffmpeg/Manifest
+++ b/media-video/ffmpeg/Manifest
@@ -1,9 +1,9 @@
MD5 0e7fbbc527dae3974d754bc9330f28a3 ffmpeg-0.4.7_pre20030624.ebuild 2244
-MD5 9f735c4a314843c2c99e081f18e14bb4 ffmpeg-0.4.8.ebuild 2214
+MD5 042308c4fe2469035fe564387f72110f ffmpeg-0.4.8.ebuild 2311
MD5 2d75291c4685dc1a93c5e91901df57c0 ffmpeg-0.4.5.ebuild 693
MD5 17a733455dace1d0147e7640772affb9 ffmpeg-0.4.7.ebuild 2161
MD5 e6b59f0960df4d0c10cfaa89aa6d48db ffmpeg-0.4.6-r1.ebuild 1561
-MD5 2a02d0c066fd934efdc5ab5d0d45893e ChangeLog 3659
+MD5 f0b3e5b16eb2ea06125cf2ee9ccf322e ChangeLog 3833
MD5 afaf74cb5011c84394bd0e9b0d5629a5 ffmpeg-0.4.6.ebuild 1523
MD5 566133b90b840d9da9452facbfef0d6e files/digest-ffmpeg-0.4.6-r1 64
MD5 6f1d9c82b5e8c3b7c46b80bc3c1bb443 files/alpha-idct.patch 777
diff --git a/media-video/ffmpeg/ffmpeg-0.4.8.ebuild b/media-video/ffmpeg/ffmpeg-0.4.8.ebuild
new file mode 100644
index 000000000000..16065039e7a3
--- /dev/null
+++ b/media-video/ffmpeg/ffmpeg-0.4.8.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.4.8.ebuild,v 1.1 2003/10/18 19:30:27 iggy Exp $
+
+inherit eutils
+
+DESCRIPTION="Complete solution to record, convert and stream audio and video. Includes libavcodec."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://ffmpeg.sourceforge.net/"
+
+IUSE="mmx encode oggvorbis doc faad dvd static sdl imlib truetype"
+
+inherit flag-o-matic
+filter-flags "-fforce-addr -fPIC"
+# fixes bug #16281
+use alpha && append-flags "-fPIC"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND="encode? ( >=media-sound/lame-3.92 )
+ oggvorbis? ( >=media-libs/libvorbis-1.0-r1 )
+ doc? ( >=app-text/texi2html-1.64 )
+ faad? ( >=media-libs/faad2-1.1 )
+ dvd? ( >=media-libs/a52dec-0.7.4 )
+ sdl? ( >=media-libs/libsdl-1.2.5 )
+ imlib? ( >=media-libs/imlib2-1.0.6 )
+ truetype? ( >=media-libs/freetype-2.1.2 )"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S}
+
+ # for some reason it tries to #include <X11/Xlib.h>,b ut doesn't use it
+ cd ${S}
+ sed -i s:\#define\ HAVE_X11:\#define\ HAVE_LINUX: ffplay.c
+
+}
+
+src_compile() {
+ local myconf
+ myconf="${myconf} --disable-opts --enable-pp"
+ use mmx || myconf="${myconf} --disable-mmx"
+ use encode && myconf="${myconf} --enable-mp3lame"
+ use oggvorbis && myconf="${myconf} --enable-vorbis"
+ use faad && myconf="${myconf} --enable-faad --enable-faadbin"
+ use dvd && myconf="${myconf} --enable-a52 --enable-a52bin"
+ use static || myconf="${myconf} --enable-shared"
+ use sdl || myconf="${myconf} --disable-ffplay"
+ use debug || myconf="${myconf} --disable-debug"
+
+ ./configure ${myconf} \
+ --prefix=/usr || die "./configure failed."
+ make || die "make failed."
+ use doc && make -C doc all
+}
+
+src_install() {
+
+ make \
+ DESTDIR=${D} \
+ prefix=${D}/usr \
+ bindir=${D}/usr/bin \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+# emake DESTDIR=${D} \
+# MANDIR=${D}/man install || die "Installation failed."
+ dosym /usr/bin/ffmpeg /usr/bin/ffplay
+ dosym /usr/lib/libavcodec-${PV}.so /usr/lib/libavcodec.so
+
+ dodoc COPYING CREDITS Changelog INSTALL README
+ docinto doc
+ dodoc doc/TODO doc/*.html doc/*.texi
+ insinto /etc
+ doins doc/ffserver.conf
+}
diff --git a/media-video/ffmpeg/files/digest-ffmpeg-0.4.8 b/media-video/ffmpeg/files/digest-ffmpeg-0.4.8
new file mode 100644
index 000000000000..fec778f232f1
--- /dev/null
+++ b/media-video/ffmpeg/files/digest-ffmpeg-0.4.8
@@ -0,0 +1 @@
+MD5 e00d47614ba1afd99ad2ea387e782dd9 ffmpeg-0.4.8.tar.gz 1352874