summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-02-06 10:09:20 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-02-06 10:09:20 +0000
commita96e87d6a026679ff952649d3d83122968ce9584 (patch)
tree3ac932fa04c476212b9a3d89824acb026844c369 /media-video
parenttidy (diff)
downloadgentoo-2-a96e87d6a026679ff952649d3d83122968ce9584.tar.gz
gentoo-2-a96e87d6a026679ff952649d3d83122968ce9584.tar.bz2
gentoo-2-a96e87d6a026679ff952649d3d83122968ce9584.zip
fix build with glibc 2.20, patch from upstream, bug #529162
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/dvdauthor/ChangeLog8
-rw-r--r--media-video/dvdauthor/dvdauthor-0.7.1.ebuild5
-rw-r--r--media-video/dvdauthor/files/dvdauthor-0.7.1-glibc220.patch162
3 files changed, 171 insertions, 4 deletions
diff --git a/media-video/dvdauthor/ChangeLog b/media-video/dvdauthor/ChangeLog
index 61bb83b8903a..2c90813e8554 100644
--- a/media-video/dvdauthor/ChangeLog
+++ b/media-video/dvdauthor/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/dvdauthor
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvdauthor/ChangeLog,v 1.51 2013/04/10 14:16:02 ssuominen Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdauthor/ChangeLog,v 1.52 2015/02/06 10:09:20 aballier Exp $
+
+ 06 Feb 2015; Alexis Ballier <aballier@gentoo.org> dvdauthor-0.7.1.ebuild,
+ +files/dvdauthor-0.7.1-glibc220.patch:
+ fix build with glibc 2.20, patch from upstream, bug #529162
10 Apr 2013; Samuli Suominen <ssuominen@gentoo.org> dvdauthor-0.7.1.ebuild:
Fix building with USE="graphicsmagick" wrt #459976 by Erik Zeek, Andrew John
diff --git a/media-video/dvdauthor/dvdauthor-0.7.1.ebuild b/media-video/dvdauthor/dvdauthor-0.7.1.ebuild
index 2331dd08ebc7..213acff4c973 100644
--- a/media-video/dvdauthor/dvdauthor-0.7.1.ebuild
+++ b/media-video/dvdauthor/dvdauthor-0.7.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvdauthor/dvdauthor-0.7.1.ebuild,v 1.2 2013/04/10 14:16:02 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdauthor/dvdauthor-0.7.1.ebuild,v 1.3 2015/02/06 10:09:20 aballier Exp $
EAPI=5
inherit eutils flag-o-matic toolchain-funcs
@@ -29,6 +29,7 @@ S=${WORKDIR}/${PN}
DOCS=( AUTHORS ChangeLog README TODO )
src_prepare() {
+ epatch "${FILESDIR}/${P}-glibc220.patch"
use graphicsmagick && \
sed -i -e 's:ExportImagePixels:dIsAbLeAuToMaGiC&:' configure
}
diff --git a/media-video/dvdauthor/files/dvdauthor-0.7.1-glibc220.patch b/media-video/dvdauthor/files/dvdauthor-0.7.1-glibc220.patch
new file mode 100644
index 000000000000..880c63aa79d7
--- /dev/null
+++ b/media-video/dvdauthor/files/dvdauthor-0.7.1-glibc220.patch
@@ -0,0 +1,162 @@
+From 5b890b47aaf6f692c876faf435e6bf8990e7a45d Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ville=20Skytt=C3=A4?= <ville.skytta@iki.fi>
+Date: Sat, 19 Jul 2014 21:06:58 +0300
+Subject: [PATCH] compat.h needs stuff from config.h so include it there
+
+This was brought up by dvdvml.* not including it and thus causing a
+build failure on Fedora (22) devel. While at it, uninclude config.h
+from files where it was included just for compat.h reasons.
+---
+ src/compat.h | 2 ++
+ src/conffile.c | 1 -
+ src/dvdauthor.c | 2 --
+ src/dvdcompile.c | 2 --
+ src/dvdpgc.c | 1 -
+ src/dvdunauthor.c | 2 --
+ src/dvduncompile.c | 1 -
+ src/dvdvob.c | 2 --
+ src/readxml.c | 2 --
+ src/spuunmux.c | 1 -
+ src/subgen-encode.c | 2 --
+ 11 files changed, 2 insertions(+), 16 deletions(-)
+
+diff --git a/src/compat.h b/src/compat.h
+index 126dcd7..93de081 100644
+--- a/src/compat.h
++++ b/src/compat.h
+@@ -1,6 +1,8 @@
+ // basic headers
+ #define _GNU_SOURCE /* really just for strndup */
+
++#include "config.h"
++
+ #ifdef HAVE_STDBOOL_H
+ # include <stdbool.h>
+ #else
+diff --git a/src/conffile.c b/src/conffile.c
+index cab661a..36ded07 100644
+--- a/src/conffile.c
++++ b/src/conffile.c
+@@ -21,7 +21,6 @@
+ * MA 02110-1301 USA.
+ */
+
+-#include "config.h"
+ #include "compat.h"
+ #include <errno.h>
+ #include "conffile.h"
+diff --git a/src/dvdauthor.c b/src/dvdauthor.c
+index d591d68..4860258 100644
+--- a/src/dvdauthor.c
++++ b/src/dvdauthor.c
+@@ -20,8 +20,6 @@
+ * MA 02110-1301 USA.
+ */
+
+-#include "config.h"
+-
+ #include "compat.h"
+
+ #include <sys/types.h>
+diff --git a/src/dvdcompile.c b/src/dvdcompile.c
+index fd232b6..47f13e5 100644
+--- a/src/dvdcompile.c
++++ b/src/dvdcompile.c
+@@ -20,8 +20,6 @@
+ * MA 02110-1301 USA.
+ */
+
+-#include "config.h"
+-
+ #include "compat.h"
+ #include <assert.h>
+
+diff --git a/src/dvdpgc.c b/src/dvdpgc.c
+index e0adc61..cf6eb04 100644
+--- a/src/dvdpgc.c
++++ b/src/dvdpgc.c
+@@ -20,7 +20,6 @@
+ * MA 02110-1301 USA.
+ */
+
+-#include "config.h"
+ #include "compat.h"
+ #include <errno.h>
+ #include <assert.h>
+diff --git a/src/dvdunauthor.c b/src/dvdunauthor.c
+index ccd422f..f988cdf 100644
+--- a/src/dvdunauthor.c
++++ b/src/dvdunauthor.c
+@@ -23,8 +23,6 @@
+ * MA 02110-1301 USA.
+ */
+
+-#include "config.h"
+-
+ #include "compat.h"
+
+ #include <ctype.h>
+diff --git a/src/dvduncompile.c b/src/dvduncompile.c
+index 0c5eaf1..a064011 100644
+--- a/src/dvduncompile.c
++++ b/src/dvduncompile.c
+@@ -22,7 +22,6 @@
+ * MA 02110-1301 USA.
+ */
+
+-#include "config.h"
+ #include "compat.h"
+
+ #include <stdio.h>
+diff --git a/src/dvdvob.c b/src/dvdvob.c
+index 2d7e2b8..2146689 100644
+--- a/src/dvdvob.c
++++ b/src/dvdvob.c
+@@ -20,8 +20,6 @@
+ * MA 02110-1301 USA.
+ */
+
+-#include "config.h"
+-
+ #include "compat.h"
+
+ #include <assert.h>
+diff --git a/src/readxml.c b/src/readxml.c
+index 61ff0a1..3b83f07 100644
+--- a/src/readxml.c
++++ b/src/readxml.c
+@@ -20,8 +20,6 @@
+ * MA 02110-1301 USA.
+ */
+
+-#include "config.h"
+-
+ #include "compat.h"
+
+ #include <assert.h>
+diff --git a/src/spuunmux.c b/src/spuunmux.c
+index 1981e41..94fcb10 100644
+--- a/src/spuunmux.c
++++ b/src/spuunmux.c
+@@ -31,7 +31,6 @@
+ * MA 02110-1301 USA.
+ */
+
+-#include "config.h"
+ #include "compat.h"
+
+ #include <fcntl.h>
+diff --git a/src/subgen-encode.c b/src/subgen-encode.c
+index 53ed4b2..962e902 100644
+--- a/src/subgen-encode.c
++++ b/src/subgen-encode.c
+@@ -21,8 +21,6 @@
+ * MA 02110-1301 USA.
+ */
+
+-#include "config.h"
+-
+ #include "compat.h"
+
+ #include <assert.h>
+ \ No newline at end of file