summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-21 12:45:38 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-21 12:45:38 +0000
commit119f385ee90c7fc59fe42d1a3657d74d70a18344 (patch)
tree30a7ebd2f71ae9083992e22ba7eeda781dc657a9 /media-video
parentPatch configure.in _before_ running eautoreconf or it'll cause maintainer-mod... (diff)
downloadgentoo-2-119f385ee90c7fc59fe42d1a3657d74d70a18344.tar.gz
gentoo-2-119f385ee90c7fc59fe42d1a3657d74d70a18344.tar.bz2
gentoo-2-119f385ee90c7fc59fe42d1a3657d74d70a18344.zip
Handle broken Altivec support differently.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpegthumbnailer/ChangeLog7
-rw-r--r--media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.3.0.ebuild32
-rw-r--r--media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.0.ebuild12
-rw-r--r--media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.1.ebuild13
4 files changed, 24 insertions, 40 deletions
diff --git a/media-video/ffmpegthumbnailer/ChangeLog b/media-video/ffmpegthumbnailer/ChangeLog
index aac51e081a39..a34c9ffbeb16 100644
--- a/media-video/ffmpegthumbnailer/ChangeLog
+++ b/media-video/ffmpegthumbnailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/ffmpegthumbnailer
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.72 2009/05/21 01:41:51 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.73 2009/05/21 12:45:38 ssuominen Exp $
+
+ 21 May 2009; Samuli Suominen <ssuominen@gentoo.org>
+ -ffmpegthumbnailer-1.3.0.ebuild, ffmpegthumbnailer-1.5.0.ebuild,
+ ffmpegthumbnailer-1.5.1.ebuild:
+ Handle broken Altivec support differently.
21 May 2009; Jeroen Roovers <jer@gentoo.org>
ffmpegthumbnailer-1.5.0.ebuild:
diff --git a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.3.0.ebuild b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.3.0.ebuild
deleted file mode 100644
index 51a60707bd44..000000000000
--- a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.3.0.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.3.0.ebuild,v 1.6 2008/12/17 14:40:24 beandog Exp $
-
-inherit multilib
-
-DESCRIPTION="Lightweight video thumbnailer that can be used by file managers"
-HOMEPAGE="http://code.google.com/p/ffmpegthumbnailer"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE=""
-
-RDEPEND="media-libs/libpng
- media-libs/jpeg
- >=media-video/ffmpeg-0.4.9_p20070330"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_compile() {
- econf --disable-dependency-tracking \
- --disable-static
- emake || die "emake failed."
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
- dodoc AUTHORS ChangeLog README TODO
- rm -f "${D}"/usr/$(get_libdir)/libffmpegthumbnailer.la || die "removal failed"
-}
diff --git a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.0.ebuild b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.0.ebuild
index 275b861da97b..c594279c6421 100644
--- a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.0.ebuild
+++ b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.0.ebuild,v 1.9 2009/05/21 01:41:51 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.0.ebuild,v 1.10 2009/05/21 12:45:38 ssuominen Exp $
EAPI=2
@@ -11,11 +11,11 @@ SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE=""
+IUSE="altivec"
RDEPEND="media-libs/libpng
media-libs/jpeg
- >=media-video/ffmpeg-0.4.9_p20070330[-altivec]"
+ >=media-video/ffmpeg-0.4.9_p20070330[altivec?]"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
@@ -28,3 +28,9 @@ src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog README TODO
}
+
+pkg_postinst() {
+ if use altivec; then
+ ewarn "Altivec support is known to be broken wrt bug #252641."
+ fi
+}
diff --git a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.1.ebuild b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.1.ebuild
index b6a2dfa838dd..f4730ed17a12 100644
--- a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.1.ebuild
+++ b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.1.ebuild,v 1.2 2009/05/20 13:04:55 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.5.1.ebuild,v 1.3 2009/05/21 12:45:38 ssuominen Exp $
EAPI=2
@@ -11,10 +11,9 @@ SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="jpeg png"
+IUSE="altivec jpeg png"
-# See bug 252641, please try to remove the -altivec soon as possible.
-RDEPEND=">=media-video/ffmpeg-0.5[-altivec]
+RDEPEND=">=media-video/ffmpeg-0.5[altivec?]
png? ( media-libs/libpng )
jpeg? ( media-libs/jpeg )"
DEPEND="${RDEPEND}
@@ -31,3 +30,9 @@ src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog README
}
+
+pkg_postinst() {
+ if use altivec; then
+ ewarn "Altivec support is known to be broken wrt bug #252641."
+ fi
+}