summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-11-19 19:47:44 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-11-19 19:47:44 +0000
commit19d486373e93f93816e3ca59d2ac346d3c4b2345 (patch)
tree097932be6cd9e69c002b4d8db8a9c92c02118c4b /media-video/vamps
parentBlock httpclient (http-access2 replacement). (diff)
downloadgentoo-2-19d486373e93f93816e3ca59d2ac346d3c4b2345.tar.gz
gentoo-2-19d486373e93f93816e3ca59d2ac346d3c4b2345.tar.bz2
gentoo-2-19d486373e93f93816e3ca59d2ac346d3c4b2345.zip
add a patch that fixes a bug that would give invalid premature eof errors, thanks to Daniel Pielmeier <daniel.pielmeier@googlemail.com>, bug #175504
(Portage version: 2.1.3.19)
Diffstat (limited to 'media-video/vamps')
-rw-r--r--media-video/vamps/ChangeLog9
-rw-r--r--media-video/vamps/files/digest-vamps-0.99.2-r13
-rw-r--r--media-video/vamps/files/vamps-0.99.2-premature-eof.patch46
-rw-r--r--media-video/vamps/vamps-0.99.2-r1.ebuild31
4 files changed, 88 insertions, 1 deletions
diff --git a/media-video/vamps/ChangeLog b/media-video/vamps/ChangeLog
index 20226b3b2f5a..512e6809f9f5 100644
--- a/media-video/vamps/ChangeLog
+++ b/media-video/vamps/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/vamps
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vamps/ChangeLog,v 1.19 2007/11/19 19:22:28 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vamps/ChangeLog,v 1.20 2007/11/19 19:47:44 aballier Exp $
+
+*vamps-0.99.2-r1 (19 Nov 2007)
+
+ 19 Nov 2007; Alexis Ballier <aballier@gentoo.org>
+ +files/vamps-0.99.2-premature-eof.patch, +vamps-0.99.2-r1.ebuild:
+ add a patch that fixes a bug that would give invalid premature eof errors,
+ thanks to Daniel Pielmeier <daniel.pielmeier@googlemail.com>, bug #175504
19 Nov 2007; Alexis Ballier <aballier@gentoo.org>
-files/vamps-0.95-amd64.patch, -vamps-0.95.ebuild:
diff --git a/media-video/vamps/files/digest-vamps-0.99.2-r1 b/media-video/vamps/files/digest-vamps-0.99.2-r1
new file mode 100644
index 000000000000..2607b4916eb3
--- /dev/null
+++ b/media-video/vamps/files/digest-vamps-0.99.2-r1
@@ -0,0 +1,3 @@
+MD5 7d438185a2ae95ebb245472d9fa47d06 vamps-0.99.2.tar.gz 47062
+RMD160 1b0d34ba3b583d9d35fc4cee30014c704e64a36d vamps-0.99.2.tar.gz 47062
+SHA256 9bac71441db55c04a642c786d6427efdb65aa27f4b1719ffa34ebc3869572694 vamps-0.99.2.tar.gz 47062
diff --git a/media-video/vamps/files/vamps-0.99.2-premature-eof.patch b/media-video/vamps/files/vamps-0.99.2-premature-eof.patch
new file mode 100644
index 000000000000..48340498d9bc
--- /dev/null
+++ b/media-video/vamps/files/vamps-0.99.2-premature-eof.patch
@@ -0,0 +1,46 @@
+--- vamps-0.99.2/vamps/vamps.c.orig 2006-04-15 08:00:07.000000000 -0400
++++ vamps-0.99.2/vamps/vamps.c 2007-01-26 06:54:27.000000000 -0500
+@@ -18,6 +18,9 @@
+ //
+ // Revision history (latest first):
+ //
++// 2007/01/26: V0.99.3: Fixed assumptions in lock() which do not hold for pipes.
++// This cures the "Premature EOF" problem.
++//
+ // 2006/04/15: V0.99.2: Fixed some signed/unsigned issues which caused compiler
+ // warnings on some platforms. No funtional changes.
+ //
+@@ -396,13 +399,24 @@
+ rhwp = rptr + avail;
+ }
+
+- n = read (0, rhwp, RBUF_SIZE - avail);
+-
+- if (n % SECT_SIZE)
+- fatal ("Premature EOF");
+-
+- rhwp += n;
+- bytes_read += n;
++ while (avail < size)
++ {
++ // read; reads from an open pipe will return any non-zero amount of data
++ // (not necessarily the amount we wanted!)
++ n = read (0, rhwp, RBUF_SIZE - avail);
++ if (!n)
++ {
++ if (avail % SECT_SIZE)
++ // we got an EOF and only a partial sector
++ fatal ("Premature EOF");
++ break;
++ }
++ else if (n == -1)
++ fatal ("Read from stdin: %s", strerror (errno));
++ rhwp += n;
++ bytes_read += n;
++ avail += n;
++ }
+
+ return !n;
+ }
+
+
diff --git a/media-video/vamps/vamps-0.99.2-r1.ebuild b/media-video/vamps/vamps-0.99.2-r1.ebuild
new file mode 100644
index 000000000000..ead00a119bba
--- /dev/null
+++ b/media-video/vamps/vamps-0.99.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/vamps/vamps-0.99.2-r1.ebuild,v 1.1 2007/11/19 19:47:44 aballier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Very fast requantisizing tool for backup DVDs"
+HOMEPAGE="http://vamps.sourceforge.net/"
+SRC_URI="mirror://sourceforge/vamps/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+DEPEND=">=media-libs/libdvdread-0.9.4"
+
+RDEPEND="${DEPEND}
+ >=media-video/dvdauthor-0.6.10"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/${P}-premature-eof.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin vamps/vamps play_cell/play_cell || die "install failed"
+}