summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-07-03 21:57:24 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-07-03 21:57:24 +0000
commit1d1738dabe80f243db105efbe5e5bc6ce8c34f51 (patch)
treea6dacfd92efce1cf84e1c599ec610a8cb9019e4c /media-video/transcode
parentRemove old ebuilds. (diff)
downloadgentoo-2-1d1738dabe80f243db105efbe5e5bc6ce8c34f51.tar.gz
gentoo-2-1d1738dabe80f243db105efbe5e5bc6ce8c34f51.tar.bz2
gentoo-2-1d1738dabe80f243db105efbe5e5bc6ce8c34f51.zip
Fix to build with libmpeg3 1.7 and recent ffmpegs, closing bug #183965 and bug #184014
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'media-video/transcode')
-rw-r--r--media-video/transcode/ChangeLog10
-rw-r--r--media-video/transcode/files/transcode-1.0.3-ffmpeg_codecs_are_not_in_public_api.patch14
-rw-r--r--media-video/transcode/files/transcode-1.0.3-libmpeg3-1.7.patch (renamed from media-video/transcode/files/transcode-1.0.3_rc2_p20070310-libmpeg3.patch)8
-rw-r--r--media-video/transcode/transcode-1.0.3.ebuild4
4 files changed, 30 insertions, 6 deletions
diff --git a/media-video/transcode/ChangeLog b/media-video/transcode/ChangeLog
index 7f4c071004e8..4a2ce8ab2b3c 100644
--- a/media-video/transcode/ChangeLog
+++ b/media-video/transcode/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-video/transcode
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/ChangeLog,v 1.178 2007/05/31 20:55:21 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/ChangeLog,v 1.179 2007/07/03 21:57:24 aballier Exp $
+
+ 03 Jul 2007; Alexis Ballier <aballier@gentoo.org>
+ +files/transcode-1.0.3-ffmpeg_codecs_are_not_in_public_api.patch,
+ +files/transcode-1.0.3-libmpeg3-1.7.patch,
+ -files/transcode-1.0.3_rc2_p20070310-libmpeg3.patch,
+ transcode-1.0.3.ebuild:
+ Fix to build with libmpeg3 1.7 and recent ffmpegs, closing bug #183965 and
+ bug #184014
31 May 2007; Markus Rothe <corsair@gentoo.org> transcode-1.0.3.ebuild:
Do not break on ppc64 any more; use patch from previous versions
diff --git a/media-video/transcode/files/transcode-1.0.3-ffmpeg_codecs_are_not_in_public_api.patch b/media-video/transcode/files/transcode-1.0.3-ffmpeg_codecs_are_not_in_public_api.patch
new file mode 100644
index 000000000000..1d5ef6674066
--- /dev/null
+++ b/media-video/transcode/files/transcode-1.0.3-ffmpeg_codecs_are_not_in_public_api.patch
@@ -0,0 +1,14 @@
+Index: transcode-1.0.3/export/aud_aux.c
+===================================================================
+--- transcode-1.0.3.orig/export/aud_aux.c
++++ transcode-1.0.3/export/aud_aux.c
+@@ -361,8 +361,7 @@ static int audio_init_ffmpeg(vob_t *vob,
+
+ pthread_mutex_lock(&init_avcodec_lock);
+ avcodec_init();
+- register_avcodec(&ac3_encoder);
+- register_avcodec(&mp2_encoder);
++ avcodec_register_all();
+ pthread_mutex_unlock(&init_avcodec_lock);
+
+ switch (o_codec) {
diff --git a/media-video/transcode/files/transcode-1.0.3_rc2_p20070310-libmpeg3.patch b/media-video/transcode/files/transcode-1.0.3-libmpeg3-1.7.patch
index a66681d31b33..6c02cd0e08ab 100644
--- a/media-video/transcode/files/transcode-1.0.3_rc2_p20070310-libmpeg3.patch
+++ b/media-video/transcode/files/transcode-1.0.3-libmpeg3-1.7.patch
@@ -1,7 +1,7 @@
-Index: transcode/import/import_mpeg3.c
+Index: transcode-1.0.3/import/import_mpeg3.c
===================================================================
---- transcode.orig/import/import_mpeg3.c
-+++ transcode/import/import_mpeg3.c
+--- transcode-1.0.3.orig/import/import_mpeg3.c
++++ transcode-1.0.3/import/import_mpeg3.c
@@ -69,6 +69,9 @@ MOD_open
{
@@ -19,7 +19,7 @@ Index: transcode/import/import_mpeg3.c
+#if MPEG3_MINOR < 7
if((file = mpeg3_open(vob->video_in_file))==NULL) {
+#else
-+ if(((file = mpeg3_open(vob->video_in_file, &mpeg3_return_value))==NULL) || (mpeg3_return_value != 0)) {
++ if(((file = mpeg3_open(vob->video_in_file, &mpeg3_return_value))==NULL) || (mpeg3_return_value != 0)) {
+#endif
fprintf(stderr, "open file failed\n");
return(TC_IMPORT_ERROR);
diff --git a/media-video/transcode/transcode-1.0.3.ebuild b/media-video/transcode/transcode-1.0.3.ebuild
index 235d42905a6c..836cb2f6619c 100644
--- a/media-video/transcode/transcode-1.0.3.ebuild
+++ b/media-video/transcode/transcode-1.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/transcode-1.0.3.ebuild,v 1.7 2007/05/31 20:55:21 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/transcode-1.0.3.ebuild,v 1.8 2007/07/03 21:57:24 aballier Exp $
WANT_AUTOMAKE=latest
WANT_AUTOCONF=latest
@@ -52,6 +52,8 @@ src_unpack() {
cd "${S}"
epatch "${DISTDIR}/${PN}-types.patch.bz2"
+ epatch "${FILESDIR}/${P}-libmpeg3-1.7.patch"
+ epatch "${FILESDIR}/${P}-ffmpeg_codecs_are_not_in_public_api.patch"
dosed -i -e "s:\$(datadir)/doc/transcode:\$(datadir)/doc/${PF}:" \
"${S}"/Makefile.am "${S}"/docs/Makefile.am "${S}"/docs/html/Makefile.am \