summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-10-08 23:23:13 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-10-08 23:23:13 +0000
commit9d7c551ff249a05128d9cf9ce9836cfbad559ac3 (patch)
treeb488e74bb31507fad553e910d257c22a09e8cb1c /media-video/subtitleeditor
parentVersion bump, upstream included SFTP fixes (diff)
downloadgentoo-2-9d7c551ff249a05128d9cf9ce9836cfbad559ac3.tar.gz
gentoo-2-9d7c551ff249a05128d9cf9ce9836cfbad559ac3.tar.bz2
gentoo-2-9d7c551ff249a05128d9cf9ce9836cfbad559ac3.zip
Clean up old revisions.
(Portage version: 2.2_rc91/cvs/Linux x86_64)
Diffstat (limited to 'media-video/subtitleeditor')
-rw-r--r--media-video/subtitleeditor/ChangeLog7
-rw-r--r--media-video/subtitleeditor/files/subtitleeditor-0.36.0-r681.patch11
-rw-r--r--media-video/subtitleeditor/subtitleeditor-0.36.0.ebuild71
-rw-r--r--media-video/subtitleeditor/subtitleeditor-0.36.1.ebuild69
4 files changed, 6 insertions, 152 deletions
diff --git a/media-video/subtitleeditor/ChangeLog b/media-video/subtitleeditor/ChangeLog
index 5628d934658f..07aafab2002c 100644
--- a/media-video/subtitleeditor/ChangeLog
+++ b/media-video/subtitleeditor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/subtitleeditor
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/ChangeLog,v 1.9 2010/08/12 21:58:38 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/ChangeLog,v 1.10 2010/10/08 23:23:13 eva Exp $
+
+ 08 Oct 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ -subtitleeditor-0.36.0.ebuild, -files/subtitleeditor-0.36.0-r681.patch,
+ -subtitleeditor-0.36.1.ebuild:
+ Clean up old revisions.
*subtitleeditor-0.37.1 (12 Aug 2010)
diff --git a/media-video/subtitleeditor/files/subtitleeditor-0.36.0-r681.patch b/media-video/subtitleeditor/files/subtitleeditor-0.36.0-r681.patch
deleted file mode 100644
index 8b3db12769b0..000000000000
--- a/media-video/subtitleeditor/files/subtitleeditor-0.36.0-r681.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/we/waveformrenderergl.cc (revisione 680)
-+++ src/we/waveformrenderergl.cc (revisione 681)
-@@ -722,7 +722,7 @@
- int text_width = get_text_width("0:00:00");
-
- float margin = text_width + text_width * 0.5;
-- while(get_pos_by_time(sec_1) < marker)
-+ while(get_pos_by_time(sec_1) < margin)
- {
- // for a sufficiently long duration sec_* will overflow before
- // the loop terminates. check the largest of them.
diff --git a/media-video/subtitleeditor/subtitleeditor-0.36.0.ebuild b/media-video/subtitleeditor/subtitleeditor-0.36.0.ebuild
deleted file mode 100644
index 63040f6d898f..000000000000
--- a/media-video/subtitleeditor/subtitleeditor-0.36.0.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/subtitleeditor-0.36.0.ebuild,v 1.2 2010/03/11 13:09:12 flameeyes Exp $
-
-EAPI="2"
-
-inherit eutils versionator flag-o-matic
-
-DESCRIPTION="GTK+2 subtitle editing tool."
-HOMEPAGE="http://home.gna.org/subtitleeditor/"
-SRC_URI="http://download.gna.org/${PN}/$(get_version_component_range 1-2)/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="debug nls opengl"
-
-RDEPEND="
- >=dev-cpp/gtkmm-2.14
- >=dev-cpp/glibmm-2.16.3
- >=dev-cpp/libxmlpp-2.20
- >=app-text/enchant-1.4.0
- opengl? ( >=dev-cpp/gtkglextmm-1.2 )
- >=dev-cpp/gstreamermm-0.10.4
- >=media-libs/gst-plugins-good-0.10
- >=media-plugins/gst-plugins-meta-0.10-r2:0.10
- >=media-plugins/gst-plugins-pango-0.10
- >=media-plugins/gst-plugins-xvideo-0.10
- app-text/iso-codes
-"
-# gst-plugins-pango needed for text overlay
-# gst-plugins-xvideo needed for video output
-
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.40
- dev-util/pkgconfig"
-
-src_prepare() {
- # Fix intltoolize broken file, see upstream #577133
- sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in || die "sed failed"
-
- # bug #308937
- epatch "${FILESDIR}"/${P}-r681.patch
-}
-
-src_configure() {
- export GST_REGISTRY="${T}/home/registry.cache.xml"
-
- # Avoid using --enable-debg as it mocks with CXXFLAGS and LDFLAGS
- use debug && append-flags -DDEBUG
-
- econf \
- --disable-debug \
- $(use_enable nls) \
- $(use_enable opengl gl)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
-
- # plugins are loaded without the help of libtool files
- find . -name '*.la' -delete
-}
-
-pkg_postinst() {
- ewarn
- ewarn "If ${PN} doesn't play some video format, please check your"
- ewarn "USE flags on media-plugins/gst-plugins-meta"
- ewarn
-}
diff --git a/media-video/subtitleeditor/subtitleeditor-0.36.1.ebuild b/media-video/subtitleeditor/subtitleeditor-0.36.1.ebuild
deleted file mode 100644
index c3f3728ca901..000000000000
--- a/media-video/subtitleeditor/subtitleeditor-0.36.1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/subtitleeditor-0.36.1.ebuild,v 1.2 2010/04/21 18:04:19 fauli Exp $
-
-EAPI="2"
-
-inherit eutils versionator flag-o-matic
-
-DESCRIPTION="GTK+2 subtitle editing tool."
-HOMEPAGE="http://home.gna.org/subtitleeditor/"
-SRC_URI="http://download.gna.org/${PN}/$(get_version_component_range 1-2)/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug nls opengl"
-
-RDEPEND="
- app-text/iso-codes
- >=dev-cpp/gtkmm-2.14
- >=dev-cpp/glibmm-2.16.3
- >=dev-cpp/libxmlpp-2.20
- >=app-text/enchant-1.4
- >=dev-cpp/gstreamermm-0.10.4
- >=media-libs/gst-plugins-good-0.10
- >=media-plugins/gst-plugins-meta-0.10-r2:0.10
- >=media-plugins/gst-plugins-pango-0.10
- >=media-plugins/gst-plugins-xvideo-0.10
- opengl? ( >=dev-cpp/gtkglextmm-1.2 )
-"
-# gst-plugins-pango needed for text overlay
-# gst-plugins-xvideo needed for video output
-
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.40
- dev-util/pkgconfig"
-
-src_prepare() {
- # Fix intltoolize broken file, see upstream #577133
- sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in \
- || die "sed failed"
-}
-
-src_configure() {
- export GST_REGISTRY="${T}/home/registry.cache.xml"
-
- # Avoid using --enable-debug as it mocks with CXXFLAGS and LDFLAGS
- use debug && append-flags -DDEBUG
-
- econf \
- --disable-debug \
- $(use_enable nls) \
- $(use_enable opengl gl)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
-
- # plugins are loaded without the help of libtool files
- find "${D}" -name '*.la' -delete || die "failed to remove *.la files"
-}
-
-pkg_postinst() {
- ewarn
- ewarn "If ${PN} doesn't play some video format, please check your"
- ewarn "USE flags on media-plugins/gst-plugins-meta"
- ewarn
-}