summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-11-21 22:25:59 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-11-21 22:25:59 +0000
commit44eb9ce50a7ac02f4eed010492cee47fc6254824 (patch)
tree9419aeb1713ddc5cd345ea90b339aee6d69fda05 /media-video/subtitleeditor
parentRespect PKG_CONFIG env var when building. (diff)
downloadgentoo-2-44eb9ce50a7ac02f4eed010492cee47fc6254824.tar.gz
gentoo-2-44eb9ce50a7ac02f4eed010492cee47fc6254824.tar.bz2
gentoo-2-44eb9ce50a7ac02f4eed010492cee47fc6254824.zip
Version bump, bug #387323. Thanks to Nikoli <nikoli@lavabit.com> for reporting.
(Portage version: 2.2.0_alpha75/cvs/Linux x86_64)
Diffstat (limited to 'media-video/subtitleeditor')
-rw-r--r--media-video/subtitleeditor/ChangeLog9
-rw-r--r--media-video/subtitleeditor/subtitleeditor-0.39.0.ebuild63
2 files changed, 71 insertions, 1 deletions
diff --git a/media-video/subtitleeditor/ChangeLog b/media-video/subtitleeditor/ChangeLog
index aec12adba01c..8d9fb130ce8c 100644
--- a/media-video/subtitleeditor/ChangeLog
+++ b/media-video/subtitleeditor/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/subtitleeditor
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/ChangeLog,v 1.12 2011/03/29 06:04:16 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/ChangeLog,v 1.13 2011/11/21 22:25:59 eva Exp $
+
+*subtitleeditor-0.39.0 (21 Nov 2011)
+
+ 21 Nov 2011; Gilles Dartiguelongue <eva@gentoo.org>
+ +subtitleeditor-0.39.0.ebuild:
+ Version bump, bug #387323. Thanks to Nikoli <nikoli@lavabit.com> for
+ reporting.
29 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
subtitleeditor-0.37.1.ebuild, subtitleeditor-0.38.0.ebuild:
diff --git a/media-video/subtitleeditor/subtitleeditor-0.39.0.ebuild b/media-video/subtitleeditor/subtitleeditor-0.39.0.ebuild
new file mode 100644
index 000000000000..01e259f11098
--- /dev/null
+++ b/media-video/subtitleeditor/subtitleeditor-0.39.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/subtitleeditor-0.39.0.ebuild,v 1.1 2011/11/21 22:25:59 eva Exp $
+
+EAPI="2"
+
+inherit eutils versionator flag-o-matic
+
+DESCRIPTION="GTK+2 subtitle editing tool."
+HOMEPAGE="http://home.gna.org/subtitleeditor/"
+SRC_URI="http://download.gna.org/${PN}/$(get_version_component_range 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug nls opengl"
+
+RDEPEND="
+ app-text/iso-codes
+ >=dev-cpp/gtkmm-2.14:2.4
+ >=dev-cpp/glibmm-2.16.3:2
+ >=dev-cpp/libxmlpp-2.20:2.6
+ >=app-text/enchant-1.4
+ >=dev-cpp/gstreamermm-0.10.4
+ >=media-libs/gst-plugins-good-0.10:0.10
+ >=media-plugins/gst-plugins-meta-0.10-r2:0.10
+ >=media-plugins/gst-plugins-pango-0.10:0.10
+ >=media-plugins/gst-plugins-xvideo-0.10:0.10
+ opengl? ( >=dev-cpp/gtkglextmm-1.2 )
+"
+# gst-plugins-pango needed for text overlay
+# gst-plugins-xvideo needed for video output
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig"
+
+src_configure() {
+ export GST_REGISTRY="${T}/home/registry.cache.xml"
+
+ # Avoid using --enable-debug as it mocks with CXXFLAGS and LDFLAGS
+ use debug && append-flags -DDEBUG
+
+ econf \
+ --disable-debug \
+ $(use_enable nls) \
+ $(use_enable opengl gl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+
+ # plugins are loaded without the help of libtool files
+ find "${D}" -name '*.la' -delete || die "failed to remove *.la files"
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If ${PN} doesn't play some video format, please check your"
+ ewarn "USE flags on media-plugins/gst-plugins-meta"
+ ewarn
+}