summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2007-01-06 21:31:47 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2007-01-06 21:31:47 +0000
commitda0a5a75d5bb3e4a0e21ffc91746c8a7dad04b10 (patch)
tree4a9c5bc946c42967725d9610484c8d023b15a969 /media-video/qdvdauthor
parentAdded qt3 to inherit, fixed bug #140345. Some cleanups. (diff)
downloadgentoo-2-da0a5a75d5bb3e4a0e21ffc91746c8a7dad04b10.tar.gz
gentoo-2-da0a5a75d5bb3e4a0e21ffc91746c8a7dad04b10.tar.bz2
gentoo-2-da0a5a75d5bb3e4a0e21ffc91746c8a7dad04b10.zip
version bump, solving bug #159901.
(Portage version: 2.1.2_rc4-r5)
Diffstat (limited to 'media-video/qdvdauthor')
-rw-r--r--media-video/qdvdauthor/ChangeLog10
-rw-r--r--media-video/qdvdauthor/files/digest-qdvdauthor-0.1.43
-rw-r--r--media-video/qdvdauthor/qdvdauthor-0.1.4.ebuild81
3 files changed, 92 insertions, 2 deletions
diff --git a/media-video/qdvdauthor/ChangeLog b/media-video/qdvdauthor/ChangeLog
index 84df0ce2077f..08187d06d8ef 100644
--- a/media-video/qdvdauthor/ChangeLog
+++ b/media-video/qdvdauthor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/qdvdauthor
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/ChangeLog,v 1.12 2006/09/18 21:15:11 sbriesen Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/ChangeLog,v 1.13 2007/01/06 21:31:47 sbriesen Exp $
+
+*qdvdauthor-0.1.4 (06 Jan 2007)
+
+ 06 Jan 2007; Stefan Briesenick <sbriesen@gentoo.org>
+ +qdvdauthor-0.1.4.ebuild:
+ version bump, solving bug #159901.
18 Sep 2006; Stefan Briesenick <sbriesen@gentoo.org>
-qdvdauthor-0.1.0.ebuild, -qdvdauthor-0.1.2.ebuild,
diff --git a/media-video/qdvdauthor/files/digest-qdvdauthor-0.1.4 b/media-video/qdvdauthor/files/digest-qdvdauthor-0.1.4
new file mode 100644
index 000000000000..84b984be6e89
--- /dev/null
+++ b/media-video/qdvdauthor/files/digest-qdvdauthor-0.1.4
@@ -0,0 +1,3 @@
+MD5 7f81f2f915a1a5709a584b839a750110 qdvdauthor-0.1.4.tar.gz 3405853
+RMD160 e38f21602abfc2aec09c782e376c6514be11d93a qdvdauthor-0.1.4.tar.gz 3405853
+SHA256 1ec3a9d2b609f5ee5da643b86beeb209bde43b2a03cb92fd7c6f660d941b4b54 qdvdauthor-0.1.4.tar.gz 3405853
diff --git a/media-video/qdvdauthor/qdvdauthor-0.1.4.ebuild b/media-video/qdvdauthor/qdvdauthor-0.1.4.ebuild
new file mode 100644
index 000000000000..cf328fe0b346
--- /dev/null
+++ b/media-video/qdvdauthor/qdvdauthor-0.1.4.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/qdvdauthor-0.1.4.ebuild,v 1.1 2007/01/06 21:31:47 sbriesen Exp $
+
+inherit eutils flag-o-matic qt3
+
+DESCRIPTION="'Q' DVD-Author is a GUI frontend for dvdauthor written in Qt"
+HOMEPAGE="http://qdvdauthor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qdvdauthor/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="xine mplayer"
+
+DEPEND=">=media-video/dvdauthor-0.6.11
+ >=media-gfx/imagemagick-6.1.8.8
+ >=media-video/mjpegtools-1.6.2
+ >=media-video/dvd-slideshow-0.7.2
+ xine? ( >=media-libs/xine-lib-1.1.0 )
+ mplayer? ( media-video/mplayer )
+ !xine? ( !mplayer? ( >=media-libs/xine-lib-1.1.0 ) )
+ media-sound/sox
+ media-sound/lame
+ media-sound/toolame
+ media-libs/netpbm
+ $(qt_min_version 3.2)"
+
+# TODO:
+# media-video/dvd-slideshow -> optional
+# installing further tools -> needs evaluation
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # do not over-optimize (see #147250)
+ replace-flags -O? -O2
+ filter-flags -finline-functions
+
+ # set our C(XX)FLAGS
+ for PRO in qdvdauthor/*.pro qdvdauthor/*/*.pro; do
+ echo "QMAKE_CFLAGS_RELEASE = ${CFLAGS}" >> ${PRO}
+ echo "QMAKE_CXXFLAGS_RELEASE = ${CXXFLAGS}" >> ${PRO}
+ done
+
+ # full-qualify qmake in configure
+ sed -i -e "s:make;:make ${MAKEOPTS};:g" \
+ -e "s:qmake:\${QTDIR}/bin/qmake QMAKE=\${QTDIR}/bin/qmake:g" configure
+
+ # fixing defaults from /usr/local/bin to gentoo default /usr/bin
+ sed -i "s:/usr/local/bin:/usr/bin:g" qdvdauthor/qdvdauthor.cpp \
+ qdvdauthor/dialog*.cpp qdvdauthor/qslideshow/dialog*.cpp doc/sound.txt
+}
+
+src_compile() {
+ local myconf="--build-qplayer --build-qslideshow"
+
+ # select backend (VLC is currently broken)
+ #use vlc && myconf="${myconf} --with-vlc-support"
+ use xine && myconf="${myconf} --with-xine-support"
+ use mplayer && myconf="${myconf} --with-mplayer-support"
+
+ # if no backend selected, use XINE as default
+ if ! use xine && ! use mplayer; then
+ myconf="${myconf} --with-xine-support"
+ fi
+
+ ./configure --prefix=/usr ${myconf} || die "configure failed"
+}
+
+src_install() {
+ make -C qdvdauthor INSTALL_ROOT="${D}" install || die "qdvdauthor install failed"
+ make -C qdvdauthor/qslideshow INSTALL_ROOT="${D}" install || die "qslideshow install failed"
+ make -C qdvdauthor/qplayer INSTALL_ROOT="${D}" install || die "qplayer install failed"
+
+ dobin bin/{qdvdauthor,qslideshow,qplayer}
+ dodoc CHANGELOG INSTALL README TODO doc/{bugs,ISO_639,render*,sound*,todo*}.txt
+ domenu qdvdauthor.desktop
+ doicon qdvdauthor.png
+}