summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-05-26 22:38:56 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2015-05-26 22:38:56 +0000
commitecbbdf4ebf3ab839773767304b22ab41c43175a0 (patch)
treed47559c173ce38f39d42181041ccb76ab12d430c /media-video/pitivi
parentRemove misleading comment. (diff)
downloadgentoo-2-ecbbdf4ebf3ab839773767304b22ab41c43175a0.tar.gz
gentoo-2-ecbbdf4ebf3ab839773767304b22ab41c43175a0.tar.bz2
gentoo-2-ecbbdf4ebf3ab839773767304b22ab41c43175a0.zip
Add support for python3_3 as it works there, raise various dependencies according to configure/check.py, fix unittests.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'media-video/pitivi')
-rw-r--r--media-video/pitivi/ChangeLog7
-rw-r--r--media-video/pitivi/files/pitivi-0.94-unittest.patch14
-rw-r--r--media-video/pitivi/pitivi-0.94.ebuild24
3 files changed, 36 insertions, 9 deletions
diff --git a/media-video/pitivi/ChangeLog b/media-video/pitivi/ChangeLog
index dedc5114839a..b6617efd51a6 100644
--- a/media-video/pitivi/ChangeLog
+++ b/media-video/pitivi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/pitivi
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/pitivi/ChangeLog,v 1.39 2015/05/24 19:23:14 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/pitivi/ChangeLog,v 1.40 2015/05/26 22:38:56 eva Exp $
+
+ 26 May 2015; Gilles Dartiguelongue <eva@gentoo.org> pitivi-0.94.ebuild,
+ +files/pitivi-0.94-unittest.patch:
+ Add support for python3_3 as it works there, raise various dependencies
+ according to configure/check.py, fix unittests.
24 May 2015; Alexandre Rostovtsev <tetromino@gentoo.org> pitivi-0.94.ebuild:
Add pycanberra dep (bug #550294, thanks to Thomas Raschbacher).
diff --git a/media-video/pitivi/files/pitivi-0.94-unittest.patch b/media-video/pitivi/files/pitivi-0.94-unittest.patch
new file mode 100644
index 000000000000..a117d108f48f
--- /dev/null
+++ b/media-video/pitivi/files/pitivi-0.94-unittest.patch
@@ -0,0 +1,14 @@
+Allow fallback to a non GL sink for unittests.
+
+--- a/pitivi/utils/pipeline.py 2015-05-25 13:58:33.980916075 +0200
++++ b/pitivi/utils/pipeline.py 2015-05-25 13:57:52.277261138 +0200
+@@ -182,6 +182,9 @@
+ # Create a cluttersink element used for display. Subclasses must connect
+ # it to self._pipeline themselves
+ self.video_sink = Gst.ElementFactory.make("glimagesink", None)
++ if self.video_sink is None:
++ self.video_sink = Gst.ElementFactory.make("xvimagesink", None)
++
+ if isinstance(pipeline, GES.Pipeline):
+ self._pipeline.preview_set_video_sink(self.video_sink)
+ else:
diff --git a/media-video/pitivi/pitivi-0.94.ebuild b/media-video/pitivi/pitivi-0.94.ebuild
index a53ddfa5fb09..19499f6b1388 100644
--- a/media-video/pitivi/pitivi-0.94.ebuild
+++ b/media-video/pitivi/pitivi-0.94.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/pitivi/pitivi-0.94.ebuild,v 1.3 2015/05/24 19:23:14 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/pitivi/pitivi-0.94.ebuild,v 1.4 2015/05/26 22:38:56 eva Exp $
EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python3_4 )
+PYTHON_COMPAT=( python{3_3,3_4} )
PYTHON_REQ_USE="sqlite"
-inherit gnome2 python-single-r1 eutils virtualx multilib
+inherit eutils gnome2 python-single-r1 virtualx
DESCRIPTION="A non-linear video editor using the GStreamer multimedia framework"
HOMEPAGE="http://www.pitivi.org"
@@ -16,10 +16,11 @@ HOMEPAGE="http://www.pitivi.org"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64"
-
IUSE="v4l test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# Do not forget to check pitivi/check.py for dependencies
+# pycanberra, gnome-desktop, libav and libnotify are optional
COMMON_DEPEND="
${PYTHON_DEPS}
>=dev-python/pycairo-1.10[${PYTHON_USEDEP}]
@@ -30,13 +31,14 @@ RDEPEND="${COMMON_DEPEND}
>=dev-libs/gobject-introspection-1.34
dev-python/dbus-python[${PYTHON_USEDEP}]
- >=dev-python/gst-python-1.1.90:1.0[${PYTHON_USEDEP}]
+ >=dev-python/gst-python-1.4:1.0[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pycanberra[${PYTHON_USEDEP}]
>=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}]
dev-python/pyxdg[${PYTHON_USEDEP}]
gnome-base/librsvg:=
+ gnome-base/gnome-desktop:3[introspection]
>=media-libs/clutter-1.12:1.0[introspection]
>=media-libs/clutter-gst-2:2.0[introspection]
@@ -46,22 +48,28 @@ RDEPEND="${COMMON_DEPEND}
>=media-libs/gstreamer-editing-services-1.4:1.0[introspection]
>=media-libs/gst-plugins-base-1.4:1.0
>=media-libs/gst-plugins-good-1.4:1.0
- >=media-plugins/gst-plugins-libav-1.2:1.0
+ >=media-plugins/gst-plugins-libav-1.4:1.0
x11-libs/libnotify[introspection]
- >=x11-libs/gtk+-3.8:3[introspection]
+ >=x11-libs/gtk+-3.10:3[introspection]
v4l? ( >=media-plugins/gst-plugins-v4l2-1.4:1.0 )
"
DEPEND="${RDEPEND}
+ app-text/yelp-tools
dev-python/setuptools
- >=app-text/gnome-doc-utils-0.18.0
>=dev-util/intltool-0.35.5
sys-devel/gettext
virtual/pkgconfig
test? ( dev-python/mock[${PYTHON_USEDEP}] )
"
+src_prepare() {
+ # Allow using non-GL sink when it cannot be found
+ epatch "${FILESDIR}"/${PN}-0.94-unittest.patch
+
+ gnome2_src_prepare
+}
src_configure() {
gnome2_src_configure \
ITSTOOL="$(type -P true)" \