summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-10-18 09:55:33 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-10-18 09:55:33 +0000
commit4b8c0112a267e28a197c7a047062a49be9e4cfd6 (patch)
tree7fc15d03285bf9c7cfcabc5f4a8c60f652fe26ce /media-video/noad
parentfix build with latest ffmpeg, bug #242070 (diff)
downloadgentoo-2-4b8c0112a267e28a197c7a047062a49be9e4cfd6.tar.gz
gentoo-2-4b8c0112a267e28a197c7a047062a49be9e4cfd6.tar.bz2
gentoo-2-4b8c0112a267e28a197c7a047062a49be9e4cfd6.zip
fix build with latest ffmpeg, bug #242096
(Portage version: 2.2_rc12/cvs/Linux 2.6.26.6 x86_64)
Diffstat (limited to 'media-video/noad')
-rw-r--r--media-video/noad/ChangeLog6
-rw-r--r--media-video/noad/files/patches-0.6.0/lavc.patch14
-rw-r--r--media-video/noad/noad-0.6.0-r9.ebuild3
3 files changed, 21 insertions, 2 deletions
diff --git a/media-video/noad/ChangeLog b/media-video/noad/ChangeLog
index d9372ff21faa..61e51a6e1460 100644
--- a/media-video/noad/ChangeLog
+++ b/media-video/noad/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/noad
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/noad/ChangeLog,v 1.32 2008/03/30 12:03:40 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/noad/ChangeLog,v 1.33 2008/10/18 09:55:33 aballier Exp $
+
+ 18 Oct 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/patches-0.6.0/lavc.patch, noad-0.6.0-r9.ebuild:
+ fix build with latest ffmpeg, bug #242096
30 Mar 2008; Joerg Bornkessel <hd_brummy@gentoo.org> noad-0.6.0-r9.ebuild:
new ffmpeg header structur fixed, bug #214740
diff --git a/media-video/noad/files/patches-0.6.0/lavc.patch b/media-video/noad/files/patches-0.6.0/lavc.patch
new file mode 100644
index 000000000000..3139a78d308e
--- /dev/null
+++ b/media-video/noad/files/patches-0.6.0/lavc.patch
@@ -0,0 +1,14 @@
+Index: noad-0.6.0/audiotools.cpp
+===================================================================
+--- noad-0.6.0.orig/audiotools.cpp
++++ noad-0.6.0/audiotools.cpp
+@@ -99,7 +99,8 @@ int scan_audio_stream_0(unsigned char *m
+ inbuf_ptr = mbuf;
+ while (size > 0)
+ {
+- len = avcodec_decode_audio(c, (short *)outbuf, &out_size,
++ out_size=AVCODEC_MAX_AUDIO_FRAME_SIZE;
++ len = avcodec_decode_audio2(c, (short *)outbuf, &out_size,
+ inbuf_ptr, size);
+ if (len < 0)
+ {
diff --git a/media-video/noad/noad-0.6.0-r9.ebuild b/media-video/noad/noad-0.6.0-r9.ebuild
index 5c2bad2c44df..b1ece974f7d6 100644
--- a/media-video/noad/noad-0.6.0-r9.ebuild
+++ b/media-video/noad/noad-0.6.0-r9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/noad/noad-0.6.0-r9.ebuild,v 1.6 2008/03/30 12:03:40 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/noad/noad-0.6.0-r9.ebuild,v 1.7 2008/10/18 09:55:33 aballier Exp $
WANT_AUTOMAKE="latest"
WANT_AUTOCONF="latest"
@@ -34,6 +34,7 @@ src_unpack() {
epatch "${FILESDIR}"/patches-${PV}/fix-osd.patch
epatch "${FILESDIR}"/patches-${PV}/hangcheck.diff
epatch "${FILESDIR}"/patches-${PV}/new-ffmpeg-extern-c.diff
+ epatch "${FILESDIR}"/patches-${PV}/lavc.patch
sed -e "s:char \*indents:const char \*indents:" -i showindex.cpp