summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-09-30 19:13:53 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-09-30 19:13:53 +0000
commit1909be7729c10718a957b6abb997949ba49e6cf5 (patch)
tree9e6cb60c2127f048a8d33d40530706a18d97ea9d /media-video/lives
parentAdd evolution-3, from gnome overlay for GNOME 3 (TODO: file bug for USE=map k... (diff)
downloadgentoo-2-1909be7729c10718a957b6abb997949ba49e6cf5.tar.gz
gentoo-2-1909be7729c10718a957b6abb997949ba49e6cf5.tar.bz2
gentoo-2-1909be7729c10718a957b6abb997949ba49e6cf5.zip
Version bump wrt #376367 by tman, including upstream patch for building against libv4l instead of v4l1 from linux-headers wrt #361943 by Jouni Rinne. Use python2 instead of python wrt #315053 by Arfrever Frehtes Taifersar Arahesis. Fix imagemagick vs. graphicsmagick dependencies wrt #314337 by Wojciech Porczyk.
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'media-video/lives')
-rw-r--r--media-video/lives/ChangeLog11
-rw-r--r--media-video/lives/lives-1.4.6.ebuild74
2 files changed, 84 insertions, 1 deletions
diff --git a/media-video/lives/ChangeLog b/media-video/lives/ChangeLog
index f99bfbe71350..c5c82123e6c7 100644
--- a/media-video/lives/ChangeLog
+++ b/media-video/lives/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-video/lives
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/lives/ChangeLog,v 1.31 2011/04/04 13:05:26 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/lives/ChangeLog,v 1.32 2011/09/30 19:13:53 ssuominen Exp $
+
+*lives-1.4.6 (30 Sep 2011)
+
+ 30 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> +lives-1.4.6.ebuild:
+ Version bump wrt #376367 by tman, including upstream patch for building
+ against libv4l instead of v4l1 from linux-headers wrt #361943 by Jouni Rinne.
+ Use python2 instead of python wrt #315053 by Arfrever Frehtes Taifersar
+ Arahesis. Fix imagemagick vs. graphicsmagick dependencies wrt #314337 by
+ Wojciech Porczyk.
*lives-1.4.2 (04 Apr 2011)
diff --git a/media-video/lives/lives-1.4.6.ebuild b/media-video/lives/lives-1.4.6.ebuild
new file mode 100644
index 000000000000..c9765830b32a
--- /dev/null
+++ b/media-video/lives/lives-1.4.6.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/lives/lives-1.4.6.ebuild,v 1.1 2011/09/30 19:13:53 ssuominen Exp $
+
+EAPI=4
+inherit eutils
+
+MY_P=LiVES-${PV}
+
+DESCRIPTION="LiVES is a Video Editing System"
+HOMEPAGE="http://lives.sf.net"
+SRC_URI="http://www.xs4all.nl/~salsaman/lives/current/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="libvisual matroska nls ogg theora" # static-libs
+
+# FIXME (incomplete workaround in place):
+# !!<${CATEGORY}/${PF} is because if you have lives installed, the bundled
+# libweed never gets installed in second emerge
+# See also bug 295293
+RDEPEND="media-video/mplayer
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ dev-lang/perl
+ >=dev-libs/glib-2.14
+ >=x11-libs/gtk+-2.16:2
+ media-libs/libsdl
+ media-libs/libv4l
+ virtual/ffmpeg
+ virtual/jpeg
+ media-sound/sox
+ virtual/cdrtools
+ || ( dev-lang/python:2.7 dev-lang/python:2.6 )
+ media-plugins/frei0r-plugins
+ media-sound/jack-audio-connection-kit
+ >=media-video/mjpegtools-1.6.2
+ sys-libs/libavc1394
+ libvisual? ( media-libs/libvisual )
+ matroska? ( media-video/mkvtoolnix )
+ ogg? ( media-sound/ogmtools )
+ theora? ( media-libs/libtheora )
+ !!<${CATEGORY}/${PF}"
+DEPEND="${DEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS BUGS ChangeLog FEATURES GETTING.STARTED NEWS README )
+
+src_prepare() {
+ esvn_clean
+
+ # Use python 2.x as per reference in plugins
+ sed -i \
+ -e '/#!.*env/s:python:python2:' \
+ lives-plugins/plugins/encoders/multi_encoder* \
+ lives-plugins/marcos-encoders/lives_*_encoder* || die
+
+}
+
+src_configure() {
+ # $(use_enable static-libs static)
+ econf \
+ --disable-static \
+ $(use_enable libvisual) \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+ find "${ED}"usr -name '*.la' -exec rm -f {} +
+ # use static-libs ||
+ rm -f "${ED}"usr/lib*/libweed-*.a
+}