summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-05-05 20:59:23 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-05-05 20:59:23 +0000
commite7bc7d4898c6aeca51fe43fdbb13bcd00420e03f (patch)
treee9c02fb01fbb6122fdf4b6af763fbd9857410a90 /media-video/handbrake
parentSupport complete EAPI src_test(). (diff)
downloadgentoo-2-e7bc7d4898c6aeca51fe43fdbb13bcd00420e03f.tar.gz
gentoo-2-e7bc7d4898c6aeca51fe43fdbb13bcd00420e03f.tar.bz2
gentoo-2-e7bc7d4898c6aeca51fe43fdbb13bcd00420e03f.zip
Made use of python-any-r1 instead of python-single-r1 since python is only relevant at Python and the implementation does not matter. Use the global gstreamer USE flag instead of the local gst USE flag. Better support prefixes using EPREFIX. Thanks to Nikoli for these suggestions. More testing of dependency versions and the use of virtuals will follow the coming week...
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'media-video/handbrake')
-rw-r--r--media-video/handbrake/ChangeLog10
-rw-r--r--media-video/handbrake/handbrake-0.9.9_pre5441.ebuild22
-rw-r--r--media-video/handbrake/handbrake-9999.ebuild22
-rw-r--r--media-video/handbrake/metadata.xml2
4 files changed, 32 insertions, 24 deletions
diff --git a/media-video/handbrake/ChangeLog b/media-video/handbrake/ChangeLog
index 699263df4a45..c4d3fb4d2999 100644
--- a/media-video/handbrake/ChangeLog
+++ b/media-video/handbrake/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-video/handbrake
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/handbrake/ChangeLog,v 1.1 2013/05/05 17:33:51 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/handbrake/ChangeLog,v 1.2 2013/05/05 20:59:23 tomwij Exp $
+
+ 05 May 2013; Tom Wijsman <TomWij@gentoo.org> handbrake-0.9.9_pre5441.ebuild,
+ handbrake-9999.ebuild, metadata.xml:
+ Made use of python-any-r1 instead of python-single-r1 since python is only
+ relevant at Python and the implementation does not matter. Use the global
+ gstreamer USE flag instead of the local gst USE flag. Better support prefixes
+ using EPREFIX. Thanks to Nikoli for these suggestions. More testing of
+ dependency versions and the use of virtuals will follow the coming week...
*handbrake-0.9.9_pre5441 (05 May 2013)
*handbrake-9999 (05 May 2013)
diff --git a/media-video/handbrake/handbrake-0.9.9_pre5441.ebuild b/media-video/handbrake/handbrake-0.9.9_pre5441.ebuild
index a17c7cfd8713..70ddd9817630 100644
--- a/media-video/handbrake/handbrake-0.9.9_pre5441.ebuild
+++ b/media-video/handbrake/handbrake-0.9.9_pre5441.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/handbrake/handbrake-0.9.9_pre5441.ebuild,v 1.1 2013/05/05 17:33:51 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/handbrake/handbrake-0.9.9_pre5441.ebuild,v 1.2 2013/05/05 20:59:23 tomwij Exp $
EAPI="5"
PYTHON_COMPAT=( python2_{5,6,7} )
-inherit eutils gnome2-utils python-single-r1
+inherit eutils gnome2-utils python-any-r1
if [[ ${PV} = *9999* ]]; then
ESVN_REPO_URI="svn://svn.handbrake.fr/HandBrake/trunk"
@@ -23,10 +23,10 @@ HOMEPAGE="http://handbrake.fr/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="gtk gst ffmpeg"
+IUSE="gtk gstreamer ffmpeg"
# Use either ffmpeg or gst-plugins/mpeg2dec for decoding MPEG-2.
-REQUIRED_USE="!ffmpeg? ( gst )"
+REQUIRED_USE="!ffmpeg? ( gstreamer )"
RDEPEND="
media-libs/a52dec
@@ -45,7 +45,7 @@ RDEPEND="
ffmpeg? ( >=media-video/ffmpeg-1.2 )
sys-libs/glibc:2.2
sys-libs/zlib
- gst? (
+ gstreamer? (
media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0
!ffmpeg? ( media-plugins/gst-plugins-mpeg2dec:1.0 )
@@ -67,7 +67,7 @@ DEPEND="${RDEPEND}
sys-devel/automake"
pkg_setup() {
- python-single-r1_pkg_setup
+ python-any-r1_pkg_setup
}
src_prepare() {
@@ -101,20 +101,20 @@ src_configure() {
local myconf=""
if ! use gtk ; then
- myconf="${myconf} --disable-gtk"
+ myconf+=" --disable-gtk"
fi
- if ! use gst ; then
- myconf="${myconf} --disable-gst"
+ if ! use gstreamer ; then
+ myconf+=" --disable-gst"
fi
if use ffmpeg ; then
- myconf="${myconf} --enable-ff-mpeg2"
+ myconf+=" --enable-ff-mpeg2"
fi
./configure \
--force \
- --prefix=/usr \
+ --prefix="${EPREFIX}/usr" \
--disable-gtk-update-checks \
${myconf} || die "Configure failed."
}
diff --git a/media-video/handbrake/handbrake-9999.ebuild b/media-video/handbrake/handbrake-9999.ebuild
index d611834d2c47..4fcea9e15b44 100644
--- a/media-video/handbrake/handbrake-9999.ebuild
+++ b/media-video/handbrake/handbrake-9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/handbrake/handbrake-9999.ebuild,v 1.1 2013/05/05 17:33:51 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/handbrake/handbrake-9999.ebuild,v 1.2 2013/05/05 20:59:23 tomwij Exp $
EAPI="5"
PYTHON_COMPAT=( python2_{5,6,7} )
-inherit eutils gnome2-utils python-single-r1
+inherit eutils gnome2-utils python-any-r1
if [[ ${PV} = *9999* ]]; then
ESVN_REPO_URI="svn://svn.handbrake.fr/HandBrake/trunk"
@@ -23,10 +23,10 @@ HOMEPAGE="http://handbrake.fr/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="gtk gst ffmpeg"
+IUSE="gtk gstreamer ffmpeg"
# Use either ffmpeg or gst-plugins/mpeg2dec for decoding MPEG-2.
-REQUIRED_USE="!ffmpeg? ( gst )"
+REQUIRED_USE="!ffmpeg? ( gstreamer )"
RDEPEND="
media-libs/a52dec
@@ -45,7 +45,7 @@ RDEPEND="
ffmpeg? ( >=media-video/ffmpeg-1.2 )
sys-libs/glibc:2.2
sys-libs/zlib
- gst? (
+ gstreamer? (
media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0
!ffmpeg? ( media-plugins/gst-plugins-mpeg2dec:1.0 )
@@ -67,7 +67,7 @@ DEPEND="${RDEPEND}
sys-devel/automake"
pkg_setup() {
- python-single-r1_pkg_setup
+ python-any-r1_pkg_setup
}
src_prepare() {
@@ -101,20 +101,20 @@ src_configure() {
local myconf=""
if ! use gtk ; then
- myconf="${myconf} --disable-gtk"
+ myconf+=" --disable-gtk"
fi
- if ! use gst ; then
- myconf="${myconf} --disable-gst"
+ if ! use gstreamer ; then
+ myconf+=" --disable-gst"
fi
if use ffmpeg ; then
- myconf="${myconf} --enable-ff-mpeg2"
+ myconf+=" --enable-ff-mpeg2"
fi
./configure \
--force \
- --prefix=/usr \
+ --prefix="${EPREFIX}/usr" \
--disable-gtk-update-checks \
${myconf} || die "Configure failed."
}
diff --git a/media-video/handbrake/metadata.xml b/media-video/handbrake/metadata.xml
index 4a8643aa966f..520fba092725 100644
--- a/media-video/handbrake/metadata.xml
+++ b/media-video/handbrake/metadata.xml
@@ -10,7 +10,7 @@
</longdescription>
<use>
<flag name="ffmpeg">Use FFmpeg from <pkg>media-video/ffmpeg</pkg> to decode MPEG-2 instead of <pkg>media-plugins/gst-plugins-mpeg2dec</pkg>.</flag>
+ <flag name="gstreamer">Support for the streaming media framework from <pkg>media-libs/gstreamer</pkg>.</flag>
<flag name="gtk">Support for Gimp ToolKit + from <pkg>x11-libs/gtk+</pkg>, requirement for a GUI-based HandBrake.</flag>
- <flag name="gst">Support for the streaming media framework from <pkg>media-libs/gstreamer</pkg>.</flag>
</use>
</pkgmetadata>