summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2004-03-10 18:56:18 +0000
committerMax Kalika <max@gentoo.org>2004-03-10 18:56:18 +0000
commitf4393867c223e4181c81717d5ab10a8f059c60f7 (patch)
tree189e2b13367e9b5d8e2786efb749a270f2571674 /media-tv
parentVersion bumped. (Manifest recommit) (diff)
downloadgentoo-2-f4393867c223e4181c81717d5ab10a8f059c60f7.tar.gz
gentoo-2-f4393867c223e4181c81717d5ab10a8f059c60f7.tar.bz2
gentoo-2-f4393867c223e4181c81717d5ab10a8f059c60f7.zip
Fix bugs #40964 and #42943 by filtering -fPIC and -fforce-addr.
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythtv/ChangeLog5
-rw-r--r--media-tv/mythtv/mythtv-0.14-r1.ebuild7
2 files changed, 9 insertions, 3 deletions
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index 19851ab9551a..b879fa2270af 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-tv/mythtv
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.16 2004/02/17 09:43:42 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.17 2004/03/10 18:56:18 max Exp $
+
+ 10 Mar 2004; Max Kalika <max@gentoo.org> mythtv-0.14-r1.ebuild:
+ Fix bugs #40964 and #42943 by filtering -fPIC and -fforce-addr.
17 Feb 2004; Daniel Ahlberg <aliz@gentoo.org> mythtv-0.14-r1.ebuild:
Fix CFLAGS and defines so that it can be compiled on amd64. Closing #37578.
diff --git a/media-tv/mythtv/mythtv-0.14-r1.ebuild b/media-tv/mythtv/mythtv-0.14-r1.ebuild
index 8f7de8670ac6..3064d9615393 100644
--- a/media-tv/mythtv/mythtv-0.14-r1.ebuild
+++ b/media-tv/mythtv/mythtv-0.14-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.14-r1.ebuild,v 1.3 2004/02/17 09:44:23 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.14-r1.ebuild,v 1.4 2004/03/10 18:56:18 max Exp $
inherit flag-o-matic
@@ -36,7 +36,7 @@ pkg_setup() {
if [ ! "`has mysql ${qt_use}`" ] ; then
eerror "Qt is missing MySQL support. Please add"
eerror "'mysql' to your USE flags, and re-emerge Qt."
- die "Qt needs mysql support"
+ die "Qt needs MySQL support"
fi
return 0
@@ -51,6 +51,9 @@ src_unpack() {
}
src_compile() {
+ # Fix bugs 40964 and 42943.
+ filter-flags -fforce-addr -fPIC
+
if [ "${ARCH}" == "amd64" ]; then
sed -e "s:-march=pentiumpro::" -e "/DEFINES += MMX/d" -i settings.pro
else