summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-05-24 14:05:55 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-05-24 14:05:55 +0000
commitbc62850decbde84ca30a09f5c689038402d9464d (patch)
treeaf6642302aa8317d314ffe6efd7733f7defe47af /media-tv
parentupdate ffmpeg 1.1 mask reason with more details (diff)
downloadgentoo-2-bc62850decbde84ca30a09f5c689038402d9464d.tar.gz
gentoo-2-bc62850decbde84ca30a09f5c689038402d9464d.tar.bz2
gentoo-2-bc62850decbde84ca30a09f5c689038402d9464d.zip
Fix ffmpeg deps: upstream recommends ffmpeg so this one shall come first in the || dep. xbmc doesnt even compile against libav, meaning the dep is in theory wrong but left there in case someone eventually gets upstream to fix it. Do not depend on virtual/ffmpeg which is not finegrained enough here (and also rather useless because of the libpostproc dep) since ffmpeg releases more often than libav these days and virtual/ffmpeg-9 depends on a masked ffmpeg version while xbmc only requires ffmpeg-1 which is unmasked.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/xbmc/ChangeLog11
-rw-r--r--media-tv/xbmc/xbmc-9999.ebuild5
2 files changed, 12 insertions, 4 deletions
diff --git a/media-tv/xbmc/ChangeLog b/media-tv/xbmc/ChangeLog
index 5c271691282a..dede33893a7f 100644
--- a/media-tv/xbmc/ChangeLog
+++ b/media-tv/xbmc/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-tv/xbmc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xbmc/ChangeLog,v 1.183 2013/05/23 21:23:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xbmc/ChangeLog,v 1.184 2013/05/24 14:05:55 aballier Exp $
+
+ 24 May 2013; Alexis Ballier <aballier@gentoo.org> xbmc-9999.ebuild:
+ Fix ffmpeg deps: upstream recommends ffmpeg so this one shall come first in
+ the || dep. xbmc doesnt even compile against libav, meaning the dep is in
+ theory wrong but left there in case someone eventually gets upstream to fix
+ it. Do not depend on virtual/ffmpeg which is not finegrained enough here (and
+ also rather useless because of the libpostproc dep) since ffmpeg releases
+ more often than libav these days and virtual/ffmpeg-9 depends on a masked
+ ffmpeg version while xbmc only requires ffmpeg-1 which is unmasked.
*xbmc-12.2 (23 May 2013)
diff --git a/media-tv/xbmc/xbmc-9999.ebuild b/media-tv/xbmc/xbmc-9999.ebuild
index f7af705eae52..001ffff599a0 100644
--- a/media-tv/xbmc/xbmc-9999.ebuild
+++ b/media-tv/xbmc/xbmc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xbmc/xbmc-9999.ebuild,v 1.144 2013/05/23 21:23:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xbmc/xbmc-9999.ebuild,v 1.145 2013/05/24 14:05:55 aballier Exp $
EAPI=5
@@ -91,8 +91,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
media-libs/tiff
pulseaudio? ( media-sound/pulseaudio )
media-sound/wavpack
- || ( media-libs/libpostproc media-video/ffmpeg )
- >=virtual/ffmpeg-9[encode]
+ || ( >=media-video/ffmpeg-1.0[encode] ( media-libs/libpostproc >=media-video/libav-9[encode] ) )
rtmp? ( media-video/rtmpdump )
avahi? ( net-dns/avahi )
nfs? ( net-fs/libnfs )