summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2009-11-02 00:01:33 +0000
committerDoug Goldstein <cardoe@gentoo.org>2009-11-02 00:01:33 +0000
commit5852ad4f042fb95898eb7671ea7fc85b4b18d661 (patch)
treee868bfc06ba156406d06cbbd0e4476f43d61a337 /media-tv
parentEnable xcomposite by default (diff)
downloadgentoo-2-5852ad4f042fb95898eb7671ea7fc85b4b18d661.tar.gz
gentoo-2-5852ad4f042fb95898eb7671ea7fc85b4b18d661.tar.bz2
gentoo-2-5852ad4f042fb95898eb7671ea7fc85b4b18d661.zip
add support for pulseaudio. add warning about automagical dependencies
(Portage version: 2.1.7.3/cvs/Linux x86_64)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythtv/ChangeLog6
-rw-r--r--media-tv/mythtv/mythtv-0.22_rc22679.ebuild20
2 files changed, 20 insertions, 6 deletions
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index e56c4530fa53..d0fc5118f09f 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/mythtv
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.283 2009/10/31 22:30:25 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.284 2009/11/02 00:01:33 cardoe Exp $
+
+ 02 Nov 2009; Doug Goldstein <cardoe@gentoo.org>
+ mythtv-0.22_rc22679.ebuild:
+ add support for pulseaudio. add warning about automagical dependencies
31 Oct 2009; Doug Goldstein <cardoe@gentoo.org>
-mythtv-0.21_p18314-r1.ebuild, -mythtv-0.21_p18314-r2.ebuild,
diff --git a/media-tv/mythtv/mythtv-0.22_rc22679.ebuild b/media-tv/mythtv/mythtv-0.22_rc22679.ebuild
index cbb20ddbca09..de4ff325d9af 100644
--- a/media-tv/mythtv/mythtv-0.22_rc22679.ebuild
+++ b/media-tv/mythtv/mythtv-0.22_rc22679.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.22_rc22679.ebuild,v 1.1 2009/10/31 22:16:07 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.22_rc22679.ebuild,v 1.2 2009/11/02 00:01:33 cardoe Exp $
EAPI=2
inherit flag-o-matic multilib eutils qt4 mythtv toolchain-funcs python
@@ -46,6 +46,7 @@ RDEPEND=">=media-libs/freetype-2.0
lcd? ( app-misc/lcdproc )
lirc? ( app-misc/lirc )
perl? ( dev-perl/DBD-mysql )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.7 )
python? ( dev-python/mysql-python )
vdpau? ( x11-libs/libvdpau )
xvmc? ( x11-libs/libXvMC )"
@@ -256,10 +257,6 @@ pkg_preinst() {
pkg_postinst() {
use python && python_mod_optimize $(python_get_sitedir)/MythTV
- elog "Want mythfrontend to start automatically?"
- elog "Set USE=autostart. Details can be found at:"
- elog "http://dev.gentoo.org/~cardoe/mythtv/autostart.html"
-
elog
elog "To always have MythBackend running and available run the following:"
elog "rc-update add mythbackend default"
@@ -275,6 +272,10 @@ pkg_postinst() {
ewarn "'eselect xvmc set nvidia' for example"
fi
+ elog "Want mythfrontend to start automatically?"
+ elog "Set USE=autostart. Details can be found at:"
+ elog "http://dev.gentoo.org/~cardoe/mythtv/autostart.html"
+
if use autostart; then
elog
elog "Please add the following to your /etc/inittab file at the end of"
@@ -282,6 +283,15 @@ pkg_postinst() {
elog "c8:2345:respawn:/sbin/mingetty --autologin mythtv tty8"
fi
+ elog
+ ewarn "Beware when you change ANY packages on your system that it may"
+ ewarn "break some or all of the MythTV components. MythTV's build system"
+ ewarn "is very fragile and only supports automagic dependencies."
+ ewarn "i.e. It depends on libraries and components it finds at build time"
+ ewarn "We try to mitigate this with RDEPENDs but be prepared to run"
+ ewarn "revdep-rebuild as necessary."
+
+
}
pkg_postrm()