summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2010-02-23 19:57:40 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2010-02-23 19:57:40 +0000
commit8bc6da136bfc7279812843ca0b673329f9c61267 (patch)
tree97f7fa65c4ea371fc7f2523c04fc5424056e4f14 /media-tv/linuxtv-dvb-apps
parentgnome-panel dependency is optional, bug #298932, thanks to Olaf for noticing. (diff)
downloadgentoo-2-8bc6da136bfc7279812843ca0b673329f9c61267.tar.gz
gentoo-2-8bc6da136bfc7279812843ca0b673329f9c61267.tar.bz2
gentoo-2-8bc6da136bfc7279812843ca0b673329f9c61267.zip
Added new snapshot.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'media-tv/linuxtv-dvb-apps')
-rw-r--r--media-tv/linuxtv-dvb-apps/ChangeLog10
-rw-r--r--media-tv/linuxtv-dvb-apps/linuxtv-dvb-apps-1.1.1.20100223.ebuild83
2 files changed, 91 insertions, 2 deletions
diff --git a/media-tv/linuxtv-dvb-apps/ChangeLog b/media-tv/linuxtv-dvb-apps/ChangeLog
index 7d404bd71e85..84e52431a3cc 100644
--- a/media-tv/linuxtv-dvb-apps/ChangeLog
+++ b/media-tv/linuxtv-dvb-apps/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-tv/linuxtv-dvb-apps
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/linuxtv-dvb-apps/ChangeLog,v 1.43 2008/12/21 14:48:57 nixnut Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/linuxtv-dvb-apps/ChangeLog,v 1.44 2010/02/23 19:57:40 zzam Exp $
+
+*linuxtv-dvb-apps-1.1.1.20100223 (23 Feb 2010)
+
+ 23 Feb 2010; Matthias Schwarzott <zzam@gentoo.org>
+ +linuxtv-dvb-apps-1.1.1.20100223.ebuild:
+ Added new snapshot.
21 Dec 2008; nixnut <nixnut@gentoo.org>
linuxtv-dvb-apps-1.1.1.20080317.ebuild:
diff --git a/media-tv/linuxtv-dvb-apps/linuxtv-dvb-apps-1.1.1.20100223.ebuild b/media-tv/linuxtv-dvb-apps/linuxtv-dvb-apps-1.1.1.20100223.ebuild
new file mode 100644
index 000000000000..db6ce1e8e0a4
--- /dev/null
+++ b/media-tv/linuxtv-dvb-apps/linuxtv-dvb-apps-1.1.1.20100223.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/linuxtv-dvb-apps/linuxtv-dvb-apps-1.1.1.20100223.ebuild,v 1.1 2010/02/23 19:57:40 zzam Exp $
+
+inherit eutils versionator multilib
+
+MY_P="${PN}-$(get_version_component_range 4)"
+
+IUSE="usb"
+SLOT="0"
+HOMEPAGE="http://www.linuxtv.org/"
+DESCRIPTION="small utils for DVB to scan, zap, view signal strength, ..."
+LICENSE="GPL-2"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+
+RDEPEND="usb? ( >=dev-libs/libusb-0.1.10a )
+ !dev-db/xbase"
+DEPEND="${RDEPEND}
+ media-tv/linuxtv-dvb-headers"
+# !dev-db/xbase (bug #208596)
+
+S="${WORKDIR}/dvb-apps-7de0663facd9"
+
+src_unpack()
+{
+ unpack ${A}
+
+ cd "${S}"
+
+ # do not compile test-progs
+ sed -i Makefile -e '/-C test/d'
+
+ # remove copy of header-files
+ rm -rf "${S}"/include
+}
+
+src_compile()
+{
+ # ttusb_dec_reset requires libusb
+ myopts=""
+ use usb && myopts="${myopts} ttusb_dec_reset=1"
+
+ emake bindir=/usr/bin datadir=/usr/share libdir=/usr/$(get_libdir) \
+ ${myopts} || die "failed to compile"
+}
+
+src_install()
+{
+ insinto /usr/bin
+ emake bindir=/usr/bin datadir=/usr/share libdir=/usr/$(get_libdir) prefix=/usr \
+ DESTDIR="${D}" INSTDIR="${T}" ${myopts} install || die "install failed"
+
+ # rename scan to dvbscan
+ mv "${D}"/usr/bin/scan "${D}"/usr/bin/dvbscan
+
+ # install zap-files
+ for dir in dvb-{s,c,t} atsc; do
+ insinto /usr/share/dvb/zap/${dir}
+ doins "${S}"/util/szap/channels-conf/${dir}/*
+ done
+
+ # install remote-key files
+ insinto /usr/share/dvb/av7110_loadkeys
+ doins "${S}"/util/av7110_loadkeys/*.rc*
+
+ # install Documentation
+ dodoc README
+ newdoc util/scan/README README.dvbscan
+ newdoc util/szap/README README.zap
+ newdoc util/av7110_loadkeys/README README.av7110_loadkeys
+
+ use usb && newdoc util/ttusb_dec_reset/README README.ttusb_dec_reset
+}
+
+pkg_postinst()
+{
+ elog "Please read the documentation in /usr/share/doc/${PF}."
+ elog "The channel lists and other files are installed in"
+ elog "/usr/share/dvb"
+ elog
+ elog "The scanning utility is now installed as dvbscan."
+}