summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2015-07-25 13:42:24 +0000
committerBen de Groot <yngwin@gentoo.org>2015-07-25 13:42:24 +0000
commita0fb124faf7b9be3f0495e70bf7766f9a0583c51 (patch)
tree9728784be82f04a90c030cb8e6ac5f7167ca39fd /media-sound
parentversion bump (diff)
downloadgentoo-2-a0fb124faf7b9be3f0495e70bf7766f9a0583c51.tar.gz
gentoo-2-a0fb124faf7b9be3f0495e70bf7766f9a0583c51.tar.bz2
gentoo-2-a0fb124faf7b9be3f0495e70bf7766f9a0583c51.zip
version bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x4FDF9CFD2FAC514E!)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/sidplayfp/ChangeLog9
-rw-r--r--media-sound/sidplayfp/sidplayfp-1.4.0.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/media-sound/sidplayfp/ChangeLog b/media-sound/sidplayfp/ChangeLog
index c68f96959492..0705abd689fd 100644
--- a/media-sound/sidplayfp/ChangeLog
+++ b/media-sound/sidplayfp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/sidplayfp
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sidplayfp/ChangeLog,v 1.7 2013/10/01 15:14:47 ssuominen Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sidplayfp/ChangeLog,v 1.8 2015/07/25 13:42:24 yngwin Exp $
+
+*sidplayfp-1.4.0 (25 Jul 2015)
+
+ 25 Jul 2015; Ben de Groot <yngwin@gentoo.org> +sidplayfp-1.4.0.ebuild:
+ version bump
*sidplayfp-1.1.0 (01 Oct 2013)
diff --git a/media-sound/sidplayfp/sidplayfp-1.4.0.ebuild b/media-sound/sidplayfp/sidplayfp-1.4.0.ebuild
new file mode 100644
index 000000000000..300bc7e3e7b7
--- /dev/null
+++ b/media-sound/sidplayfp/sidplayfp-1.4.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sidplayfp/sidplayfp-1.4.0.ebuild,v 1.1 2015/07/25 13:42:24 yngwin Exp $
+
+EAPI=5
+inherit eutils versionator
+
+DESCRIPTION="A sidplay2 fork with resid-fp"
+HOMEPAGE="http://sourceforge.net/projects/sidplay-residfp/"
+SRC_URI="mirror://sourceforge/sidplay-residfp/${PN}/$(get_version_component_range 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa oss pulseaudio"
+
+RDEPEND=">=media-libs/libsidplayfp-1.8.0
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ oss? ( virtual/os-headers )"
+
+DOCS=( AUTHORS README TODO )
+
+src_prepare() {
+ use alsa || { sed -i -e 's:alsa >= 1.0:dIsAbLe&:' configure || die; }
+ use pulseaudio || { sed -i -e 's:libpulse-simple >= 1.0:dIsAbLe&:' configure || die; }
+}
+
+src_configure() {
+ export ac_cv_header_linux_soundcard_h=$(usex oss)
+ econf
+}