summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-02-10 20:48:39 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-02-10 20:48:39 +0000
commit94b8d623e3b2d6bd34e63c9a44f72ff3efb74225 (patch)
treef5d3280e31107a1023bedcb492bcd7719cca8c4c /media-sound
parentStable for amd64, wrt bug #456454 (diff)
downloadgentoo-2-94b8d623e3b2d6bd34e63c9a44f72ff3efb74225.tar.gz
gentoo-2-94b8d623e3b2d6bd34e63c9a44f72ff3efb74225.tar.bz2
gentoo-2-94b8d623e3b2d6bd34e63c9a44f72ff3efb74225.zip
Version bump
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/musique/ChangeLog9
-rw-r--r--media-sound/musique/musique-1.2.1.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/media-sound/musique/ChangeLog b/media-sound/musique/ChangeLog
index 0b8d8a807d8d..143124abb4d8 100644
--- a/media-sound/musique/ChangeLog
+++ b/media-sound/musique/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/musique
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/musique/ChangeLog,v 1.6 2012/10/23 19:27:28 hwoarang Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/musique/ChangeLog,v 1.7 2013/02/10 20:48:39 hwoarang Exp $
+
+*musique-1.2.1 (10 Feb 2013)
+
+ 10 Feb 2013; Markos Chandras <hwoarang@gentoo.org> +musique-1.2.1.ebuild:
+ Version bump
*musique-1.2 (23 Oct 2012)
diff --git a/media-sound/musique/musique-1.2.1.ebuild b/media-sound/musique/musique-1.2.1.ebuild
new file mode 100644
index 000000000000..e2d0bba1b345
--- /dev/null
+++ b/media-sound/musique/musique-1.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/musique/musique-1.2.1.ebuild,v 1.1 2013/02/10 20:48:39 hwoarang Exp $
+
+EAPI="5"
+
+inherit eutils qt4-r2
+
+DESCRIPTION="Qt4 music player."
+HOMEPAGE="http://flavio.tordini.org/musique"
+# Same tarball for every release. We repackage it
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/qt-gui:4[dbus,gtkstyle]
+ x11-libs/qt-sql:4[sqlite]
+ || ( x11-libs/qt-phonon:4 media-libs/phonon )
+ media-libs/taglib
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+DOCS="CHANGES TODO"
+
+src_prepare () {
+ # bug 422665. Upstream only cares about ubuntu
+ # so this bug will be fixed once ubuntu moves
+ # to gcc-4.7. No, I will not send this patch upstream
+ # *again*
+ epatch "${FILESDIR}"/${PN}-1.1-gcc47.patch
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ eqmake4 ${PN}.pro PREFIX="/usr"
+}
+
+src_install() {
+ qt4-r2_src_install
+ doicon data/${PN}.svg
+}