summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-07-20 09:09:20 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-07-20 09:09:20 +0000
commit86e61e515a61aebb80b4e2a9369e79a4bc5a1211 (patch)
treeec4cd58caef61182b56b8ca7acac008658caed64 /media-sound
parentversion bump (diff)
downloadgentoo-2-86e61e515a61aebb80b4e2a9369e79a4bc5a1211.tar.gz
gentoo-2-86e61e515a61aebb80b4e2a9369e79a4bc5a1211.tar.bz2
gentoo-2-86e61e515a61aebb80b4e2a9369e79a4bc5a1211.zip
version bump, add qt5 useflag
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/qjackctl/ChangeLog7
-rw-r--r--media-sound/qjackctl/qjackctl-0.4.0.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/media-sound/qjackctl/ChangeLog b/media-sound/qjackctl/ChangeLog
index 878a4ced6872..c665691573c6 100644
--- a/media-sound/qjackctl/ChangeLog
+++ b/media-sound/qjackctl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/qjackctl
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/ChangeLog,v 1.84 2015/04/08 07:21:46 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/ChangeLog,v 1.85 2015/07/20 09:09:20 aballier Exp $
+
+*qjackctl-0.4.0 (20 Jul 2015)
+
+ 20 Jul 2015; Alexis Ballier <aballier@gentoo.org> +qjackctl-0.4.0.ebuild:
+ version bump, add qt5 useflag
*qjackctl-0.3.13 (08 Apr 2015)
diff --git a/media-sound/qjackctl/qjackctl-0.4.0.ebuild b/media-sound/qjackctl/qjackctl-0.4.0.ebuild
new file mode 100644
index 000000000000..3631a57ff6a3
--- /dev/null
+++ b/media-sound/qjackctl/qjackctl-0.4.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/qjackctl-0.4.0.ebuild,v 1.1 2015/07/20 09:09:20 aballier Exp $
+
+EAPI=5
+
+inherit qmake-utils
+
+DESCRIPTION="A Qt application to control the JACK Audio Connection Kit and ALSA sequencer connections"
+HOMEPAGE="http://qjackctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qjackctl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="alsa dbus debug portaudio +qt5"
+
+RDEPEND="
+ >=media-sound/jack-audio-connection-kit-0.109.2
+ qt5? ( dev-qt/qtcore:5 dev-qt/qtgui:5 )
+ !qt5? ( dev-qt/qtcore:4 dev-qt/qtgui:4 )
+ alsa? ( media-libs/alsa-lib )
+ dbus? ( dev-qt/qtdbus:4 )
+ portaudio? ( media-libs/portaudio )"
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog README TODO TRANSLATORS"
+
+src_configure() {
+ use qt5 && export PATH="$(qt5_get_bindir):${PATH}"
+ econf \
+ $(use_with !qt5 qt4 $(qt4_get_bindir)) \
+ $(use_with qt5 qt5 $(qt5_get_bindir)) \
+ $(use_enable alsa alsa-seq) \
+ $(use_enable dbus) \
+ $(use_enable debug) \
+ $(use_enable portaudio)
+
+ # Emulate what the Makefile does, so that we can get the correct
+ # compiler used.
+ if use qt5 ; then
+ eqmake5 ${PN}.pro -o ${PN}.mak
+ else
+ eqmake4 ${PN}.pro -o ${PN}.mak
+ fi
+}
+
+src_compile() {
+ emake -f ${PN}.mak
+}