summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-12-12 18:44:51 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-12-12 18:44:51 +0000
commit5631505b60b6dd296165ac2f485942108f072067 (patch)
tree1ff608159ac76fafc87c76278d5f6c6cd85df1ad /media-sound
parentVersion bump (diff)
downloadgentoo-2-5631505b60b6dd296165ac2f485942108f072067.tar.gz
gentoo-2-5631505b60b6dd296165ac2f485942108f072067.tar.bz2
gentoo-2-5631505b60b6dd296165ac2f485942108f072067.zip
version bump
(Portage version: 2.2_rc58/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/patchage/ChangeLog8
-rw-r--r--media-sound/patchage/files/ldconfig.patch14
-rw-r--r--media-sound/patchage/patchage-0.4.4.ebuild52
3 files changed, 73 insertions, 1 deletions
diff --git a/media-sound/patchage/ChangeLog b/media-sound/patchage/ChangeLog
index efd4e09880f7..dacffe72eb18 100644
--- a/media-sound/patchage/ChangeLog
+++ b/media-sound/patchage/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/patchage
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/patchage/ChangeLog,v 1.8 2009/08/02 21:12:43 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/patchage/ChangeLog,v 1.9 2009/12/12 18:44:51 aballier Exp $
+
+*patchage-0.4.4 (12 Dec 2009)
+
+ 12 Dec 2009; Alexis Ballier <aballier@gentoo.org> +patchage-0.4.4.ebuild,
+ +files/ldconfig.patch:
+ version bump
02 Aug 2009; <chainsaw@gentoo.org> patchage-0.4.2.ebuild:
Marked stable on AMD64 as requested by Alexis Ballier
diff --git a/media-sound/patchage/files/ldconfig.patch b/media-sound/patchage/files/ldconfig.patch
new file mode 100644
index 000000000000..f53ff9e7df59
--- /dev/null
+++ b/media-sound/patchage/files/ldconfig.patch
@@ -0,0 +1,14 @@
+Index: slv2-0.6.2/autowaf.py
+===================================================================
+--- slv2-0.6.2.orig/autowaf.py
++++ slv2-0.6.2/autowaf.py
+@@ -324,8 +324,5 @@ def build_dox(bld, name, version, srcdir
+ out1.command_is_external = True
+
+ def shutdown():
+- # This isn't really correct (for packaging), but people asking is annoying
+- if Options.commands['install']:
+- try: os.popen("/sbin/ldconfig")
+- except: pass
++ return
+
diff --git a/media-sound/patchage/patchage-0.4.4.ebuild b/media-sound/patchage/patchage-0.4.4.ebuild
new file mode 100644
index 000000000000..702f89778950
--- /dev/null
+++ b/media-sound/patchage/patchage-0.4.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/patchage/patchage-0.4.4.ebuild,v 1.1 2009/12/12 18:44:51 aballier Exp $
+
+EAPI=2
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Modular patch bay for audio and MIDI systems"
+HOMEPAGE="http://wiki.drobilla.net/Patchage"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug lash"
+
+RDEPEND=">=media-libs/raul-0.5.1
+ >=x11-libs/flowcanvas-0.5.1
+ >=dev-cpp/gtkmm-2.11.12
+ dev-cpp/glibmm
+ dev-cpp/libglademm
+ dev-cpp/libgnomecanvasmm
+ dev-libs/boost
+ >=media-sound/jack-audio-connection-kit-0.107
+ alsa? ( media-libs/alsa-lib )
+ lash? ( dev-libs/dbus-glib )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/ldconfig.patch"
+}
+
+src_configure() {
+ tc-export CC CXX CPP AR RANLIB
+ ./waf configure \
+ --prefix=/usr \
+ $(use debug && echo "--debug") \
+ $(use alsa || echo "--no-alsa") \
+ $(use lash || echo "--no-lash") \
+ || die
+}
+
+src_compile() {
+ ./waf || die
+}
+
+src_install() {
+ ./waf install --destdir="${D}" || die
+ dodoc AUTHORS README ChangeLog
+}