summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-06-20 09:10:29 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-06-20 09:10:29 +0000
commit53457d571808edfd0836b9f535603e22fff55587 (patch)
treea99f84342fd22939c035676a521b2f46dcf39b5d /media-sound
parentStable for sparc, wrt bug #473190 (diff)
downloadgentoo-2-53457d571808edfd0836b9f535603e22fff55587.tar.gz
gentoo-2-53457d571808edfd0836b9f535603e22fff55587.tar.bz2
gentoo-2-53457d571808edfd0836b9f535603e22fff55587.zip
Initial commit (bug #371773)
(Portage version: 2.2.0_alpha182/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/umurmur/ChangeLog12
-rw-r--r--media-sound/umurmur/files/umurmur.conf58
-rw-r--r--media-sound/umurmur/files/umurmurd.confd3
-rw-r--r--media-sound/umurmur/files/umurmurd.initd19
-rw-r--r--media-sound/umurmur/metadata.xml15
-rw-r--r--media-sound/umurmur/umurmur-0.2.13.ebuild74
6 files changed, 181 insertions, 0 deletions
diff --git a/media-sound/umurmur/ChangeLog b/media-sound/umurmur/ChangeLog
new file mode 100644
index 000000000000..ca7858637cf1
--- /dev/null
+++ b/media-sound/umurmur/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for media-sound/umurmur
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/umurmur/ChangeLog,v 1.1 2013/06/20 09:10:29 polynomial-c Exp $
+
+*umurmur-0.2.13 (20 Jun 2013)
+
+ 20 Jun 2013; Lars Wendler <polynomial-c@gentoo.org> +umurmur-0.2.13.ebuild,
+ +files/umurmur.conf, +files/umurmurd.confd, +files/umurmurd.initd,
+ +metadata.xml:
+ Initial commit. This fixes bug #371773 reported by Hans Nieser who also
+ contributed various files to the bug.
+
diff --git a/media-sound/umurmur/files/umurmur.conf b/media-sound/umurmur/files/umurmur.conf
new file mode 100644
index 000000000000..cebcca28a583
--- /dev/null
+++ b/media-sound/umurmur/files/umurmur.conf
@@ -0,0 +1,58 @@
+# This configuration is based on the official example configuration. More information can be found
+# at http://code.google.com/p/umurmur/wiki/Configuring02x
+
+max_bandwidth = 48000;
+welcometext = "Welcome to uMurmur!";
+certificate = "/etc/umurmur/cert.crt";
+private_key = "/etc/umurmur/key.key";
+password = "";
+max_users = 10;
+
+# Specify port and/or address to bind to. Typically not needed.
+# Default is '*' for address and 64738 for port.
+# Can also be specified on the command line, which takes precedence if
+# both are specified.
+# bindport = 64738;
+# bindaddr = "192.168.1.1";
+
+# Specify this for privilege dropping. If username is specified but not
+# the groupname, the user's login group is used.
+username = "murmur";
+groupname = "murmur";
+
+# Root channel must always be defined first.
+# If a channel has a parent, the parent must be defined before the child channel(s).
+channels = ( {
+ name = "Root";
+ parent = "";
+ description = "The Root of all channels";
+ noenter = true;
+ },
+ {
+ name = "Lobby";
+ parent = "Root";
+ description = "Lobby channel";
+ },
+ {
+ name = "Red team";
+ parent = "Lobby";
+ description = "The Red team channel";
+ },
+ {
+ name = "Blue team";
+ parent = "Lobby";
+ description = "The Blue team channel";
+ }
+);
+# Channel links configuration.
+channel_links = ( {
+ source = "Lobby";
+ destination = "Red team";
+ },
+ {
+ source = "Lobby";
+ destination = "Blue team";
+ }
+);
+
+default_channel = "Lobby";
diff --git a/media-sound/umurmur/files/umurmurd.confd b/media-sound/umurmur/files/umurmurd.confd
new file mode 100644
index 000000000000..d83461ce725d
--- /dev/null
+++ b/media-sound/umurmur/files/umurmurd.confd
@@ -0,0 +1,3 @@
+# Additional flags to be passed to umurmurd
+UMURMURD_OPTS="-r"
+
diff --git a/media-sound/umurmur/files/umurmurd.initd b/media-sound/umurmur/files/umurmurd.initd
new file mode 100644
index 000000000000..151f49e4c89d
--- /dev/null
+++ b/media-sound/umurmur/files/umurmurd.initd
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/umurmur/files/umurmurd.initd,v 1.1 2013/06/20 09:10:29 polynomial-c Exp $
+
+description="umurmurd - A minimalistic mumble server"
+pidfile="/run/umurmurd/umurmurd.pid"
+command="/usr/bin/umurmurd"
+command_args="-c /etc/umurmur/umurmur.conf -p ${pidfile} ${UMURMURD_OPTS}"
+start_stop_daemon_args="-p ${pidfile} -w 100"
+
+depend() {
+ need net
+ use logger
+}
+
+start_pre() {
+ checkpath -d -o murmur ${pidfile%/*}
+}
diff --git a/media-sound/umurmur/metadata.xml b/media-sound/umurmur/metadata.xml
new file mode 100644
index 000000000000..5b3fe5497165
--- /dev/null
+++ b/media-sound/umurmur/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>voip</herd>
+ <maintainer>
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <longdescription lang="en">
+ uMumble is a minimalistic Mumble server primarily targeted to run on routers with an open OS like OpenWRT. The server part of Mumble is called Murmur, hence the name uMurmur.
+ </longdescription>
+ <use>
+ <flag name='polarssl'>Use <pkg>net-libs/polarssl</pkg> instead of <pkg>dev-libs/openssl</pkg></flag>
+ </use>
+</pkgmetadata>
diff --git a/media-sound/umurmur/umurmur-0.2.13.ebuild b/media-sound/umurmur/umurmur-0.2.13.ebuild
new file mode 100644
index 000000000000..8e547a65d50b
--- /dev/null
+++ b/media-sound/umurmur/umurmur-0.2.13.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/umurmur/umurmur-0.2.13.ebuild,v 1.1 2013/06/20 09:10:29 polynomial-c Exp $
+
+EAPI=5
+
+inherit eutils user
+
+DESCRIPTION="Minimalistic Murmur (Mumble server)"
+HOMEPAGE="http://code.google.com/p/umurmur/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="polarssl"
+
+DEPEND=">=dev-libs/protobuf-c-0.14
+ dev-libs/libconfig
+ polarssl? ( >=net-libs/polarssl-1.0.0 )
+ !polarssl? ( dev-libs/openssl )"
+
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup murmur
+ enewuser murmur "" "" "" murmur
+}
+
+src_configure() {
+ local myconf
+
+ # build uses polarssl by default, but instead, make it use openssl
+ # unless polarssl is desired.
+ use !polarssl && myconf="${myconf} --with-ssl=openssl"
+
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newinitd "${FILESDIR}"/umurmurd.initd umurmurd
+ newconfd "${FILESDIR}"/umurmurd.confd umurmurd
+
+ dodoc AUTHORS ChangeLog
+ newdoc README.md README
+
+ # Some permissions are adjusted as the config may contain a server
+ # password, and /etc/umurmur will typically contain the cert and the
+ # key used to sign it, which are read after priveleges are dropped.
+ local confdir="/etc/umurmur"
+ dodir ${confdir}
+ fperms 0750 ${confdir}
+ fowners root:murmur ${confdir}
+
+ insinto ${confdir}
+ doins "${FILESDIR}"/umurmur.conf
+ fperms 0640 ${confdir}/umurmur.conf
+}
+
+pkg_postinst() {
+ elog "A configuration file has been installed at /etc/umurmur.conf - you may "
+ elog "want to review it. See also"
+ elog " http://code.google.com/p/umurmur/wiki/Configuring02x"
+
+ if use polarssl ; then
+ elog
+ elog "Because you have enabled PolarSSL support, umurmurd will use a"
+ elog "predefined test-certificate and key if none are configured, which"
+ elog "is insecure. See http://code.google.com/p/umurmur/wiki/Installing02x#Installing_uMurmur_with_PolarSSL_support"
+ elog "for more information on how to create your certificate and key"
+ fi
+}