summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-09-08 11:21:41 +0000
committerMamoru Komachi <usata@gentoo.org>2004-09-08 11:21:41 +0000
commit22c78359b8563fde44d7555f421d4b1b0cbe1a03 (patch)
tree2a6e473370cf6daa261a6472027e0fe427a08d3f /media-sound
parentRemoved ri from DEPEND, see bug #62521. (Manifest recommit) (diff)
downloadgentoo-2-22c78359b8563fde44d7555f421d4b1b0cbe1a03.tar.gz
gentoo-2-22c78359b8563fde44d7555f421d4b1b0cbe1a03.tar.bz2
gentoo-2-22c78359b8563fde44d7555f421d4b1b0cbe1a03.zip
Fixed missing doc problem. This closes bug #49381.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/museseq/ChangeLog5
-rw-r--r--media-sound/museseq/museseq-0.6.2-r1.ebuild18
2 files changed, 19 insertions, 4 deletions
diff --git a/media-sound/museseq/ChangeLog b/media-sound/museseq/ChangeLog
index f47da5e53ac1..9aae91b7c90a 100644
--- a/media-sound/museseq/ChangeLog
+++ b/media-sound/museseq/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/museseq
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/museseq/ChangeLog,v 1.14 2004/09/04 15:29:20 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/museseq/ChangeLog,v 1.15 2004/09/08 11:21:41 usata Exp $
+
+ 08 Sep 2004; Mamoru KOMACHI <usata@gentoo.org> museseq-0.6.2-r1.ebuild:
+ Fixed missing doc problem. This closes bug #49381.
04 Sep 2004; Chris White <chriswhite@gentoo.org> :
Fixed strange manifest errors.
diff --git a/media-sound/museseq/museseq-0.6.2-r1.ebuild b/media-sound/museseq/museseq-0.6.2-r1.ebuild
index 34156db82688..49c736085bfe 100644
--- a/media-sound/museseq/museseq-0.6.2-r1.ebuild
+++ b/media-sound/museseq/museseq-0.6.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/museseq/museseq-0.6.2-r1.ebuild,v 1.1 2004/07/11 22:21:52 fvdpol Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/museseq/museseq-0.6.2-r1.ebuild,v 1.2 2004/09/08 11:21:41 usata Exp $
inherit virtualx eutils kde-functions
need-qt 3
@@ -15,14 +15,16 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~amd64"
-IUSE="jack fluidsynth ladcca"
+IUSE="jack fluidsynth ladcca doc"
DEPEND="media-libs/alsa-lib \
>=media-libs/libsndfile-1.0.4 \
>=x11-libs/qt-3.1.0
ladcca? ( >=media-libs/ladcca-0.4.0 ) \
jack? ( media-sound/jack-audio-connection-kit ) \
- fluidsynth? ( media-sound/fluidsynth )"
+ fluidsynth? ( media-sound/fluidsynth )
+ doc? ( app-text/openjade
+ app-text/docbook-dsssl-stylesheets )"
S=${WORKDIR}/${MY_P}
@@ -44,6 +46,11 @@ src_compile() {
use ladcca || myconf="${myconf} --disable-ladcca"
use jack || myconf="${myconf} --disable-jack"
use fluidsynth || myconf="${myconf} --disable-fluidsynth"
+ if use doc ; then
+ # bug 49381
+ local stylesheets="$(echo /usr/share/sgml/docbook/dsssl-stylesheets-*)"
+ myconf="${myconf} --with-docbook-stylesheets=${stylesheets}"
+ fi
Xeconf ${myconf} || die "configure failed"
### borrowed from kde.eclass #
@@ -67,12 +74,17 @@ src_compile() {
addpredict /dev/dri/card*
emake || die
+ use doc && ( cd doc ; make manual )
}
src_install() {
make DESTDIR=${D} install || die
dodoc COPYING INSTALL README README.softsynth SECURITY TODO
+ mv ${D}/usr/share/muse/html ${D}/usr/share/doc/${PF}/html
+ dosym /usr/share/doc/${PF}/html /usr/share/muse/html
+ use doc && dohtml doc/*
+
# Name conflict with media-sound/muse. See bug #34973
mv ${D}/usr/bin/muse ${D}/usr/bin/lmuse
if [ ! -f /usr/bin/muse -o -L /usr/bin/muse ]; then