summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-01-29 10:28:47 +0000
committerPacho Ramos <pacho@gentoo.org>2015-01-29 10:28:47 +0000
commit84d77d341025e610a7a2cd97a4c0625788474fd2 (patch)
tree391201aacb72ac1cd97ed46659de7474b513d8ea /media-sound/terminatorx
parentdrop old (diff)
downloadgentoo-2-84d77d341025e610a7a2cd97a4c0625788474fd2.tar.gz
gentoo-2-84d77d341025e610a7a2cd97a4c0625788474fd2.tar.bz2
gentoo-2-84d77d341025e610a7a2cd97a4c0625788474fd2.zip
Use gnome2.eclass properly, fix compilation with current zlib (#413623), drop old
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-sound/terminatorx')
-rw-r--r--media-sound/terminatorx/ChangeLog13
-rw-r--r--media-sound/terminatorx/files/terminatorx-3.84-new-zlib.patch19
-rw-r--r--media-sound/terminatorx/terminatorx-3.84-r1.ebuild (renamed from media-sound/terminatorx/terminatorx-3.83.ebuild)29
-rw-r--r--media-sound/terminatorx/terminatorx-3.84.ebuild54
4 files changed, 49 insertions, 66 deletions
diff --git a/media-sound/terminatorx/ChangeLog b/media-sound/terminatorx/ChangeLog
index 752409be522a..ba0eb11fedf3 100644
--- a/media-sound/terminatorx/ChangeLog
+++ b/media-sound/terminatorx/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/terminatorx
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/terminatorx/ChangeLog,v 1.35 2012/05/05 09:02:12 mgorny Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/terminatorx/ChangeLog,v 1.36 2015/01/29 10:28:47 pacho Exp $
+
+*terminatorx-3.84-r1 (29 Jan 2015)
+
+ 29 Jan 2015; Pacho Ramos <pacho@gentoo.org>
+ +files/terminatorx-3.84-new-zlib.patch, +terminatorx-3.84-r1.ebuild,
+ -terminatorx-3.83.ebuild, -terminatorx-3.84.ebuild:
+ Use gnome2.eclass properly, fix compilation with current zlib (#413623), drop
+ old
05 May 2012; Michał Górny <mgorny@gentoo.org> terminatorx-3.82.ebuild,
terminatorx-3.83.ebuild, terminatorx-3.84.ebuild:
@@ -133,4 +141,3 @@
Submitted by Dietrich Heise <dietrich@pegestorf.de>
Thanks Dietrich
-
diff --git a/media-sound/terminatorx/files/terminatorx-3.84-new-zlib.patch b/media-sound/terminatorx/files/terminatorx-3.84-new-zlib.patch
new file mode 100644
index 000000000000..db05d7828d16
--- /dev/null
+++ b/media-sound/terminatorx/files/terminatorx-3.84-new-zlib.patch
@@ -0,0 +1,19 @@
+Description: Fix FTBFS errors with newer zlib.
+Author: Moritz Muehlenhoff <muehlenhoff@univention.de>
+Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=663053
+Forwarded: no
+---
+ src/tX_midiin.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- terminatorx.orig/src/tX_midiin.cc
++++ terminatorx/src/tX_midiin.cc
+@@ -447,7 +447,7 @@ gboolean tX_midiin::midi_learn_destroy(G
+
+ void tX_midiin::store_connections(FILE *rc, char *indent)
+ {
+- gzFile *rz=NULL;
++ gzFile rz=NULL;
+
+ tX_store("%s<midi_connections>\n", indent);
+
diff --git a/media-sound/terminatorx/terminatorx-3.83.ebuild b/media-sound/terminatorx/terminatorx-3.84-r1.ebuild
index 7d16815ce0e6..5dd776e5c118 100644
--- a/media-sound/terminatorx/terminatorx-3.83.ebuild
+++ b/media-sound/terminatorx/terminatorx-3.84-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/terminatorx/terminatorx-3.83.ebuild,v 1.2 2012/05/05 09:02:12 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/terminatorx/terminatorx-3.84-r1.ebuild,v 1.1 2015/01/29 10:28:47 pacho Exp $
-EAPI=2
+EAPI=5
+GCONF_DEBUG="no"
inherit gnome2 eutils
@@ -14,9 +15,10 @@ SRC_URI="http://www.terminatorx.org/dist/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="alsa mad vorbis sox"
+IUSE="alsa debug mad vorbis sox"
-RDEPEND="alsa? ( media-libs/alsa-lib )
+RDEPEND="
+ alsa? ( media-libs/alsa-lib )
mad? ( media-sound/madplay )
vorbis? ( media-libs/libvorbis )
sox? ( media-sound/sox
@@ -30,25 +32,34 @@ RDEPEND="alsa? ( media-libs/alsa-lib )
media-libs/ladspa-sdk
media-libs/ladspa-cmt
app-text/scrollkeeper
- media-libs/liblrdf"
+ media-libs/liblrdf
+"
DEPEND="${RDEPEND}
virtual/pkgconfig
x11-proto/xproto
x11-proto/inputproto
- x11-proto/xf86dgaproto"
+ x11-proto/xf86dgaproto
+"
S=${WORKDIR}/${MY_P}
+src_prepare() {
+ # Patch from debian to compile with recent zlib
+ epatch "${FILESDIR}"/${PN}-3.84-new-zlib.patch
+ gnome2_src_prepare
+}
+
src_configure() {
- econf \
+ gnome2_src_configure \
$(use_enable alsa) \
+ $(use_enable debug) \
$(use_enable mad) \
$(use_enable vorbis) \
$(use_enable sox)
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
+ gnome2_src_install
newicon gnome-support/terminatorX-app.png terminatorX.png
make_desktop_entry terminatorX terminatorX terminatorX AudioVideo
}
diff --git a/media-sound/terminatorx/terminatorx-3.84.ebuild b/media-sound/terminatorx/terminatorx-3.84.ebuild
deleted file mode 100644
index 85fe9894e8f1..000000000000
--- a/media-sound/terminatorx/terminatorx-3.84.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/terminatorx/terminatorx-3.84.ebuild,v 1.2 2012/05/05 09:02:12 mgorny Exp $
-
-EAPI=4
-
-inherit gnome2 eutils
-
-MY_P=${P/terminatorx/terminatorX}
-DESCRIPTION='realtime audio synthesizer that allows you to "scratch" on digitally sampled audio data'
-HOMEPAGE="http://www.terminatorx.org/"
-SRC_URI="http://www.terminatorx.org/dist/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="alsa mad vorbis sox"
-
-RDEPEND="alsa? ( media-libs/alsa-lib )
- mad? ( media-sound/madplay )
- vorbis? ( media-libs/libvorbis )
- sox? ( media-sound/sox
- media-sound/mpg123 )
- >=x11-libs/gtk+-2.2:2
- >=dev-libs/glib-2.2:2
- x11-libs/libXi
- x11-libs/libXxf86dga
- dev-libs/libxml2
- media-libs/audiofile
- media-libs/ladspa-sdk
- media-libs/ladspa-cmt
- app-text/scrollkeeper
- media-libs/liblrdf"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- x11-proto/xproto
- x11-proto/inputproto
- x11-proto/xf86dgaproto"
-
-S=${WORKDIR}/${MY_P}
-
-src_configure() {
- econf \
- $(use_enable alsa) \
- $(use_enable mad) \
- $(use_enable vorbis) \
- $(use_enable sox)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- newicon gnome-support/terminatorX-app.png terminatorX.png
- make_desktop_entry terminatorX terminatorX terminatorX AudioVideo
-}