summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Parpart <trapni@gentoo.org>2010-01-03 15:53:31 +0000
committerChristian Parpart <trapni@gentoo.org>2010-01-03 15:53:31 +0000
commit9ff2a0818de7471555267228cda2025ee934c608 (patch)
tree7105aeb93f3192e1713066c3331b60fc429dc34e /media-sound/teamspeak-client-bin
parentFiles were not being cleaned from package.mask. Remove old version (diff)
downloadgentoo-2-9ff2a0818de7471555267228cda2025ee934c608.tar.gz
gentoo-2-9ff2a0818de7471555267228cda2025ee934c608.tar.bz2
gentoo-2-9ff2a0818de7471555267228cda2025ee934c608.zip
version bump
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/teamspeak-client-bin')
-rw-r--r--media-sound/teamspeak-client-bin/ChangeLog10
-rw-r--r--media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.0_beta9.ebuild54
2 files changed, 62 insertions, 2 deletions
diff --git a/media-sound/teamspeak-client-bin/ChangeLog b/media-sound/teamspeak-client-bin/ChangeLog
index a1ca3863e1af..a64f154161e6 100644
--- a/media-sound/teamspeak-client-bin/ChangeLog
+++ b/media-sound/teamspeak-client-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/teamspeak-client-bin
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/teamspeak-client-bin/ChangeLog,v 1.1 2009/12/23 11:31:49 trapni Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/teamspeak-client-bin/ChangeLog,v 1.2 2010/01/03 15:53:31 trapni Exp $
+
+*teamspeak-client-bin-3.0.0_beta9 (03 Jan 2010)
+
+ 03 Jan 2010; Christian Parpart <trapni@gentoo.org>
+ +teamspeak-client-bin-3.0.0_beta9.ebuild:
+ version bump
*teamspeak-client-bin-3.0.0_beta5 (23 Dec 2009)
diff --git a/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.0_beta9.ebuild b/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.0_beta9.ebuild
new file mode 100644
index 000000000000..646c545425d8
--- /dev/null
+++ b/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.0_beta9.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.0_beta9.ebuild,v 1.1 2010/01/03 15:53:31 trapni Exp $
+
+# NOTE: The comments in this file are for instruction and documentation.
+# They're not meant to appear with your final, production ebuild. Please
+# remember to remove them before submitting or committing your ebuild. That
+# doesn't mean you can't add your own comments though.
+
+# The 'Header' on the third line should just be left alone. When your ebuild
+# will be committed to cvs, the details on that line will be automatically
+# generated to contain the correct data.
+
+EAPI=1
+
+inherit eutils
+
+DESCRIPTION="TeamSpeak Client - Voice Communication Software"
+HOMEPAGE="http://teamspeak.com/"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="builtin-qt"
+RESTRICT="strip"
+PROPERTIES="interactive"
+
+SRC_URI="
+ amd64? ( http://ftp.4players.de/pub/hosted/ts3/releases/beta-9/TeamSpeak3-Client-linux_amd64-${PV/_/-}.run )
+ x86? ( http://ftp.4players.de/pub/hosted/ts3/releases/beta-9/TeamSpeak3-Client-linux_x86-${PV/_/-}.run )
+"
+
+DEPEND="!builtin-qt? ( x11-libs/qt-core:4 x11-libs/qt-gui:4 )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ # TODO: unpack_makeself -- use this version once it supports makeself 2.1.6
+ for i in ${A}; do
+ sh "${DISTDIR}/${i}" --target "${WORKDIR}" || die "unpack failed"
+ done
+}
+
+src_install() {
+ local dest="${D}/opt/teamspeak3-client"
+
+ mkdir -p "${dest}"
+ cp -R "${WORKDIR}/"* "${dest}/" || die
+
+ exeinto /usr/bin
+ doexe "${FILESDIR}/teamspeak3"
+
+ mv "${dest}/ts3client_linux_"* "${dest}/ts3client"
+
+ useq builtin-qt || rm "${dest}"/libQt*
+}