summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-02-07 10:24:16 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-02-07 10:24:16 +0000
commitdcc7c23244971a74e6b99e926959df4c5df56e96 (patch)
tree709f36a4bb1f10dbcd18d3112ac7e88395f05a02 /media-sound/nted
parentVersion bump (diff)
downloadgentoo-2-dcc7c23244971a74e6b99e926959df4c5df56e96.tar.gz
gentoo-2-dcc7c23244971a74e6b99e926959df4c5df56e96.tar.bz2
gentoo-2-dcc7c23244971a74e6b99e926959df4c5df56e96.zip
Version bump. Fixes bug #301543 and bug #295760
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/nted')
-rw-r--r--media-sound/nted/ChangeLog10
-rw-r--r--media-sound/nted/nted-1.9.16.ebuild37
2 files changed, 45 insertions, 2 deletions
diff --git a/media-sound/nted/ChangeLog b/media-sound/nted/ChangeLog
index dd748abf021a..eb81e075ea3a 100644
--- a/media-sound/nted/ChangeLog
+++ b/media-sound/nted/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/nted
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/nted/ChangeLog,v 1.9 2009/12/20 19:11:42 hwoarang Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/nted/ChangeLog,v 1.10 2010/02/07 10:24:16 hwoarang Exp $
+
+*nted-1.9.16 (07 Feb 2010)
+
+ 07 Feb 2010; Markos Chandras <hwoarang@gentoo.org> +nted-1.9.16.ebuild:
+ Version bump ( bug #301543 ). Fix documentation installation ( bug #295760
+ ).
*nted-1.9.13 (20 Dec 2009)
diff --git a/media-sound/nted/nted-1.9.16.ebuild b/media-sound/nted/nted-1.9.16.ebuild
new file mode 100644
index 000000000000..0a8dbc1a5a43
--- /dev/null
+++ b/media-sound/nted/nted-1.9.16.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/nted/nted-1.9.16.ebuild,v 1.1 2010/02/07 10:24:16 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="WYSIWYG score editor for GTK+2"
+HOMEPAGE="http://vsr.informatik.tu-chemnitz.de/staff/jan/nted/nted.xhtml"
+SRC_URI="http://vsr.informatik.tu-chemnitz.de/staff/jan/${PN}/sources/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc nls debug"
+RDEPEND="doc? ( gnome-extra/yelp app-text/xmlto )
+ x11-libs/cairo
+ x11-libs/gtk+:2
+ media-libs/alsa-lib"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf $(use_with doc) \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ --docdir=/usr/share/doc/${PF}
+
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ABOUT_* ChangeLog FAQ NEWS README || die "dodoc failed"
+ doman "man/${PN}.1" || die "doman failed"
+}