summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-03-04 17:21:13 +0000
committerJeroen Roovers <jer@gentoo.org>2015-03-04 17:21:13 +0000
commiteb69748e6906ec3641f3bc019357508670300076 (patch)
treea04b3c530db8b9fe016b0095374effd91a364211 /media-sound/ncmpcpp
parentRemove old. (diff)
downloadgentoo-2-eb69748e6906ec3641f3bc019357508670300076.tar.gz
gentoo-2-eb69748e6906ec3641f3bc019357508670300076.tar.bz2
gentoo-2-eb69748e6906ec3641f3bc019357508670300076.zip
Version bump.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'media-sound/ncmpcpp')
-rw-r--r--media-sound/ncmpcpp/ChangeLog8
-rw-r--r--media-sound/ncmpcpp/ncmpcpp-0.6.3.ebuild65
-rw-r--r--media-sound/ncmpcpp/ncmpcpp-9999.ebuild8
3 files changed, 75 insertions, 6 deletions
diff --git a/media-sound/ncmpcpp/ChangeLog b/media-sound/ncmpcpp/ChangeLog
index 63c3f3cabef6..960d5a02aa70 100644
--- a/media-sound/ncmpcpp/ChangeLog
+++ b/media-sound/ncmpcpp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/ncmpcpp
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ncmpcpp/ChangeLog,v 1.108 2015/02/27 11:06:09 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ncmpcpp/ChangeLog,v 1.109 2015/03/04 17:21:13 jer Exp $
+
+*ncmpcpp-0.6.3 (04 Mar 2015)
+
+ 04 Mar 2015; Jeroen Roovers <jer@gentoo.org> +ncmpcpp-0.6.3.ebuild,
+ ncmpcpp-9999.ebuild:
+ Version bump.
27 Feb 2015; Agostino Sarubbo <ago@gentoo.org> ncmpcpp-0.6.2.ebuild:
Stable for sparc, wrt bug #537110
diff --git a/media-sound/ncmpcpp/ncmpcpp-0.6.3.ebuild b/media-sound/ncmpcpp/ncmpcpp-0.6.3.ebuild
new file mode 100644
index 000000000000..96412c697a82
--- /dev/null
+++ b/media-sound/ncmpcpp/ncmpcpp-0.6.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ncmpcpp/ncmpcpp-0.6.3.ebuild,v 1.1 2015/03/04 17:21:13 jer Exp $
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="featureful ncurses based MPD client inspired by ncmpc"
+HOMEPAGE="http://ncmpcpp.rybczak.net/"
+SRC_URI="http://ncmpcpp.rybczak.net/stable/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+IUSE="clock curl outputs taglib unicode visualizer"
+
+RDEPEND="
+ >=media-libs/libmpdclient-2.1
+ curl? ( net-misc/curl )
+ dev-libs/boost:=[nls,threads]
+ sys-libs/ncurses[unicode?]
+ sys-libs/readline:*
+ taglib? ( media-libs/taglib )
+ visualizer? ( sci-libs/fftw:3.0 )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i -e '/^docdir/d' {,doc/}Makefile{.am,.in} || die
+ sed -i -e 's|COPYING||g' Makefile{.am,.in} || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable clock) \
+ $(use_enable outputs) \
+ $(use_enable unicode) \
+ $(use_enable visualizer) \
+ $(use_with curl) \
+ $(use_with taglib) \
+ $(use_with visualizer fftw) \
+ --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+
+ dodoc doc/{bindings,config}
+}
+
+pkg_postinst() {
+ echo
+ elog "Example configuration files have been installed at"
+ elog "${ROOT}usr/share/doc/${PF}"
+ elog "${P} uses ~/.ncmpcpp/config and ~/.ncmpcpp/bindings"
+ elog "as user configuration files."
+ echo
+ if use visualizer; then
+ elog "If you want to use the visualizer, you need mpd with fifo enabled."
+ echo
+ fi
+}
diff --git a/media-sound/ncmpcpp/ncmpcpp-9999.ebuild b/media-sound/ncmpcpp/ncmpcpp-9999.ebuild
index 3b2286808eba..e2ce2749e880 100644
--- a/media-sound/ncmpcpp/ncmpcpp-9999.ebuild
+++ b/media-sound/ncmpcpp/ncmpcpp-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ncmpcpp/ncmpcpp-9999.ebuild,v 1.8 2015/01/03 09:59:39 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ncmpcpp/ncmpcpp-9999.ebuild,v 1.9 2015/03/04 17:21:13 jer Exp $
EAPI=5
-inherit autotools bash-completion-r1 eutils git-r3
+inherit autotools eutils git-r3
DESCRIPTION="featureful ncurses based MPD client inspired by ncmpc"
HOMEPAGE="http://ncmpcpp.rybczak.net/"
@@ -20,7 +20,7 @@ RDEPEND="
curl? ( net-misc/curl )
dev-libs/boost:=[nls,threads]
sys-libs/ncurses[unicode?]
- sys-libs/readline
+ sys-libs/readline:*
taglib? ( media-libs/taglib )
visualizer? ( sci-libs/fftw:3.0 )
"
@@ -51,8 +51,6 @@ src_install() {
default
dodoc doc/{bindings,config}
-
- newbashcomp doc/${PN}-completion.bash ${PN}
}
pkg_postinst() {