summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-07-03 16:46:30 +0000
committerPacho Ramos <pacho@gentoo.org>2010-07-03 16:46:30 +0000
commit1b2c8ecf79165f7fa3b05e714d555b73c01c07ab (patch)
tree43e0713bf1ae88f293fe8beba6f51f0237001b6c /media-sound/muine
parentAdd ~ia64/~sparc wrt #324867 (diff)
downloadgentoo-2-1b2c8ecf79165f7fa3b05e714d555b73c01c07ab.tar.gz
gentoo-2-1b2c8ecf79165f7fa3b05e714d555b73c01c07ab.tar.bz2
gentoo-2-1b2c8ecf79165f7fa3b05e714d555b73c01c07ab.zip
Revision bump with bugfixes
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/muine')
-rw-r--r--media-sound/muine/ChangeLog16
-rw-r--r--media-sound/muine/files/muine-0.8.11-drop-deprecated.patch31
-rw-r--r--media-sound/muine/files/muine-0.8.11-multimedia-keys.patch26
-rw-r--r--media-sound/muine/muine-0.8.10.ebuild88
-rw-r--r--media-sound/muine/muine-0.8.11-r1.ebuild (renamed from media-sound/muine/muine-0.8.11.ebuild)33
5 files changed, 97 insertions, 97 deletions
diff --git a/media-sound/muine/ChangeLog b/media-sound/muine/ChangeLog
index f777c73031ed..9977a1a9b294 100644
--- a/media-sound/muine/ChangeLog
+++ b/media-sound/muine/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for media-sound/muine
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/muine/ChangeLog,v 1.57 2009/09/27 16:35:35 nixnut Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/muine/ChangeLog,v 1.58 2010/07/03 16:46:30 pacho Exp $
+
+*muine-0.8.11-r1 (03 Jul 2010)
+
+ 03 Jul 2010; Pacho Ramos <pacho@gentoo.org> -muine-0.8.10.ebuild,
+ -muine-0.8.11.ebuild, +muine-0.8.11-r1.ebuild,
+ +files/muine-0.8.11-drop-deprecated.patch,
+ +files/muine-0.8.11-multimedia-keys.patch:
+ Revision bump: fix dependencies (bug #292912 by gentoo_m), install docs in
+ proper place (bug #295173 by Diego E. 'Flameeyes' Pettenò), fix
+ multimedia key support broken since Gnome 2.22, replace deprecated gtk
+ functions letting this work with gtk+-2.20, fix missing icons and
+ intltoolize broken file, install gconf schemas properly. Remove old.
27 Sep 2009; nixnut <nixnut@gentoo.org> muine-0.8.10-r1.ebuild:
ppc stable #283739
diff --git a/media-sound/muine/files/muine-0.8.11-drop-deprecated.patch b/media-sound/muine/files/muine-0.8.11-drop-deprecated.patch
new file mode 100644
index 000000000000..fa4b6d8ca2d8
--- /dev/null
+++ b/media-sound/muine/files/muine-0.8.11-drop-deprecated.patch
@@ -0,0 +1,31 @@
+From 86e885f1f17db2ec3caa31b0ff7955dfe2b4e543 Mon Sep 17 00:00:00 2001
+From: daniel g. siegel <dgsiegel@gnome.org>
+Date: Tue, 27 Apr 2010 18:22:57 +0000
+Subject: replace some deprecated gtk functions
+
+use gtk_widget_has_focus instead of GTK_WIDGET_HAS_FOCUS and
+gtk_widget_get_state instead of GTK_WIDGET_STATE
+---
+diff --git a/libmuine/rb-cell-renderer-pixbuf.c b/libmuine/rb-cell-renderer-pixbuf.c
+index 42cff41..abf6958 100644
+--- a/libmuine/rb-cell-renderer-pixbuf.c
++++ b/libmuine/rb-cell-renderer-pixbuf.c
+@@ -295,14 +295,14 @@ rb_cell_renderer_pixbuf_render (GtkCellRenderer *cell,
+
+ if ((flags & GTK_CELL_RENDERER_SELECTED) == GTK_CELL_RENDERER_SELECTED)
+ {
+- if (GTK_WIDGET_HAS_FOCUS (widget))
++ if (gtk_widget_has_focus (widget))
+ state = GTK_STATE_SELECTED;
+ else
+ state = GTK_STATE_ACTIVE;
+ }
+ else
+ {
+- if (GTK_WIDGET_STATE (widget) == GTK_STATE_INSENSITIVE)
++ if (gtk_widget_get_state (widget) == GTK_STATE_INSENSITIVE)
+ state = GTK_STATE_INSENSITIVE;
+ else
+ state = GTK_STATE_NORMAL;
+--
+cgit v0.8.3.1
diff --git a/media-sound/muine/files/muine-0.8.11-multimedia-keys.patch b/media-sound/muine/files/muine-0.8.11-multimedia-keys.patch
new file mode 100644
index 000000000000..5bce0ca765c0
--- /dev/null
+++ b/media-sound/muine/files/muine-0.8.11-multimedia-keys.patch
@@ -0,0 +1,26 @@
+From d4dd66d73885db1b2aea2a267197413559bed5bc Mon Sep 17 00:00:00 2001
+From: Priit Laes <plaes@plaes.org>
+Date: Wed, 16 Sep 2009 21:30:06 +0000
+Subject: Fix multimedia key support for >=Gnome-2.22
+
+---
+diff --git a/src/GnomeMMKeys.cs b/src/GnomeMMKeys.cs
+index dd99718..af5419a 100644
+--- a/src/GnomeMMKeys.cs
++++ b/src/GnomeMMKeys.cs
+@@ -37,11 +37,11 @@ namespace Muine
+ public class GnomeMMKeys : IDisposable
+ {
+ private const string BusName = "org.gnome.SettingsDaemon";
+- private const string ObjectPath = "/org/gnome/SettingsDaemon";
++ private const string ObjectPath = "/org/gnome/SettingsDaemon/MediaKeys";
+
+ private delegate void MediaPlayerKeyPressedHandler(string application, string key);
+
+- [Interface("org.gnome.SettingsDaemon")]
++ [Interface("org.gnome.SettingsDaemon.MediaKeys")]
+ private interface ISettingsDaemon
+ {
+ void GrabMediaPlayerKeys(string application, uint time);
+--
+cgit v0.8.3.1
diff --git a/media-sound/muine/muine-0.8.10.ebuild b/media-sound/muine/muine-0.8.10.ebuild
deleted file mode 100644
index 0f4ba0010c5f..000000000000
--- a/media-sound/muine/muine-0.8.10.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/muine/muine-0.8.10.ebuild,v 1.7 2009/04/05 21:39:24 loki_val Exp $
-
-EAPI=2
-
-inherit base gnome2 mono eutils multilib flag-o-matic
-
-DESCRIPTION="A music player for GNOME"
-HOMEPAGE="http://muine-player.org"
-SRC_URI="http://download.gnome.org/sources/muine/0.8/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="flac mad vorbis xine"
-
-RDEPEND="x11-themes/gnome-icon-theme
- >=dev-lang/mono-2
- >=x11-libs/gtk+-2.6
- >=dev-dotnet/gtk-sharp-2.12.6
- >=dev-dotnet/glade-sharp-2.12.6
- >=dev-dotnet/gnome-sharp-2.6
- >=dev-dotnet/gconf-sharp-2.6
- >=dev-dotnet/gnomevfs-sharp-2.6
- >=dev-dotnet/dbus-sharp-0.4
- >=dev-dotnet/dbus-glib-sharp-0.3
- sys-libs/gdbm
- >=media-libs/flac-1.1.2
- >=media-libs/libvorbis-1
- >=media-libs/libid3tag-0.15.0b
- xine? ( >=media-libs/xine-lib-1 )
- !xine? (
- =media-libs/gstreamer-0.10*
- =media-libs/gst-plugins-base-0.10*
- =media-libs/gst-plugins-good-0.10*
- =media-plugins/gst-plugins-gconf-0.10*
- =media-plugins/gst-plugins-gnomevfs-0.10*
- flac? ( =media-plugins/gst-plugins-flac-0.10* )
- mad? ( =media-plugins/gst-plugins-mad-0.10* )
- vorbis? ( =media-plugins/gst-plugins-ogg-0.10*
- =media-plugins/gst-plugins-vorbis-0.10* )
- )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- app-text/scrollkeeper
- gnome-base/gnome-common
- >=dev-util/intltool-0.29
- virtual/monodoc"
-
-DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS PLUGINS README TODO"
-
-PATCHES=( "${FILESDIR}/${P}-buttons.patch" )
-
-# The build is not parallel safe
-MAKEOPTS="${MAKEOPTS} -j1"
-
-src_unpack() {
- gnome2_src_unpack
-}
-
-src_prepare() {
- base_src_prepare
-
-}
-
-src_configure() {
- gnome2_src_configure --enable-compile-warnings=yes --disable-faad2 $(use_enable xine)
-}
-
-src_compile() {
- default
-}
-
-src_install() {
- gnome2_src_install
- insinto /usr/$(get_libdir)/${PN}/plugins
- doins "${S}"/plugins/TrayIcon.dll
-}
-
-pkg_postinst() {
- elog
- elog "Upstream no longer packages the tray icon plugin by default."
- elog "The Gentoo ebuilds will continue to install the plugin, if you don't"
- elog "want to use the plugin, remove TrayIcon.dll from"
- elog "/usr/$(get_libdir)/muine/plugins/"
- elog
-}
diff --git a/media-sound/muine/muine-0.8.11.ebuild b/media-sound/muine/muine-0.8.11-r1.ebuild
index 15400f7297f8..4247ee26ad2e 100644
--- a/media-sound/muine/muine-0.8.11.ebuild
+++ b/media-sound/muine/muine-0.8.11-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/muine/muine-0.8.11.ebuild,v 1.1 2009/09/13 20:17:20 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/muine/muine-0.8.11-r1.ebuild,v 1.1 2010/07/03 16:46:30 pacho Exp $
EAPI=2
@@ -26,10 +26,8 @@ RDEPEND="
>=dev-dotnet/gnomevfs-sharp-2.6
>=dev-dotnet/dbus-sharp-0.4
>=dev-dotnet/dbus-glib-sharp-0.3
+ >=dev-dotnet/taglib-sharp-2.0.3
sys-libs/gdbm
- >=media-libs/flac-1.1.2
- >=media-libs/libvorbis-1
- >=media-libs/libid3tag-0.15.0b
=media-libs/gstreamer-0.10*
=media-libs/gst-plugins-base-0.10*
=media-libs/gst-plugins-good-0.10*
@@ -51,8 +49,28 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS PLUGINS README TODO"
-src_configure() {
- gnome2_src_configure --enable-compile-warnings=yes
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-compile-warnings=yes
+ --docdir=/usr/share/doc/"${PF}"
+ "
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix multimedia key support for >=Gnome-2.22
+ epatch "${FILESDIR}/${P}-multimedia-keys.patch"
+
+ # Replace some deprecated gtk functions
+ epatch "${FILESDIR}/${P}-drop-deprecated.patch"
+
+ # Update icons, upstream bug #623480
+ sed "s:stock_timer:list-add:g" -i src/AddWindow.cs src/StockIcons.cs || die
+
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in \
+ || die "sed failed"
}
src_install() {
@@ -62,6 +80,7 @@ src_install() {
}
pkg_postinst() {
+ gnome2_pkg_postinst
elog
elog "Upstream no longer packages the tray icon plugin by default."
elog "The Gentoo ebuilds will continue to install the plugin, if you don't"