summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-09 17:13:54 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-09 17:13:54 +0000
commita9616335928cc3dbe16a96eb79ba3745ca1f05a2 (patch)
treef292b232fdc2bdf998136e0cf8d493d4c0017e30 /media-sound/mp3blaster
parentx86 stable wrt bug #396359 (diff)
downloadgentoo-2-a9616335928cc3dbe16a96eb79ba3745ca1f05a2.tar.gz
gentoo-2-a9616335928cc3dbe16a96eb79ba3745ca1f05a2.tar.bz2
gentoo-2-a9616335928cc3dbe16a96eb79ba3745ca1f05a2.zip
Fix building with USE="sid" and sys-devel/gcc >= 4.4.x wrt #362347 by "Boris". Remove deprecated media-sound/esound support. One of USE oss or sdl must be enabled; use REQUIRED_USE
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/mp3blaster')
-rw-r--r--media-sound/mp3blaster/ChangeLog10
-rw-r--r--media-sound/mp3blaster/files/mp3blaster-3.2.5-gcc44.patch13
-rw-r--r--media-sound/mp3blaster/mp3blaster-3.2.5.ebuild52
3 files changed, 44 insertions, 31 deletions
diff --git a/media-sound/mp3blaster/ChangeLog b/media-sound/mp3blaster/ChangeLog
index 15342a7f34c1..2da5357a91fe 100644
--- a/media-sound/mp3blaster/ChangeLog
+++ b/media-sound/mp3blaster/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/mp3blaster
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3blaster/ChangeLog,v 1.50 2010/11/01 01:53:47 xmw Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3blaster/ChangeLog,v 1.51 2012/01/09 17:13:54 ssuominen Exp $
+
+ 09 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> mp3blaster-3.2.5.ebuild,
+ +files/mp3blaster-3.2.5-gcc44.patch:
+ Fix building with USE="sid" and sys-devel/gcc >= 4.4.x wrt #362347 by
+ "Boris". Remove deprecated media-sound/esound support. One of USE oss or sdl
+ must be enabled; use REQUIRED_USE
01 Nov 2010; Michael Weber <xmw@gentoo.org> mp3blaster-3.2.5.ebuild:
arm stable
diff --git a/media-sound/mp3blaster/files/mp3blaster-3.2.5-gcc44.patch b/media-sound/mp3blaster/files/mp3blaster-3.2.5-gcc44.patch
new file mode 100644
index 000000000000..fc1a6c8d053e
--- /dev/null
+++ b/media-sound/mp3blaster/files/mp3blaster-3.2.5-gcc44.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/362347
+
+--- src/global.cc
++++ src/global.cc
+@@ -371,7 +371,7 @@
+ is_sid(const char *filename)
+ {
+ #ifdef HAVE_SIDPLAYER
+- char *ext = strrchr(filename, '.');
++ const char *ext = strrchr(filename, '.');
+ if (ext) {
+ if (!strcasecmp(ext, ".psid")) return 1;
+ if (!strcasecmp(ext, ".sid")) return 1;
diff --git a/media-sound/mp3blaster/mp3blaster-3.2.5.ebuild b/media-sound/mp3blaster/mp3blaster-3.2.5.ebuild
index 5ba10e791ab9..c438e4cd91b3 100644
--- a/media-sound/mp3blaster/mp3blaster-3.2.5.ebuild
+++ b/media-sound/mp3blaster/mp3blaster-3.2.5.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3blaster/mp3blaster-3.2.5.ebuild,v 1.8 2010/11/01 01:53:47 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3blaster/mp3blaster-3.2.5.ebuild,v 1.9 2012/01/09 17:13:54 ssuominen Exp $
+EAPI=4
inherit eutils
DESCRIPTION="Text console based program for playing audio files"
@@ -11,33 +12,29 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="esd lirc oss sdl sid vorbis"
+IUSE="lirc oss sdl sid vorbis"
-RDEPEND=">=sys-libs/ncurses-5.2
+RDEPEND=">=sys-libs/ncurses-5.7-r7
lirc? ( app-misc/lirc )
- vorbis? ( >=media-libs/libvorbis-1 )
+ sdl? ( media-libs/libsdl )
sid? ( =media-libs/libsidplay-1* )
- esd? ( media-sound/esound )
- sdl? ( media-libs/libsdl )"
+ vorbis? ( >=media-libs/libvorbis-1 )"
DEPEND="${RDEPEND}
x11-misc/imake"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # File collision with media-sound/splay.
- sed -i -e "s:splay.1:splay_mp3blaster.1:" Makefile.in
- mv splay.1 splay_mp3blaster.1
-}
+REQUIRED_USE="|| ( oss sdl )"
+
+DOCS="AUTHORS BUGS ChangeLog CREDITS FAQ NEWS README TODO"
-src_compile() {
- local myconf
- if ! use esd && ! use sdl && ! use oss ; then
- ewarn "You've disabled esd, sdl, and oss. Enabling oss for you."
- myconf="--with-oss"
- fi
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+ # file collision with media-sound/splay
+ sed -i -e 's:splay.1:splay_mp3blaster.1:' Makefile.in || die
+ mv -vf splay.1 splay_mp3blaster.1 || die
+}
- # newthreads and libpth support is broken.
+src_configure() {
+ # libpth and newthreads support are both broken
econf \
--disable-newthreads \
--without-pth \
@@ -45,16 +42,13 @@ src_compile() {
$(use_with lirc) \
$(use_with vorbis oggvorbis) \
$(use_with sid sidplay) \
- $(use_with esd) \
+ --without-esd \
$(use_with sdl) \
- $(use_with oss) \
- ${myconf}
- emake || die "emake failed."
+ $(use_with oss)
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
- # File collision with media-sound/splay.
- mv "${D}"/usr/bin/splay "${D}"/usr/bin/splay_mp3blaster || die
- dodoc AUTHORS BUGS ChangeLog CREDITS FAQ NEWS README TODO
+ default
+ # file collision with media-sound/splay
+ mv -vf "${ED}"usr/bin/splay "${ED}"usr/bin/splay_mp3blaster || die
}