summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-06-06 16:51:58 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-06-06 16:51:58 +0000
commit6059c129a3b0563f934d0b28ca1dfe57258661d7 (patch)
treebb7710cbf60a9fd7801a537b977996c078b532d6 /media-sound/mimd
parentppc stable #271954 (diff)
downloadgentoo-2-6059c129a3b0563f934d0b28ca1dfe57258661d7.tar.gz
gentoo-2-6059c129a3b0563f934d0b28ca1dfe57258661d7.tar.bz2
gentoo-2-6059c129a3b0563f934d0b28ca1dfe57258661d7.zip
Fix compile with _FORTIFY_SOURCE=2 wrt #272512, thanks to Diego E. Pettenò.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/mimd')
-rw-r--r--media-sound/mimd/ChangeLog9
-rw-r--r--media-sound/mimd/files/mimd-0.30.1-fortify_sources.patch12
-rw-r--r--media-sound/mimd/mimd-0.30.1.ebuild27
3 files changed, 33 insertions, 15 deletions
diff --git a/media-sound/mimd/ChangeLog b/media-sound/mimd/ChangeLog
index 1bfdf1bf8d77..0bdad22d0a2c 100644
--- a/media-sound/mimd/ChangeLog
+++ b/media-sound/mimd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/mimd
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mimd/ChangeLog,v 1.3 2007/01/05 17:34:26 flameeyes Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mimd/ChangeLog,v 1.4 2009/06/06 16:51:58 ssuominen Exp $
+
+ 06 Jun 2009; Samuli Suominen <ssuominen@gentoo.org> mimd-0.30.1.ebuild,
+ +files/mimd-0.30.1-fortify_sources.patch:
+ Fix compile with _FORTIFY_SOURCE=2 wrt #272512, thanks to Diego E.
+ Pettenò.
05 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> mimd-0.30.1.ebuild:
Convert to use elog.
diff --git a/media-sound/mimd/files/mimd-0.30.1-fortify_sources.patch b/media-sound/mimd/files/mimd-0.30.1-fortify_sources.patch
new file mode 100644
index 000000000000..74a1e76560b1
--- /dev/null
+++ b/media-sound/mimd/files/mimd-0.30.1-fortify_sources.patch
@@ -0,0 +1,12 @@
+diff -ur mimd-0.30.1.orig/src/parser.cpp mimd-0.30.1/src/parser.cpp
+--- mimd-0.30.1.orig/src/parser.cpp 2003-07-10 21:35:52.000000000 +0300
++++ mimd-0.30.1/src/parser.cpp 2009-06-06 19:49:56.000000000 +0300
+@@ -37,7 +37,7 @@
+ int fd;
+
+ // Check to see if we can make a scratch file in the directory
+- if((fd=open(tf.c_str(), O_RDWR|O_CREAT|O_TRUNC)) == -1)
++ if((fd=open(tf.c_str(), O_RDWR|O_CREAT|O_TRUNC, S_IRUSR|S_IWUSR)) == -1)
+ return false;
+
+ // Close and delete the test file
diff --git a/media-sound/mimd/mimd-0.30.1.ebuild b/media-sound/mimd/mimd-0.30.1.ebuild
index f1e03e5074b4..4bebf27b28e4 100644
--- a/media-sound/mimd/mimd-0.30.1.ebuild
+++ b/media-sound/mimd/mimd-0.30.1.ebuild
@@ -1,37 +1,38 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mimd/mimd-0.30.1.ebuild,v 1.4 2007/01/05 17:34:26 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mimd/mimd-0.30.1.ebuild,v 1.5 2009/06/06 16:51:58 ssuominen Exp $
+EAPI=2
inherit eutils
DESCRIPTION="Multicast streaming server for MPEG1/2 and MP3 files."
-
HOMEPAGE="http://darkwing.uoregon.edu/~tkay/mim.html"
SRC_URI="http://darkwing.uoregon.edu/~tkay/${P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~amd64 ~x86 ~ppc"
IUSE=""
RDEPEND=">=media-plugins/live-2006.12.08
- dev-libs/xerces-c"
+ dev-libs/xerces-c"
DEPEND="${RDEPEND}
dev-lang/perl"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${P}+live-2006.12.08.patch"
- cp Makefile.in Makefile
+src_prepare() {
+ epatch "${FILESDIR}"/${P}+live-2006.12.08.patch \
+ "${FILESDIR}"/${P}-fortify_sources.patch
+ cp -f Makefile.in Makefile
}
+src_configure() { :; }
+
src_compile() {
- emake || die
+ emake || die "emake failed"
}
src_install() {
- dobin mimd
+ dobin mimd || die "dobin failed"
dodoc doc/mimd.pod
if [ -x /usr/bin/pod2html ]; then