summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-12-01 21:55:03 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-12-01 21:55:03 +0000
commit2beea1004d994dca47cd72d40defde35348a8f63 (patch)
tree18039b4a42ddd7cac8fc7b318d78b1778472b5c9 /media-sound/kradio
parentRemove old. (diff)
downloadgentoo-2-2beea1004d994dca47cd72d40defde35348a8f63.tar.gz
gentoo-2-2beea1004d994dca47cd72d40defde35348a8f63.tar.bz2
gentoo-2-2beea1004d994dca47cd72d40defde35348a8f63.zip
Add recent libav fix from sabayon / upstream, bug 392369
(Portage version: 2.1.10.39/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/kradio')
-rw-r--r--media-sound/kradio/ChangeLog6
-rw-r--r--media-sound/kradio/files/kradio-4.0.2-libav.patch35
-rw-r--r--media-sound/kradio/kradio-4.0.2.ebuild4
3 files changed, 43 insertions, 2 deletions
diff --git a/media-sound/kradio/ChangeLog b/media-sound/kradio/ChangeLog
index e3159562df6b..a6f6b82b03b1 100644
--- a/media-sound/kradio/ChangeLog
+++ b/media-sound/kradio/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/kradio
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kradio/ChangeLog,v 1.29 2011/10/28 23:34:35 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kradio/ChangeLog,v 1.30 2011/12/01 21:55:03 dilfridge Exp $
+
+ 01 Dec 2011; Andreas K. Huettel <dilfridge@gentoo.org> kradio-4.0.2.ebuild,
+ +files/kradio-4.0.2-libav.patch:
+ Add recent libav fix from sabayon / upstream, bug 392369
28 Oct 2011; Jonathan Callen <abcd@gentoo.org> kradio-4.0.2.ebuild:
Bump to EAPI=4
diff --git a/media-sound/kradio/files/kradio-4.0.2-libav.patch b/media-sound/kradio/files/kradio-4.0.2-libav.patch
new file mode 100644
index 000000000000..87d486149144
--- /dev/null
+++ b/media-sound/kradio/files/kradio-4.0.2-libav.patch
@@ -0,0 +1,35 @@
+X-Git-Url:
+http://kradio.git.sourceforge.net/git/gitweb.cgi?p=kradio%2Fkradio;a=blobdiff_plain;f=plugins%2Finternetradio%2Fdecoder_thread.cpp;h=c74d6e20578faf3b5dee877aa6de0c9269f49ad9;hp=4cd6cc0543200e9e274e38fa8badb63556a419c3;hb=4f4ec44f49d83b85702bb002455a57374245d825;hpb=c5dea0c01bf5cc16f49cf3d58b837b2fab02d988
+
+diff --git a/plugins/internetradio/decoder_thread.cpp b/plugins/internetradio/decoder_thread.cpp
+index 4cd6cc0..c74d6e2 100644
+--- a/plugins/internetradio/decoder_thread.cpp
++++ b/plugins/internetradio/decoder_thread.cpp
+@@ -373,7 +373,6 @@ void InternetRadioDecoder::openAVStream(const QString &stream, bool warningsNotE
+
+ //av_log_set_level(255);
+ m_av_pFormatCtx = avformat_alloc_context();
+- memset(m_av_pFormatCtx, 0, sizeof(*m_av_pFormatCtx));
+ m_av_pFormatCtx->probesize = m_maxProbeSize;
+ m_av_pFormatCtx->max_analyze_duration = m_maxAnalyzeTime * AV_TIME_BASE;
+
+@@ -475,7 +474,6 @@ void InternetRadioDecoder::openAVStream(const QString &stream, bool warningsNotE
+ m_av_pFormatCtx_opened = true;
+ }
+ else {
+-
+ // IErrorLogClient::staticLogDebug("InternetRadioDecoder::openAVStream: av_open_input_file start");
+ if (av_open_input_file(&m_av_pFormatCtx, stream.toUtf8(), iformat, 0, &av_params) != 0) {
+ if (warningsNotErrors) {
+@@ -535,7 +533,11 @@ void InternetRadioDecoder::openAVStream(const QString &stream, bool warningsNotE
+ m_av_audioStream = -1;
+ for (unsigned int i = 0; i < m_av_pFormatCtx->nb_streams; i++) {
+ // if (m_av_pFormatCtx->streams[i]->codec->codec_type == CODEC_TYPE_AUDIO && m_av_audioStream < 0) {
++#if LIBAVCODEC_VERSION_MAJOR < 53
+ if (m_av_pFormatCtx->streams[i]->codec->codec_type == CODEC_TYPE_AUDIO) { // take last stream
++#else
++ if (m_av_pFormatCtx->streams[i]->codec->codec_type == AVMEDIA_TYPE_AUDIO) { // take last stream
++#endif
+ m_av_audioStream = i;
+ break;
+ }
diff --git a/media-sound/kradio/kradio-4.0.2.ebuild b/media-sound/kradio/kradio-4.0.2.ebuild
index 8fe99a6c0744..d75d8f8c37e8 100644
--- a/media-sound/kradio/kradio-4.0.2.ebuild
+++ b/media-sound/kradio/kradio-4.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kradio/kradio-4.0.2.ebuild,v 1.5 2011/10/28 23:34:35 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kradio/kradio-4.0.2.ebuild,v 1.6 2011/12/01 21:55:03 dilfridge Exp $
EAPI=4
@@ -34,6 +34,8 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-libav.patch" )
+
S=${WORKDIR}/${MY_P}
src_configure() {