summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-11-05 20:07:00 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-11-05 20:07:00 +0000
commit2c6801a2d180ae39d11932b15dd504fc688c86f8 (patch)
tree7d35653168b152616da7bc739f45a34d95f0d868 /media-sound/kid3/kid3-0.6.ebuild
parentAdd musicbrainz flag for media-sound/kid3. (diff)
downloadgentoo-2-2c6801a2d180ae39d11932b15dd504fc688c86f8.tar.gz
gentoo-2-2c6801a2d180ae39d11932b15dd504fc688c86f8.tar.bz2
gentoo-2-2c6801a2d180ae39d11932b15dd504fc688c86f8.zip
New version (#110998). Make kde support optional. Ad support for vorbis, flac, musicbrainz.
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'media-sound/kid3/kid3-0.6.ebuild')
-rw-r--r--media-sound/kid3/kid3-0.6.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-sound/kid3/kid3-0.6.ebuild b/media-sound/kid3/kid3-0.6.ebuild
new file mode 100644
index 000000000000..3c04ad520566
--- /dev/null
+++ b/media-sound/kid3/kid3-0.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/kid3-0.6.ebuild,v 1.1 2005/11/05 20:07:00 greg_g Exp $
+
+inherit kde-functions
+
+DESCRIPTION="A simple ID3 tag editor for QT/KDE."
+HOMEPAGE="http://kid3.sourceforge.net/"
+SRC_URI="mirror://sourceforge/kid3/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="flac kde musicbrainz vorbis"
+
+DEPEND="=x11-libs/qt-3*
+ >=media-libs/id3lib-3.8.3
+ kde? ( kde-base/kdelibs )
+ vorbis? ( media-libs/libvorbis )
+ flac? ( media-libs/flac )
+ musicbrainz? ( media-libs/tunepimp )"
+
+set-kdedir 3
+
+src_compile() {
+ local myconf="$(use_with kde)
+ $(use_with vorbis)
+ $(use_with flac)
+ $(use_with musicbrainz)"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+}