summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-12 06:59:20 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-12 06:59:20 +0000
commitc50d2fbb5827795e4d42220439366aaeed4e4449 (patch)
tree872f868118dbbe0fd2c2b9da81d62a5c7241dd9b /media-sound/jokosher/jokosher-0.11.1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-c50d2fbb5827795e4d42220439366aaeed4e4449.tar.gz
gentoo-2-c50d2fbb5827795e4d42220439366aaeed4e4449.tar.bz2
gentoo-2-c50d2fbb5827795e4d42220439366aaeed4e4449.zip
Version bump wrt #260967, thanks to Dennis Lichtenthäler.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/jokosher/jokosher-0.11.1.ebuild')
-rw-r--r--media-sound/jokosher/jokosher-0.11.1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/media-sound/jokosher/jokosher-0.11.1.ebuild b/media-sound/jokosher/jokosher-0.11.1.ebuild
new file mode 100644
index 000000000000..5207b5731c85
--- /dev/null
+++ b/media-sound/jokosher/jokosher-0.11.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/jokosher/jokosher-0.11.1.ebuild,v 1.1 2009/05/12 06:59:19 ssuominen Exp $
+
+NEED_PYTHON=2.4
+inherit eutils gnome2 distutils
+
+DESCRIPTION="A simple yet powerful multi-track studio"
+HOMEPAGE="http://www.jokosher.org"
+SRC_URI="http://launchpad.net/jokosher/0.11/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome"
+
+# NOTE: setuptools are a runtime requirement as the app
+# loads its extensions via pkg_resources
+# Removed gnome-python and pyxml from deps because Ubuntu
+# doesn't dep on them. Let me know if there is trouble, ssuominen.
+RDEPEND="dev-python/dbus-python
+ >=dev-python/gst-python-0.10.8
+ dev-python/pycairo
+ >=dev-python/pygtk-2.10
+ gnome-base/librsvg
+ >=media-libs/gnonlin-0.10.9
+ >=media-libs/gst-plugins-good-0.10.6
+ >=media-libs/gst-plugins-bad-0.10.5
+ >=media-plugins/gst-plugins-alsa-0.10.14
+ >=media-plugins/gst-plugins-flac-0.10.6
+ gnome? ( >=media-plugins/gst-plugins-gnomevfs-0.10.14 )
+ >=media-plugins/gst-plugins-lame-0.10.6
+ >=media-plugins/gst-plugins-ogg-0.10.14
+ >=media-plugins/gst-plugins-vorbis-0.10.14
+ >=media-plugins/gst-plugins-ladspa-0.10.5
+ x11-themes/hicolor-icon-theme
+ dev-python/setuptools
+ dev-python/pyxdg"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper"
+
+PYTHON_MODNAME="Jokosher"
+
+src_unpack() {
+ gnome2_src_unpack
+ epatch "${FILESDIR}"/${P}-update-database.patch
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ gnome2_pkg_postrm
+}