summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-08-05 10:15:08 +0000
committerSamuli Suominen <drac@gentoo.org>2007-08-05 10:15:08 +0000
commit4ebca785d5a07f38bc2c5ded3467db8b4699e71d (patch)
tree4d9aaaa963f91889c40ec8789aed2d9d5f63a1e3 /media-sound/gnump3d
parentRevision bump to push out fixes for baselayout-2 users. (diff)
downloadgentoo-2-4ebca785d5a07f38bc2c5ded3467db8b4699e71d.tar.gz
gentoo-2-4ebca785d5a07f38bc2c5ded3467db8b4699e71d.tar.bz2
gentoo-2-4ebca785d5a07f38bc2c5ded3467db8b4699e71d.zip
Version bump for bug 182814, thanks to shad for reporting.
(Portage version: 2.1.3.3)
Diffstat (limited to 'media-sound/gnump3d')
-rw-r--r--media-sound/gnump3d/ChangeLog5
-rw-r--r--media-sound/gnump3d/files/digest-gnump3d-2.93
-rw-r--r--media-sound/gnump3d/gnump3d-2.9.ebuild71
3 files changed, 78 insertions, 1 deletions
diff --git a/media-sound/gnump3d/ChangeLog b/media-sound/gnump3d/ChangeLog
index 2b53706cca18..09f4ab51ef92 100644
--- a/media-sound/gnump3d/ChangeLog
+++ b/media-sound/gnump3d/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/gnump3d
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gnump3d/ChangeLog,v 1.54 2007/05/13 16:28:58 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnump3d/ChangeLog,v 1.55 2007/08/05 10:15:07 drac Exp $
+
+ 05 Aug 2007; Samuli Suominen <drac@gentoo.org> +gnump3d-2.9.ebuild:
+ Version bump for bug 182814, thanks to shad for reporting.
13 May 2007; Steve Dibb <beandog@gentoo.org> gnump3d-2.9.9.9.ebuild:
amd64 stable
diff --git a/media-sound/gnump3d/files/digest-gnump3d-2.9 b/media-sound/gnump3d/files/digest-gnump3d-2.9
new file mode 100644
index 000000000000..61aebeacaf96
--- /dev/null
+++ b/media-sound/gnump3d/files/digest-gnump3d-2.9
@@ -0,0 +1,3 @@
+MD5 515c872a3a2ff808fcd45e98b49faf30 gnump3d-2.9final.tar.bz2 653092
+RMD160 2a5ea591f1fe2ff08123431d803f9e0ad5a421c4 gnump3d-2.9final.tar.bz2 653092
+SHA256 990b232037c634ed051f53ed28358dd258a3555b11c83bf4e8fb564f51f3ca9c gnump3d-2.9final.tar.bz2 653092
diff --git a/media-sound/gnump3d/gnump3d-2.9.ebuild b/media-sound/gnump3d/gnump3d-2.9.ebuild
new file mode 100644
index 000000000000..9cd09a646c03
--- /dev/null
+++ b/media-sound/gnump3d/gnump3d-2.9.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnump3d/gnump3d-2.9.ebuild,v 1.3 2007/08/05 10:15:07 drac Exp $
+
+inherit eutils multilib
+
+MY_PV=${PV/9/9final}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="A streaming server for MP3, OGG vorbis and other streamable files"
+HOMEPAGE="http://www.gnump3d.org/"
+SRC_URI="http://savannah.gnu.org/download/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-apps/sed
+ dev-lang/perl"
+
+RESTRICT="test"
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ enewuser gnump3d '' '' '' nogroup || die "Failed to add new user."
+ LIBDIR=/usr/$(get_libdir)
+}
+
+src_compile() { :; }
+
+src_install() {
+ PERLDIR="`perl bin/getlibdir`"
+
+ insinto ${PERLDIR}/gnump3d
+ doins lib/gnump3d/*.pm
+ insinto ${PERLDIR}/gnump3d/plugins
+ doins lib/gnump3d/plugins/*.pm
+ insinto ${PERLDIR}/gnump3d/lang
+ doins lib/gnump3d/lang/*.pm
+
+ dobin bin/gnump3d2 bin/gnump3d-top bin/gnump3d-index
+ dosym /usr/bin/gnump3d2 /usr/bin/gnump3d
+ doman man/*.1
+
+ dodir /usr/share/gnump3d
+ cp -R templates/* "${D}"/usr/share/gnump3d/
+
+ insinto /etc/gnump3d
+ doins etc/gnump3d.conf etc/mime.types etc/file.types
+ dosed "s,PLUGINDIR,${PERLDIR},g" /etc/gnump3d/gnump3d.conf
+ dosed 's,^user *= *\(.*\)$,user = gnump3d,g' /etc/gnump3d/gnump3d.conf
+
+ dodoc AUTHORS ChangeLog DOWNSAMPLING PLUGINS README SUPPORT TODO
+
+ newinitd "${FILESDIR}"/${PN}.init.d gnump3d
+ newconfd "${FILESDIR}"/${PN}.conf.d gnump3d
+
+ keepdir /var/log/gnump3d
+ keepdir /var/cache/gnump3d/serving
+
+ fowners gnump3d:nogroup /var/log/gnump3d /var/cache/gnump3d
+}
+
+pkg_postinst() {
+ einfo
+ elog "Please edit your /etc/gnump3d/gnump3d.conf before running"
+ elog "/etc/init.d/gnump3d start"
+ einfo
+}