summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-06-18 08:36:51 +0000
committerTim Harder <radhermit@gentoo.org>2012-06-18 08:36:51 +0000
commitdecf8e3d300fe7bc3615df8122f21dd19729ba45 (patch)
tree82ebcef0933f2f799f4b0f21889190965bba0afb /media-sound/ecasound
parentBump (diff)
downloadgentoo-2-decf8e3d300fe7bc3615df8122f21dd19729ba45.tar.gz
gentoo-2-decf8e3d300fe7bc3615df8122f21dd19729ba45.tar.bz2
gentoo-2-decf8e3d300fe7bc3615df8122f21dd19729ba45.zip
Fix build with python enabled (bug #421167), use native python implementation (C implementation is deprecated), and force lv2 support when tests are enabled.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/ecasound')
-rw-r--r--media-sound/ecasound/ChangeLog7
-rw-r--r--media-sound/ecasound/ecasound-2.9.0.ebuild16
2 files changed, 15 insertions, 8 deletions
diff --git a/media-sound/ecasound/ChangeLog b/media-sound/ecasound/ChangeLog
index 8cd8f296fb97..996ffff64a0b 100644
--- a/media-sound/ecasound/ChangeLog
+++ b/media-sound/ecasound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/ecasound
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.64 2012/06/14 06:22:46 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.65 2012/06/18 08:36:51 radhermit Exp $
+
+ 18 Jun 2012; Tim Harder <radhermit@gentoo.org> ecasound-2.9.0.ebuild:
+ Fix build with python enabled (bug #421167), use native python implementation
+ (C implementation is deprecated), and force lv2 support when tests are
+ enabled.
*ecasound-2.9.0 (14 Jun 2012)
diff --git a/media-sound/ecasound/ecasound-2.9.0.ebuild b/media-sound/ecasound/ecasound-2.9.0.ebuild
index 7a07eec141ae..18b77a5cc9eb 100644
--- a/media-sound/ecasound/ecasound-2.9.0.ebuild
+++ b/media-sound/ecasound/ecasound-2.9.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ecasound-2.9.0.ebuild,v 1.1 2012/06/14 06:22:46 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ecasound-2.9.0.ebuild,v 1.2 2012/06/18 08:36:51 radhermit Exp $
EAPI=4
PYTHON_DEPEND="python? 2"
@@ -15,7 +15,8 @@ LICENSE="GPL-2"
SLOT="1"
KEYWORDS="~amd64 ~x86"
IUSE="alsa audiofile debug doc jack libsamplerate lv2 mikmod ncurses oil osc oss
-python ruby sndfile static-libs"
+python ruby sndfile static-libs test"
+REQUIRED_USE="test? ( lv2 )"
RDEPEND="sys-libs/readline
alsa? ( media-libs/alsa-lib )
@@ -34,7 +35,10 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
pkg_setup() {
- use python && python_set_active_version 2
+ if use python ; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
}
src_prepare() {
@@ -52,11 +56,8 @@ src_configure() {
local pyconf
if use python ; then
- pyconf="--enable-pyecasound=c
- --with-python-includes=$(python_get_includedir)
+ pyconf="--with-python-includes=$(python_get_includedir)
--with-python-modules=$(python_get_libdir)"
- else
- pyconf="--disable-pyecasound"
fi
econf \
@@ -74,6 +75,7 @@ src_configure() {
$(use_enable oil liboil) \
$(use_enable osc liblo) \
$(use_enable oss) \
+ $(use_enable python pyecasound) \
$(use_enable ruby rubyecasound) \
$(use_enable sndfile) \
$(use_enable static-libs static) \