summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-02-12 04:47:43 +0000
committerTim Harder <radhermit@gentoo.org>2013-02-12 04:47:43 +0000
commitc725782f35cc45f458acc53790497cdb92e8f238 (patch)
tree106746e062004b728ac8aa636620a44f9c28f1bd /media-sound/easytag
parentFix building with kernels that split obj & src dirs. Fix building against li... (diff)
downloadgentoo-2-c725782f35cc45f458acc53790497cdb92e8f238.tar.gz
gentoo-2-c725782f35cc45f458acc53790497cdb92e8f238.tar.bz2
gentoo-2-c725782f35cc45f458acc53790497cdb92e8f238.zip
Version bump.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-sound/easytag')
-rw-r--r--media-sound/easytag/ChangeLog9
-rw-r--r--media-sound/easytag/easytag-2.1.8.ebuild59
-rw-r--r--media-sound/easytag/files/easytag-2.1.8-desktop.patch11
-rw-r--r--media-sound/easytag/files/easytag-2.1.8-docs.patch14
-rw-r--r--media-sound/easytag/files/easytag-2.1.8-werror.patch11
5 files changed, 103 insertions, 1 deletions
diff --git a/media-sound/easytag/ChangeLog b/media-sound/easytag/ChangeLog
index 0f45eaea9dae..46a9ca547d59 100644
--- a/media-sound/easytag/ChangeLog
+++ b/media-sound/easytag/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/easytag
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/easytag/ChangeLog,v 1.165 2013/02/10 04:41:46 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/easytag/ChangeLog,v 1.166 2013/02/12 04:47:43 radhermit Exp $
+
+*easytag-2.1.8 (12 Feb 2013)
+
+ 12 Feb 2013; Tim Harder <radhermit@gentoo.org> +easytag-2.1.8.ebuild,
+ +files/easytag-2.1.8-desktop.patch, +files/easytag-2.1.8-docs.patch,
+ +files/easytag-2.1.8-werror.patch:
+ Version bump.
10 Feb 2013; Tim Harder <radhermit@gentoo.org> easytag-2.1.7-r2.ebuild:
Update HOMEPAGE (bug #456378).
diff --git a/media-sound/easytag/easytag-2.1.8.ebuild b/media-sound/easytag/easytag-2.1.8.ebuild
new file mode 100644
index 000000000000..5b46a8fd73db
--- /dev/null
+++ b/media-sound/easytag/easytag-2.1.8.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/easytag/easytag-2.1.8.ebuild,v 1.1 2013/02/12 04:47:43 radhermit Exp $
+
+EAPI=5
+inherit eutils autotools gnome.org fdo-mime
+
+DESCRIPTION="GTK+ utility for editing MP2, MP3, MP4, FLAC, Ogg and other media tags"
+HOMEPAGE="http://projects.gnome.org/easytag/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="flac mp3 mp4 nls speex vorbis wavpack"
+
+RDEPEND=">=x11-libs/gtk+-2.24:2
+ mp3? (
+ >=media-libs/id3lib-3.8.3-r7
+ media-libs/libid3tag
+ )
+ flac? (
+ media-libs/flac
+ media-libs/libvorbis
+ )
+ mp4? ( media-libs/taglib[mp4] )
+ vorbis? ( media-libs/libvorbis )
+ wavpack? ( media-sound/wavpack )
+ speex? (
+ media-libs/speex
+ media-libs/libvorbis
+ )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-desktop.patch
+ epatch "${FILESDIR}"/${P}-werror.patch
+ epatch "${FILESDIR}"/${P}-docs.patch
+ eautoreconf
+}
+
+DOCS=( AUTHORS ChangeLog HACKING NEWS README THANKS TODO )
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable mp3) \
+ $(use_enable mp3 id3v23) \
+ $(use_enable vorbis ogg) \
+ $(use_enable speex) \
+ $(use_enable flac) \
+ $(use_enable mp4) \
+ $(use_enable wavpack)
+}
+
+pkg_postinst() { fdo-mime_desktop_database_update; }
+pkg_postrm() { fdo-mime_desktop_database_update; }
diff --git a/media-sound/easytag/files/easytag-2.1.8-desktop.patch b/media-sound/easytag/files/easytag-2.1.8-desktop.patch
new file mode 100644
index 000000000000..1f0e7c3626a3
--- /dev/null
+++ b/media-sound/easytag/files/easytag-2.1.8-desktop.patch
@@ -0,0 +1,11 @@
+--- easytag-2.1.8/easytag.desktop.in
++++ easytag-2.1.8/easytag.desktop.in
+@@ -6,7 +6,7 @@
+ Type=Application
+ Icon=easytag
+ Categories=GTK;AudioVideo;AudioVideoEditing;
+-MimeType=x-directory/normal;inode/directory;audio/x-mp3;audio/x-mpeg;audio/mpeg;application/ogg;audio/x-vorbis+ogg;audio/x-flac;audio/x-musepack;audio/x-ape;
++MimeType=inode/directory;audio/x-mp3;audio/x-mpeg;audio/mpeg;application/ogg;audio/x-vorbis+ogg;audio/x-flac;audio/x-musepack;audio/x-ape;
+ Exec=easytag %F
+ Terminal=false
+ StartupNotify=true
diff --git a/media-sound/easytag/files/easytag-2.1.8-docs.patch b/media-sound/easytag/files/easytag-2.1.8-docs.patch
new file mode 100644
index 000000000000..52846c37bf1f
--- /dev/null
+++ b/media-sound/easytag/files/easytag-2.1.8-docs.patch
@@ -0,0 +1,14 @@
+--- easytag-2.1.8/Makefile.am
++++ easytag-2.1.8/Makefile.am
+@@ -197,11 +197,6 @@
+ $(AM_V_at)$(POST_UNINSTALL)
+ test -n "$(DESTDIR)" || $(UPDATE_ICON_CACHE) "$(iconthemedir)"
+
+-dist_doc_DATA = \
+- HACKING \
+- THANKS \
+- TODO
+-
+ dist_noinst_DATA = \
+ $(desktop_in_files) \
+ $(easytag_headers) \
diff --git a/media-sound/easytag/files/easytag-2.1.8-werror.patch b/media-sound/easytag/files/easytag-2.1.8-werror.patch
new file mode 100644
index 000000000000..546c96c8e7eb
--- /dev/null
+++ b/media-sound/easytag/files/easytag-2.1.8-werror.patch
@@ -0,0 +1,11 @@
+--- easytag-2.1.8/configure.ac
++++ easytag-2.1.8/configure.ac
+@@ -239,7 +239,7 @@
+ AC_MSG_RESULT([$have_ws2])])
+
+ dnl Check that the compiler accepts the given warning flags.
+-warning_flags="-Wall -Wstrict-prototypes -Wnested-externs -Werror=missing-prototypes -Werror=implicit-function-declaration -Werror=pointer-arith -Werror=init-self -Werror=format-security -Werror=format=2 -Werror=missing-include-dirs -Werror=declaration-after-statement"
++warning_flags="-Wall -Wstrict-prototypes -Wnested-externs"
+
+ realsave_CFLAGS="$CFLAGS"
+ for option in $warning_flags; do