summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-07-07 16:40:16 +0000
committerSamuli Suominen <drac@gentoo.org>2008-07-07 16:40:16 +0000
commitdcec0f37c0e5ec1559286dd3c9042d9d40074214 (patch)
tree41832c4dbd0990c4496fb3e1ba58f407da7ad2cd /media-sound/darkice
parentUpdate taglib-sharp dep. for bug #230465, thanks to corec. (diff)
downloadgentoo-2-dcec0f37c0e5ec1559286dd3c9042d9d40074214.tar.gz
gentoo-2-dcec0f37c0e5ec1559286dd3c9042d9d40074214.tar.bz2
gentoo-2-dcec0f37c0e5ec1559286dd3c9042d9d40074214.zip
Version bump for bug 231062, thanks to Ákos Maróy for reporting.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc3 x86_64)
Diffstat (limited to 'media-sound/darkice')
-rw-r--r--media-sound/darkice/ChangeLog7
-rw-r--r--media-sound/darkice/darkice-0.19.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/media-sound/darkice/ChangeLog b/media-sound/darkice/ChangeLog
index 2b9a3bc63fbc..f43aa4516b82 100644
--- a/media-sound/darkice/ChangeLog
+++ b/media-sound/darkice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/darkice
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/darkice/ChangeLog,v 1.47 2008/03/27 10:45:18 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/darkice/ChangeLog,v 1.48 2008/07/07 16:40:16 drac Exp $
+
+*darkice-0.19 (07 Jul 2008)
+
+ 07 Jul 2008; Samuli Suominen <drac@gentoo.org> +darkice-0.19.ebuild:
+ Version bump for bug 231062, thanks to Ákos Maróy for reporting.
27 Mar 2008; Samuli Suominen <drac@gentoo.org>
-files/darkice-0.17.1-64bit.patch, +files/darkice-0.18.1-gcc43.patch,
diff --git a/media-sound/darkice/darkice-0.19.ebuild b/media-sound/darkice/darkice-0.19.ebuild
new file mode 100644
index 000000000000..9f962159871a
--- /dev/null
+++ b/media-sound/darkice/darkice-0.19.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/darkice/darkice-0.19.ebuild,v 1.1 2008/07/07 16:40:16 drac Exp $
+
+inherit eutils
+
+DESCRIPTION="IceCast live streamer, delivering ogg and mp3 streams simultaneously to multiple hosts."
+HOMEPAGE="http://darkice.sourceforge.net"
+SRC_URI="http://${PN}.tyrell.hu/dist/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="aac alsa encode jack twolame vorbis"
+
+RDEPEND="encode? ( media-sound/lame )
+ vorbis? ( media-libs/libvorbis )
+ aac? ( media-libs/faac )
+ twolame? ( media-sound/twolame )
+ alsa? ( media-libs/alsa-lib )
+ jack? ( media-sound/jack-audio-connection-kit )
+ !encode? ( !vorbis? ( !aac? ( !twolame? ( media-libs/libvorbis ) ) ) )"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.18.1-gcc43.patch
+}
+
+src_compile() {
+ if ! use encode && ! use vorbis && ! use aac && ! use twolame; then
+ ewarn "One of USE flags encode, vorbis, aac, or twolame is required."
+ ewarn "Selecting vorbis for you."
+ local myconf="--with-vorbis"
+ fi
+
+ econf $(use_with aac faac) \
+ $(use_with alsa) \
+ $(use_with encode lame) \
+ $(use_with jack) \
+ $(use_with twolame) \
+ $(use_with vorbis) \
+ ${myconf}
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog FAQ NEWS README TODO
+}