summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-12-19 19:50:26 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-12-19 19:50:26 +0000
commit4424ff0a08dfe62d01aecb80a184aca6bf2578b7 (patch)
tree0e178a0719ed729a8bbbef1bee4713a60472eea4 /media-sound/cowbell
parentremove old (diff)
downloadgentoo-2-4424ff0a08dfe62d01aecb80a184aca6bf2578b7.tar.gz
gentoo-2-4424ff0a08dfe62d01aecb80a184aca6bf2578b7.tar.bz2
gentoo-2-4424ff0a08dfe62d01aecb80a184aca6bf2578b7.zip
Add GCONF_DEBUG=no because the pkg doesn't support --enable/--disable-debug configure option. Add AC_PROG_CXX for libtool-2.2 wrt #241578, thanks to <larstobi at snota.no>. Run intltoolize because otherwise it won't build or install them at all.
(Portage version: 2.1.6.1/cvs/Linux 2.6.27.7 i686)
Diffstat (limited to 'media-sound/cowbell')
-rw-r--r--media-sound/cowbell/ChangeLog9
-rw-r--r--media-sound/cowbell/cowbell-0.2.7.1.ebuild11
-rw-r--r--media-sound/cowbell/files/cowbell-0.2.7.1-libtool.patch11
3 files changed, 29 insertions, 2 deletions
diff --git a/media-sound/cowbell/ChangeLog b/media-sound/cowbell/ChangeLog
index 5671ffc79a9f..4d94ed328c63 100644
--- a/media-sound/cowbell/ChangeLog
+++ b/media-sound/cowbell/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/cowbell
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cowbell/ChangeLog,v 1.9 2008/11/25 16:29:20 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cowbell/ChangeLog,v 1.10 2008/12/19 19:50:26 ssuominen Exp $
+
+ 19 Dec 2008; <ssuominen@gentoo.org> +files/cowbell-0.2.7.1-libtool.patch,
+ cowbell-0.2.7.1.ebuild:
+ Add GCONF_DEBUG=no because the pkg doesn't support
+ --enable/--disable-debug configure option. Add AC_PROG_CXX for libtool-2.2
+ wrt #241578, thanks to <larstobi at snota.no>. Run intltoolize because
+ otherwise it won't build or install them at all.
25 Nov 2008; Peter Alfredsen <loki_val@gentoo.org> cowbell-0.2.7.1.ebuild:
Go eapi-2, fixup deps for gtk-sharp-2.12.6
diff --git a/media-sound/cowbell/cowbell-0.2.7.1.ebuild b/media-sound/cowbell/cowbell-0.2.7.1.ebuild
index ed40fdc06b2b..8d07f8650d58 100644
--- a/media-sound/cowbell/cowbell-0.2.7.1.ebuild
+++ b/media-sound/cowbell/cowbell-0.2.7.1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cowbell/cowbell-0.2.7.1.ebuild,v 1.5 2008/11/25 16:29:20 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cowbell/cowbell-0.2.7.1.ebuild,v 1.6 2008/12/19 19:50:26 ssuominen Exp $
EAPI=2
+GCONF_DEBUG=no
+
inherit autotools gnome2 mono
DESCRIPTION="Elegantly tag and rename mp3/ogg/flac files"
@@ -27,6 +29,13 @@ DOCS="AUTHORS ChangeLog NEWS README"
MAKEOPTS="${MAKEOPTS} -j1"
+src_unpack() {
+ gnome2_src_unpack
+ epatch "${FILESDIR}"/${P}-libtool.patch
+ intltoolize --force --copy --automake || die "intltoolize failed."
+ eautoreconf
+}
+
src_configure() {
gnome2_src_configure
}
diff --git a/media-sound/cowbell/files/cowbell-0.2.7.1-libtool.patch b/media-sound/cowbell/files/cowbell-0.2.7.1-libtool.patch
new file mode 100644
index 000000000000..583377658c45
--- /dev/null
+++ b/media-sound/cowbell/files/cowbell-0.2.7.1-libtool.patch
@@ -0,0 +1,11 @@
+diff -ur cowbell-0.2.7.1.orig/configure.in cowbell-0.2.7.1/configure.in
+--- cowbell-0.2.7.1.orig/configure.in 2006-05-09 05:44:20.000000000 +0300
++++ cowbell-0.2.7.1/configure.in 2008-12-19 21:29:20.000000000 +0200
+@@ -6,6 +6,7 @@
+ AC_PROG_INSTALL
+ AC_PROG_INTLTOOL([0.21])
+ AC_PROG_LIBTOOL
++AC_PROG_CXX
+
+ AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
+ if test "x$PKG_CONFIG" = "xno"; then