summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-01-08 04:20:06 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-01-08 04:20:06 +0000
commit49e100d688270d234b4d2529a8e554f5d391a0eb (patch)
tree7be3a0d76b17585997c81243e918ace52a3c1ede /media-sound/cantata
parentBump (diff)
downloadgentoo-2-49e100d688270d234b4d2529a8e554f5d391a0eb.tar.gz
gentoo-2-49e100d688270d234b4d2529a8e554f5d391a0eb.tar.bz2
gentoo-2-49e100d688270d234b4d2529a8e554f5d391a0eb.zip
Version bump. Thanks to Nikoli. Fixes bug #497152. Remove unused patches, too.
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'media-sound/cantata')
-rw-r--r--media-sound/cantata/ChangeLog11
-rw-r--r--media-sound/cantata/cantata-1.2.2.ebuild91
-rw-r--r--media-sound/cantata/files/cantata-1.0.3-audiocd-automagic.patch42
-rw-r--r--media-sound/cantata/files/cantata-1.0.3-system-qjson.patch35
4 files changed, 100 insertions, 79 deletions
diff --git a/media-sound/cantata/ChangeLog b/media-sound/cantata/ChangeLog
index e6a2f477a64a..d991d88b3110 100644
--- a/media-sound/cantata/ChangeLog
+++ b/media-sound/cantata/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/cantata
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cantata/ChangeLog,v 1.22 2013/10/14 20:52:14 johu Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cantata/ChangeLog,v 1.23 2014/01/08 04:20:06 mrueg Exp $
+
+*cantata-1.2.2 (08 Jan 2014)
+
+ 08 Jan 2014; Manuel Rüger <mrueg@gentoo.org> +cantata-1.2.2.ebuild,
+ -files/cantata-1.0.3-audiocd-automagic.patch,
+ -files/cantata-1.0.3-system-qjson.patch:
+ Version bump. Thanks to Nikoli. Fixes bug #497152. Remove unused patches, too.
*cantata-1.1.3 (14 Oct 2013)
diff --git a/media-sound/cantata/cantata-1.2.2.ebuild b/media-sound/cantata/cantata-1.2.2.ebuild
new file mode 100644
index 000000000000..4c05d589bef2
--- /dev/null
+++ b/media-sound/cantata/cantata-1.2.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cantata/cantata-1.2.2.ebuild,v 1.1 2014/01/08 04:20:06 mrueg Exp $
+
+EAPI=5
+KDE_REQUIRED="optional"
+KDE_LINGUAS="cs de en_GB es hu ko pl ru zh_CN"
+inherit kde4-base
+
+DESCRIPTION="A featureful and configurable Qt4 client for the music player daemon (MPD)"
+HOMEPAGE="https://code.google.com/p/cantata/"
+SRC_URI="https://cantata.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="cddb cdda kde lame mtp musicbrainz qt5 replaygain taglib"
+REQUIRED_USE="
+ cddb? ( cdda taglib )
+ cdda? ( || ( cddb musicbrainz ) )
+ lame? ( cdda taglib )
+ mtp? ( taglib )
+ musicbrainz? ( cdda taglib )
+ qt5? ( !kde )
+ replaygain? ( taglib )
+"
+
+DEPEND="
+ cdda? ( media-sound/cdparanoia )
+ cddb? ( media-libs/libcddb )
+ kde? ( $(add_kdebase_dep kwalletd) )
+ lame? ( media-sound/lame )
+ mtp? ( media-libs/libmtp )
+ musicbrainz? ( media-libs/musicbrainz:5 )
+ qt5? (
+ dev-qt/qtconcurrent:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ )
+ !qt5? (
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ )
+ replaygain? (
+ media-libs/speex
+ media-sound/mpg123
+ virtual/ffmpeg
+ )
+ taglib? (
+ media-libs/taglib[asf,mp4]
+ media-libs/taglib-extras
+ !kde? ( sys-fs/udisks:2 )
+ )
+ dev-libs/qjson
+ sys-libs/zlib
+ x11-libs/libX11
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep oxygen-icons)
+"
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ rm -rf 3rdparty/qjson || die
+ use kde && { rm -rf 3rdparty/solid-lite/ || die ;}
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable cdda CDPARANOIA)
+ $(cmake-utils_use_enable cddb)
+ $(cmake-utils_use_enable kde)
+ $(cmake-utils_use_enable kde kwallet)
+ $(cmake-utils_use_enable lame)
+ $(cmake-utils_use_enable mtp)
+ $(cmake-utils_use_enable musicbrainz)
+ $(cmake-utils_use_enable qt5)
+ $(cmake-utils_use_enable replaygain FFMPEG)
+ $(cmake-utils_use_enable replaygain MPG123)
+ $(cmake-utils_use_enable replaygain SPEEXDSP)
+ $(cmake-utils_use_enable taglib)
+ $(cmake-utils_use_enable taglib TAGLIB_EXTRAS)
+ -DENABLE_HTTPS_SUPPORT=ON
+ -DENABLE_HTTP_STREAM_PLAYBACK=OFF
+ -DENABLE_UDISKS2=ON
+ )
+ kde4-base_src_configure
+}
diff --git a/media-sound/cantata/files/cantata-1.0.3-audiocd-automagic.patch b/media-sound/cantata/files/cantata-1.0.3-audiocd-automagic.patch
deleted file mode 100644
index 311aac1a3b74..000000000000
--- a/media-sound/cantata/files/cantata-1.0.3-audiocd-automagic.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-Index: CMakeLists.txt
-===================================================================
---- CMakeLists.txt (revision 2749)
-+++ CMakeLists.txt (revision 2750)
-@@ -33,6 +33,10 @@
- OPTION(ENABLE_UDISKS2 "Build UDisks2 backend, and NOT UDisks, for Qt builds" OFF)
- OPTION(ENABLE_OVERLAYSCROLLBARS "Enable support for overlay style scrollbars when using QGtkStyle (Linux only)" OFF)
- OPTION(ENABLE_ONLINE_SERVICES "Enable support for online services (Jamendo and Magantune)" ON)
-+OPTION(ENABLE_CDPARANOIA "Enable CDParanoia libraries (required for AudioCD support)" ON)
-+OPTION(ENABLE_CDDB "Enable CDDB libraries (either this or MusicBrianz required for AudioCD support)" ON)
-+OPTION(ENABLE_MUSICBRAINZ "Enable MusicBrianz libraries (either this or CDDB required for AudioCD support)" ON)
-+OPTION(ENABLE_LAME "Enable LAME libraries (required for AudioCD playback support)" ON)
-
- if (ENABLE_QT5)
- set(ENABLE_PHONON FALSE)
-@@ -142,12 +146,20 @@
- SET( CANTATA_UIS ${CANTATA_UIS} online/onlineservicespage.ui)
- endif (ENABLE_ONLINE_SERVICES)
-
--find_package( Cdparanoia )
--if (CDPARANOIA_FOUND)
-- find_package( CDDB )
-- find_package( MusicBrainz5 )
-- find_package( Lame )
--endif (CDPARANOIA_FOUND)
-+if (ENABLE_CDPARANOIA)
-+ find_package(Cdparanoia)
-+ if (CDPARANOIA_FOUND)
-+ if (ENABLE_CDDB)
-+ find_package(CDDB)
-+ endif (ENABLE_CDDB)
-+ if (ENABLE_MUSICBRAINZ)
-+ find_package(MusicBrainz5)
-+ endif (ENABLE_MUSICBRAINZ)
-+ if (ENABLE_LAME)
-+ find_package(Lame)
-+ endif (ENABLE_LAME)
-+ endif (CDPARANOIA_FOUND)
-+endif (ENABLE_CDPARANOIA)
-
- if (ENABLE_TAGLIB)
- set(TAGLIB_MIN_VERSION "1.6")
diff --git a/media-sound/cantata/files/cantata-1.0.3-system-qjson.patch b/media-sound/cantata/files/cantata-1.0.3-system-qjson.patch
deleted file mode 100644
index 3bae049af2e5..000000000000
--- a/media-sound/cantata/files/cantata-1.0.3-system-qjson.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Index: CMakeLists.txt
-===================================================================
---- CMakeLists.txt (revision 2794)
-+++ CMakeLists.txt (revision 2795)
-@@ -166,6 +166,10 @@
- find_package(Taglib)
- endif (ENABLE_TAGLIB)
-
-+if (NOT ENABLE_QT5 AND NOT WIN32)
-+ find_package( QJSON )
-+endif (NOT ENABLE_QT5 AND NOT WIN32)
-+
- if (ENABLE_OVERLAYSCROLLBARS)
- add_definitions(-DENABLE_OVERLAYSCROLLBARS)
- endif (ENABLE_OVERLAYSCROLLBARS)
-@@ -495,9 +499,17 @@
- endif (NOT WIN32)
-
- add_subdirectory(3rdparty/qtiocompressor)
--add_subdirectory(3rdparty/qjson)
--TARGET_LINK_LIBRARIES(cantata qtiocompressor qjson)
-
-+if (QJSON_FOUND)
-+ include_directories(${QJSON_INCLUDE_DIR})
-+ TARGET_LINK_LIBRARIES(cantata ${QJSON_LIBRARIES})
-+else (QJSON_FOUND)
-+ add_subdirectory(3rdparty/qjson)
-+ TARGET_LINK_LIBRARIES(cantata qjson)
-+endif (QJSON_FOUND)
-+
-+TARGET_LINK_LIBRARIES(cantata qtiocompressor)
-+
- ADD_SUBDIRECTORY( icons )
-
- target_link_libraries(cantata support sha2 ${QTLIBS} ${ZLIB_LIBRARIES})