summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-07-29 12:30:19 +0000
committerSamuli Suominen <drac@gentoo.org>2007-07-29 12:30:19 +0000
commit11ac334d7d17ecefaa27fe0b92033b6eba313fda (patch)
treed50dcf510322e6c5b88d839d186744dfaba57d98 /media-sound/awesfx
parentForce jgoodies-forms version to be <1.1.0 as a temporary workaround of bug #1... (diff)
downloadgentoo-2-11ac334d7d17ecefaa27fe0b92033b6eba313fda.tar.gz
gentoo-2-11ac334d7d17ecefaa27fe0b92033b6eba313fda.tar.bz2
gentoo-2-11ac334d7d17ecefaa27fe0b92033b6eba313fda.zip
Version bump, fixing also bug 186327.
(Portage version: 2.1.3)
Diffstat (limited to 'media-sound/awesfx')
-rw-r--r--media-sound/awesfx/ChangeLog10
-rw-r--r--media-sound/awesfx/awesfx-0.5.1.ebuild50
-rw-r--r--media-sound/awesfx/files/awesfx-0.5.1-configure-noalsa.patch263
-rw-r--r--media-sound/awesfx/files/awesfx-0.5.1-include.patch48
-rw-r--r--media-sound/awesfx/files/awesfx-0.5.1-makefile-noalsa.patch82
-rw-r--r--media-sound/awesfx/files/digest-awesfx-0.5.13
6 files changed, 455 insertions, 1 deletions
diff --git a/media-sound/awesfx/ChangeLog b/media-sound/awesfx/ChangeLog
index 63c98eab4263..d5cfcc6e24eb 100644
--- a/media-sound/awesfx/ChangeLog
+++ b/media-sound/awesfx/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/awesfx
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/awesfx/ChangeLog,v 1.20 2007/01/21 21:14:53 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/awesfx/ChangeLog,v 1.21 2007/07/29 12:30:19 drac Exp $
+
+*awesfx-0.5.1 (29 Jul 2007)
+
+ 29 Jul 2007; Samuli Suominen <drac@gentoo.org>
+ +files/awesfx-0.5.1-configure-noalsa.patch,
+ +files/awesfx-0.5.1-include.patch,
+ +files/awesfx-0.5.1-makefile-noalsa.patch, +awesfx-0.5.1.ebuild:
+ Version bump, fixing also bug 186327.
21 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> -awesfx-0.5.0c.ebuild:
Remove old version.
diff --git a/media-sound/awesfx/awesfx-0.5.1.ebuild b/media-sound/awesfx/awesfx-0.5.1.ebuild
new file mode 100644
index 000000000000..15fc29cabe8a
--- /dev/null
+++ b/media-sound/awesfx/awesfx-0.5.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/awesfx/awesfx-0.5.1.ebuild,v 1.1 2007/07/29 12:30:19 drac Exp $
+
+inherit eutils portability
+
+DESCRIPTION="AWE Utilities - sfxload"
+HOMEPAGE="http://www.alsa-project.org/~iwai/awedrv.html#Utils"
+SRC_URI="http://ftp.suse.com/pub/people/tiwai/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="alsa"
+
+DEPEND="alsa? ( >=media-libs/alsa-lib-1 )"
+
+BANK_LOC="/usr/share/sounds/sf2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-include.patch
+}
+
+src_compile() {
+ if ! use alsa; then
+ einfo "Removing ALSA support!"
+ epatch "${FILESDIR}"/${P}-configure-noalsa.patch
+ econf --with-sfpath=${BANK_LOC} || die
+ epatch "${FILESDIR}"/${P}-makefile-noalsa.patch
+ sed -i -e 's/'^LIBS.*-lasound.*$'/LIBS = -lm $(dlopen_lib) -lpthread/' Makefile
+ else
+ econf --with-sfpath=${BANK_LOC} || die
+ fi
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog README SBKtoSF2.txt
+ dodoc "${D}"/usr/share/sounds/sf2/README-bank
+ rm "${D}"/usr/share/sounds/sf2/README-bank
+}
+
+pkg_postinst() {
+ elog "Please copy your SoundFont files from the original CD-ROM"
+ elog "shipped with your soundcard to ${BANK_LOC}"
+}
diff --git a/media-sound/awesfx/files/awesfx-0.5.1-configure-noalsa.patch b/media-sound/awesfx/files/awesfx-0.5.1-configure-noalsa.patch
new file mode 100644
index 000000000000..a43b9d64e5fe
--- /dev/null
+++ b/media-sound/awesfx/files/awesfx-0.5.1-configure-noalsa.patch
@@ -0,0 +1,263 @@
+diff -ur awesfx-0.5.1.orig/configure awesfx-0.5.1/configure
+--- awesfx-0.5.1.orig/configure 2007-07-25 12:56:30.000000000 +0300
++++ awesfx-0.5.1/configure 2007-07-29 15:16:17.000000000 +0300
+@@ -19647,259 +19647,6 @@
+
+
+
+-alsa_save_CFLAGS="$CFLAGS"
+-alsa_save_LDFLAGS="$LDFLAGS"
+-alsa_save_LIBS="$LIBS"
+-alsa_found=yes
+-
+-
+-# Check whether --with-alsa-prefix was given.
+-if test "${with_alsa_prefix+set}" = set; then
+- withval=$with_alsa_prefix; alsa_prefix="$withval"
+-else
+- alsa_prefix=""
+-fi
+-
+-
+-
+-# Check whether --with-alsa-inc-prefix was given.
+-if test "${with_alsa_inc_prefix+set}" = set; then
+- withval=$with_alsa_inc_prefix; alsa_inc_prefix="$withval"
+-else
+- alsa_inc_prefix=""
+-fi
+-
+-
+-# Check whether --enable-alsatest was given.
+-if test "${enable_alsatest+set}" = set; then
+- enableval=$enable_alsatest; enable_alsatest="$enableval"
+-else
+- enable_alsatest=yes
+-fi
+-
+-
+-{ echo "$as_me:$LINENO: checking for ALSA CFLAGS" >&5
+-echo $ECHO_N "checking for ALSA CFLAGS... $ECHO_C" >&6; }
+-if test "$alsa_inc_prefix" != "" ; then
+- ALSA_CFLAGS="$ALSA_CFLAGS -I$alsa_inc_prefix"
+- CFLAGS="$CFLAGS -I$alsa_inc_prefix"
+-fi
+-{ echo "$as_me:$LINENO: result: $ALSA_CFLAGS" >&5
+-echo "${ECHO_T}$ALSA_CFLAGS" >&6; }
+-
+-{ echo "$as_me:$LINENO: checking for ALSA LDFLAGS" >&5
+-echo $ECHO_N "checking for ALSA LDFLAGS... $ECHO_C" >&6; }
+-if test "$alsa_prefix" != "" ; then
+- ALSA_LIBS="$ALSA_LIBS -L$alsa_prefix"
+- LDFLAGS="$LDFLAGS $ALSA_LIBS"
+-fi
+-
+-ALSA_LIBS="$ALSA_LIBS -lasound -lm -ldl -lpthread"
+-LIBS="$ALSA_LIBS $LIBS"
+-{ echo "$as_me:$LINENO: result: $ALSA_LIBS" >&5
+-echo "${ECHO_T}$ALSA_LIBS" >&6; }
+-
+-min_alsa_version=1.0.0
+-{ echo "$as_me:$LINENO: checking for libasound headers version >= $min_alsa_version" >&5
+-echo $ECHO_N "checking for libasound headers version >= $min_alsa_version... $ECHO_C" >&6; }
+-no_alsa=""
+- alsa_min_major_version=`echo $min_alsa_version | \
+- sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`
+- alsa_min_minor_version=`echo $min_alsa_version | \
+- sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\2/'`
+- alsa_min_micro_version=`echo $min_alsa_version | \
+- sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\3/'`
+-
+-
+-ac_ext=c
+-ac_cpp='$CPP $CPPFLAGS'
+-ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
+-ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
+-ac_compiler_gnu=$ac_cv_c_compiler_gnu
+-
+-cat >conftest.$ac_ext <<_ACEOF
+-/* confdefs.h. */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h. */
+-
+-#include <alsa/asoundlib.h>
+-
+-int
+-main ()
+-{
+-
+-/* ensure backward compatibility */
+-#if !defined(SND_LIB_MAJOR) && defined(SOUNDLIB_VERSION_MAJOR)
+-#define SND_LIB_MAJOR SOUNDLIB_VERSION_MAJOR
+-#endif
+-#if !defined(SND_LIB_MINOR) && defined(SOUNDLIB_VERSION_MINOR)
+-#define SND_LIB_MINOR SOUNDLIB_VERSION_MINOR
+-#endif
+-#if !defined(SND_LIB_SUBMINOR) && defined(SOUNDLIB_VERSION_SUBMINOR)
+-#define SND_LIB_SUBMINOR SOUNDLIB_VERSION_SUBMINOR
+-#endif
+-
+-# if(SND_LIB_MAJOR > $alsa_min_major_version)
+- exit(0);
+-# else
+-# if(SND_LIB_MAJOR < $alsa_min_major_version)
+-# error not present
+-# endif
+-
+-# if(SND_LIB_MINOR > $alsa_min_minor_version)
+- exit(0);
+-# else
+-# if(SND_LIB_MINOR < $alsa_min_minor_version)
+-# error not present
+-# endif
+-
+-# if(SND_LIB_SUBMINOR < $alsa_min_micro_version)
+-# error not present
+-# endif
+-# endif
+-# endif
+-exit(0);
+-
+- ;
+- return 0;
+-}
+-_ACEOF
+-rm -f conftest.$ac_objext
+-if { (ac_try="$ac_compile"
+-case "(($ac_try" in
+- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
+- *) ac_try_echo=$ac_try;;
+-esac
+-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
+- (eval "$ac_compile") 2>conftest.er1
+- ac_status=$?
+- grep -v '^ *+' conftest.er1 >conftest.err
+- rm -f conftest.er1
+- cat conftest.err >&5
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } && {
+- test -z "$ac_c_werror_flag" ||
+- test ! -s conftest.err
+- } && test -s conftest.$ac_objext; then
+- { echo "$as_me:$LINENO: result: found." >&5
+-echo "${ECHO_T}found." >&6; }
+-else
+- echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+- { echo "$as_me:$LINENO: result: not present." >&5
+-echo "${ECHO_T}not present." >&6; }
+- { { echo "$as_me:$LINENO: error: Sufficiently new version of libasound not found." >&5
+-echo "$as_me: error: Sufficiently new version of libasound not found." >&2;}
+- { (exit 1); exit 1; }; }
+- alsa_found=no
+-
+-fi
+-
+-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
+-ac_ext=c
+-ac_cpp='$CPP $CPPFLAGS'
+-ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
+-ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
+-ac_compiler_gnu=$ac_cv_c_compiler_gnu
+-
+-
+-if test "x$enable_alsatest" = "xyes"; then
+-
+-{ echo "$as_me:$LINENO: checking for snd_ctl_open in -lasound" >&5
+-echo $ECHO_N "checking for snd_ctl_open in -lasound... $ECHO_C" >&6; }
+-if test "${ac_cv_lib_asound_snd_ctl_open+set}" = set; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+- ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lasound $LIBS"
+-cat >conftest.$ac_ext <<_ACEOF
+-/* confdefs.h. */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h. */
+-
+-/* Override any GCC internal prototype to avoid an error.
+- Use char because int might match the return type of a GCC
+- builtin and then its argument prototype would still apply. */
+-#ifdef __cplusplus
+-extern "C"
+-#endif
+-char snd_ctl_open ();
+-int
+-main ()
+-{
+-return snd_ctl_open ();
+- ;
+- return 0;
+-}
+-_ACEOF
+-rm -f conftest.$ac_objext conftest$ac_exeext
+-if { (ac_try="$ac_link"
+-case "(($ac_try" in
+- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
+- *) ac_try_echo=$ac_try;;
+-esac
+-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
+- (eval "$ac_link") 2>conftest.er1
+- ac_status=$?
+- grep -v '^ *+' conftest.er1 >conftest.err
+- rm -f conftest.er1
+- cat conftest.err >&5
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } && {
+- test -z "$ac_c_werror_flag" ||
+- test ! -s conftest.err
+- } && test -s conftest$ac_exeext &&
+- $as_test_x conftest$ac_exeext; then
+- ac_cv_lib_asound_snd_ctl_open=yes
+-else
+- echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+- ac_cv_lib_asound_snd_ctl_open=no
+-fi
+-
+-rm -f core conftest.err conftest.$ac_objext conftest_ipa8_conftest.oo \
+- conftest$ac_exeext conftest.$ac_ext
+-LIBS=$ac_check_lib_save_LIBS
+-fi
+-{ echo "$as_me:$LINENO: result: $ac_cv_lib_asound_snd_ctl_open" >&5
+-echo "${ECHO_T}$ac_cv_lib_asound_snd_ctl_open" >&6; }
+-if test $ac_cv_lib_asound_snd_ctl_open = yes; then
+- cat >>confdefs.h <<_ACEOF
+-#define HAVE_LIBASOUND 1
+-_ACEOF
+-
+- LIBS="-lasound $LIBS"
+-
+-else
+- { { echo "$as_me:$LINENO: error: No linkable libasound was found." >&5
+-echo "$as_me: error: No linkable libasound was found." >&2;}
+- { (exit 1); exit 1; }; }
+- alsa_found=no
+-
+-fi
+-
+-fi
+-
+-if test "x$alsa_found" = "xyes" ; then
+- :
+- LIBS=`echo $LIBS | sed 's/-lasound//g'`
+- LIBS=`echo $LIBS | sed 's/ //'`
+- LIBS="-lasound $LIBS"
+-fi
+-if test "x$alsa_found" = "xno" ; then
+- :
+- CFLAGS="$alsa_save_CFLAGS"
+- LDFLAGS="$alsa_save_LDFLAGS"
+- LIBS="$alsa_save_LIBS"
+- ALSA_CFLAGS=""
+- ALSA_LIBS=""
+-fi
+
+
+
diff --git a/media-sound/awesfx/files/awesfx-0.5.1-include.patch b/media-sound/awesfx/files/awesfx-0.5.1-include.patch
new file mode 100644
index 000000000000..0116781e64b6
--- /dev/null
+++ b/media-sound/awesfx/files/awesfx-0.5.1-include.patch
@@ -0,0 +1,48 @@
+diff -ur awesfx-0.5.1.orig/awelib/loadbank.c awesfx-0.5.1/awelib/loadbank.c
+--- awesfx-0.5.1.orig/awelib/loadbank.c 2004-01-22 18:58:13.000000000 +0200
++++ awesfx-0.5.1/awelib/loadbank.c 2007-07-29 15:02:36.000000000 +0300
+@@ -24,11 +24,10 @@
+ #include <ctype.h>
+ #ifdef linux
+ #include <linux/soundcard.h>
+-#include <linux/awe_voice.h>
+ #else
+ #include <machine/soundcard.h>
+-#include <awe_voice.h>
+ #endif
++#include "awe_voice.h"
+ #include "util.h"
+ #include "awebank.h"
+ #include "aweseq.h"
+diff -ur awesfx-0.5.1.orig/awelib/parsesf.c awesfx-0.5.1/awelib/parsesf.c
+--- awesfx-0.5.1.orig/awelib/parsesf.c 2004-02-04 17:18:35.000000000 +0200
++++ awesfx-0.5.1/awelib/parsesf.c 2007-07-29 15:02:01.000000000 +0300
+@@ -29,11 +29,10 @@
+ #include <errno.h>
+ #ifdef linux
+ #include <linux/soundcard.h>
+-#include <linux/awe_voice.h>
+ #else
+ #include <machine/soundcard.h>
+-#include <awe_voice.h>
+ #endif
++#include "awe_voice.h"
+ #include "awe_parm.h"
+ #include "itypes.h"
+ #include "sffile.h"
+diff -ur awesfx-0.5.1.orig/include/awe_parm.h awesfx-0.5.1/include/awe_parm.h
+--- awesfx-0.5.1.orig/include/awe_parm.h 2000-04-27 16:45:35.000000000 +0300
++++ awesfx-0.5.1/include/awe_parm.h 2007-07-29 15:07:37.000000000 +0300
+@@ -21,11 +21,7 @@
+ #ifndef AWE_PARM_H_DEF
+ #define AWE_PARM_H_DEF
+
+-#ifdef linux
+-#include <linux/awe_voice.h>
+-#else
+-#include <awe_voice.h>
+-#endif
++#include "awe_voice.h"
+
+ void awe_init_parm(awe_voice_parm *pp);
+ void awe_init_voice(awe_voice_info *vp);
diff --git a/media-sound/awesfx/files/awesfx-0.5.1-makefile-noalsa.patch b/media-sound/awesfx/files/awesfx-0.5.1-makefile-noalsa.patch
new file mode 100644
index 000000000000..49afc98c6cc3
--- /dev/null
+++ b/media-sound/awesfx/files/awesfx-0.5.1-makefile-noalsa.patch
@@ -0,0 +1,82 @@
+--- Makefile.orig 2007-07-29 15:19:05.000000000 +0300
++++ Makefile 2007-07-29 15:23:51.000000000 +0300
+@@ -33,7 +33,7 @@
+ POST_UNINSTALL = :
+ build_triplet = i686-pc-linux-gnu
+ host_triplet = i686-pc-linux-gnu
+-bin_PROGRAMS = sfxload$(EXEEXT) asfxload$(EXEEXT) aweset$(EXEEXT) \
++bin_PROGRAMS = sfxload$(EXEEXT) aweset$(EXEEXT) \
+ gusload$(EXEEXT) setfx$(EXEEXT) sf2text$(EXEEXT) \
+ text2sf$(EXEEXT) sfxtest$(EXEEXT)
+ subdir = .
+@@ -53,9 +53,6 @@
+ am__installdirs = "$(DESTDIR)$(bindir)" "$(DESTDIR)$(man1dir)"
+ binPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
+ PROGRAMS = $(bin_PROGRAMS)
+-am_asfxload_OBJECTS = asfxload.$(OBJEXT) alsa.$(OBJEXT)
+-asfxload_OBJECTS = $(am_asfxload_OBJECTS)
+-asfxload_DEPENDENCIES = awelib/libawe.a
+ am_aweset_OBJECTS = aweset.$(OBJEXT) seq.$(OBJEXT)
+ aweset_OBJECTS = $(am_aweset_OBJECTS)
+ aweset_LDADD = $(LDADD)
+@@ -96,10 +93,10 @@
+ LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
+ --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) \
+ $(LDFLAGS) -o $@
+-SOURCES = $(asfxload_SOURCES) $(aweset_SOURCES) $(gusload_SOURCES) \
++SOURCES = $(aweset_SOURCES) $(gusload_SOURCES) \
+ $(setfx_SOURCES) $(sf2text_SOURCES) $(sfxload_SOURCES) \
+ $(sfxtest_SOURCES) $(text2sf_SOURCES)
+-DIST_SOURCES = $(asfxload_SOURCES) $(aweset_SOURCES) \
++DIST_SOURCES = $(aweset_SOURCES) \
+ $(gusload_SOURCES) $(setfx_SOURCES) $(sf2text_SOURCES) \
+ $(sfxload_SOURCES) $(sfxtest_SOURCES) $(text2sf_SOURCES)
+ RECURSIVE_TARGETS = all-recursive check-recursive dvi-recursive \
+@@ -166,7 +163,7 @@
+ INSTALL_STRIP_PROGRAM = $(install_sh) -c -s
+ LDFLAGS = -Wl,-O1,--as-needed
+ LIBOBJS =
+-LIBS =
++LIBS = -lm -ldl -lpthread
+ LIBTOOL = $(SHELL) $(top_builddir)/libtool
+ LN_S = ln -s
+ LTLIBOBJS =
+@@ -240,8 +237,6 @@
+ SUBDIRS = awelib include samples etc
+ LDADD = awelib/libawe.a
+ INCLUDES = -Iinclude
+-asfxload_SOURCES = asfxload.c alsa.c
+-asfxload_LDADD = awelib/libawe.a
+ sfxload_SOURCES = sfxload.c seq.c
+ aweset_SOURCES = aweset.c seq.c
+ gusload_SOURCES = gusload.c seq.c
+@@ -317,9 +312,6 @@
+ echo " rm -f $$p $$f"; \
+ rm -f $$p $$f ; \
+ done
+-asfxload$(EXEEXT): $(asfxload_OBJECTS) $(asfxload_DEPENDENCIES)
+- @rm -f asfxload$(EXEEXT)
+- $(LINK) $(asfxload_OBJECTS) $(asfxload_LDADD) $(LIBS)
+ aweset$(EXEEXT): $(aweset_OBJECTS) $(aweset_DEPENDENCIES)
+ @rm -f aweset$(EXEEXT)
+ $(LINK) $(aweset_OBJECTS) $(aweset_LDADD) $(LIBS)
+@@ -348,8 +340,6 @@
+ distclean-compile:
+ -rm -f *.tab.c
+
+-include ./$(DEPDIR)/alsa.Po
+-include ./$(DEPDIR)/asfxload.Po
+ include ./$(DEPDIR)/aweset.Po
+ include ./$(DEPDIR)/gusload.Po
+ include ./$(DEPDIR)/seq.Po
+@@ -828,8 +818,8 @@
+
+
+ install-data-hook:
+- rm -f $(DESTDIR)$(mandir)/man1/asfxload.1
+- (cd $(DESTDIR)$(mandir)/man1 && $(LN_S) sfxload.1 asfxload.1)
++# rm -f $(DESTDIR)$(mandir)/man1/asfxload.1
++# (cd $(DESTDIR)$(mandir)/man1 && $(LN_S) sfxload.1 asfxload.1)
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/media-sound/awesfx/files/digest-awesfx-0.5.1 b/media-sound/awesfx/files/digest-awesfx-0.5.1
new file mode 100644
index 000000000000..3f9fd8495571
--- /dev/null
+++ b/media-sound/awesfx/files/digest-awesfx-0.5.1
@@ -0,0 +1,3 @@
+MD5 3ddc510f03ae8dfee3d1bf089fc3fea4 awesfx-0.5.1.tar.gz 406372
+RMD160 353a499f82764fab900b5e1b1e524ba56f030df3 awesfx-0.5.1.tar.gz 406372
+SHA256 fa3c24e12265d9cc153f633e1291a7103263a785834c5a3f0dcd7845ef81495c awesfx-0.5.1.tar.gz 406372