summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2009-01-04 13:25:00 +0000
committerChristoph Mende <angelos@gentoo.org>2009-01-04 13:25:00 +0000
commit728d7515fe45d91e8aaeee8572be04d56bdf8cef (patch)
treea959585a8144e8fa4b14fcc7621dfc1f9bc223c3 /media-sound/audio-entropyd
parentclean up (diff)
downloadgentoo-2-728d7515fe45d91e8aaeee8572be04d56bdf8cef.tar.gz
gentoo-2-728d7515fe45d91e8aaeee8572be04d56bdf8cef.tar.bz2
gentoo-2-728d7515fe45d91e8aaeee8572be04d56bdf8cef.zip
Version bump
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'media-sound/audio-entropyd')
-rw-r--r--media-sound/audio-entropyd/ChangeLog10
-rw-r--r--media-sound/audio-entropyd/audio-entropyd-1.0.5.ebuild35
-rw-r--r--media-sound/audio-entropyd/files/audio-entropyd-1.0.5-uclibc.patch27
3 files changed, 70 insertions, 2 deletions
diff --git a/media-sound/audio-entropyd/ChangeLog b/media-sound/audio-entropyd/ChangeLog
index 1eab99e01809..0aa7d18a3284 100644
--- a/media-sound/audio-entropyd/ChangeLog
+++ b/media-sound/audio-entropyd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/audio-entropyd
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audio-entropyd/ChangeLog,v 1.26 2008/05/14 00:14:28 angelos Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audio-entropyd/ChangeLog,v 1.27 2009/01/04 13:24:59 angelos Exp $
+
+*audio-entropyd-1.0.5 (04 Jan 2009)
+
+ 04 Jan 2009; Christoph Mende <angelos@gentoo.org>
+ +files/audio-entropyd-1.0.5-uclibc.patch, +audio-entropyd-1.0.5.ebuild:
+ Version bump
14 May 2008; Christoph Mende <angelos@gentoo.org>
-audio-entropyd-1.0.0.ebuild:
diff --git a/media-sound/audio-entropyd/audio-entropyd-1.0.5.ebuild b/media-sound/audio-entropyd/audio-entropyd-1.0.5.ebuild
new file mode 100644
index 000000000000..f53e580d5116
--- /dev/null
+++ b/media-sound/audio-entropyd/audio-entropyd-1.0.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audio-entropyd/audio-entropyd-1.0.5.ebuild,v 1.1 2009/01/04 13:24:59 angelos Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Audio-entropyd generates entropy-data for the /dev/random device."
+HOMEPAGE="http://www.vanheusden.com/aed/"
+SRC_URI="http://www.vanheusden.com/aed/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-audio-entropyd )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-uclibc.patch"
+ sed -i -e "s:^OPT_FLAGS=.*:OPT_FLAGS=${CFLAGS}:" Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dosbin audio-entropyd || die "dosbin failed"
+ dodoc README README.2 TODO
+ newinitd "${FILESDIR}/${PN}.init" ${PN}
+ newconfd "${FILESDIR}/${PN}.conf" ${PN}
+}
diff --git a/media-sound/audio-entropyd/files/audio-entropyd-1.0.5-uclibc.patch b/media-sound/audio-entropyd/files/audio-entropyd-1.0.5-uclibc.patch
new file mode 100644
index 000000000000..bdf5adeff825
--- /dev/null
+++ b/media-sound/audio-entropyd/files/audio-entropyd-1.0.5-uclibc.patch
@@ -0,0 +1,27 @@
+--- audio-entropyd-1.0.1.orig/error.c 2008-01-22 09:50:28 +0000
++++ audio-entropyd-1.0.1/error.c 2008-01-22 09:53:51 +0000
+@@ -9,13 +9,13 @@
+ #include <signal.h>
+ #include <syslog.h>
+ #include <regex.h>
+-#if defined(__GLIBC__)
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
+ #include <execinfo.h>
+ #endif
+
+ void print_trace(void)
+ {
+-#if defined(__GLIBC__)
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
+ void *array[MAX_BACKTRACE_LENGTH];
+ size_t size;
+
+@@ -39,7 +39,7 @@
+ printf("\n\n\nDebug information:\n");
+ if (errno) fprintf(stderr, "errno: %d=%s (if applicable)\n", errno, strerror(errno));
+
+-#if defined(__GLIBC__)
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
+ print_trace();
+ #endif
+