summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-01-22 12:22:45 +0000
committerChristoph Mende <angelos@gentoo.org>2008-01-22 12:22:45 +0000
commit46be153da734c196e9ab1622f0ccb74daaebbe1e (patch)
tree26912b151373b8988863354a2a755defcd476d5c /media-sound/audio-entropyd
parentFix Emacs support, bug 202331. (diff)
downloadgentoo-2-46be153da734c196e9ab1622f0ccb74daaebbe1e.tar.gz
gentoo-2-46be153da734c196e9ab1622f0ccb74daaebbe1e.tar.bz2
gentoo-2-46be153da734c196e9ab1622f0ccb74daaebbe1e.zip
Work around compilation failures on uclibc
(Portage version: 2.1.4)
Diffstat (limited to 'media-sound/audio-entropyd')
-rw-r--r--media-sound/audio-entropyd/ChangeLog6
-rw-r--r--media-sound/audio-entropyd/audio-entropyd-1.0.1.ebuild5
-rw-r--r--media-sound/audio-entropyd/files/audio-entropyd-1.0.1-uclibc.patch27
3 files changed, 35 insertions, 3 deletions
diff --git a/media-sound/audio-entropyd/ChangeLog b/media-sound/audio-entropyd/ChangeLog
index 25c1b138f6c7..7794c7f7425f 100644
--- a/media-sound/audio-entropyd/ChangeLog
+++ b/media-sound/audio-entropyd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/audio-entropyd
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audio-entropyd/ChangeLog,v 1.23 2008/01/21 21:58:40 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audio-entropyd/ChangeLog,v 1.24 2008/01/22 12:22:44 angelos Exp $
+
+ 22 Jan 2008; Christoph Mende <angelos@gentoo.org>
+ +files/audio-entropyd-1.0.1-uclibc.patch, audio-entropyd-1.0.1.ebuild:
+ Work around compilation failures on uclibc
21 Jan 2008; Markus Meier <maekke@gentoo.org>
-audio-entropyd-0.0.6.ebuild:
diff --git a/media-sound/audio-entropyd/audio-entropyd-1.0.1.ebuild b/media-sound/audio-entropyd/audio-entropyd-1.0.1.ebuild
index 3e4d3efcfea3..90d551dfc0a7 100644
--- a/media-sound/audio-entropyd/audio-entropyd-1.0.1.ebuild
+++ b/media-sound/audio-entropyd/audio-entropyd-1.0.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audio-entropyd/audio-entropyd-1.0.1.ebuild,v 1.3 2008/01/21 21:55:52 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audio-entropyd/audio-entropyd-1.0.1.ebuild,v 1.4 2008/01/22 12:22:44 angelos Exp $
-inherit toolchain-funcs
+inherit eutils toolchain-funcs
DESCRIPTION="Audio-entropyd generates entropy-data for the /dev/random device."
HOMEPAGE="http://www.vanheusden.com/aed/"
@@ -19,6 +19,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}/${P}-uclibc.patch"
sed -i -e "s:^OPT_FLAGS=.*:OPT_FLAGS=${CFLAGS}:" Makefile
}
diff --git a/media-sound/audio-entropyd/files/audio-entropyd-1.0.1-uclibc.patch b/media-sound/audio-entropyd/files/audio-entropyd-1.0.1-uclibc.patch
new file mode 100644
index 000000000000..bdf5adeff825
--- /dev/null
+++ b/media-sound/audio-entropyd/files/audio-entropyd-1.0.1-uclibc.patch
@@ -0,0 +1,27 @@
+--- audio-entropyd-1.0.1.orig/error.c 2008-01-22 09:50:28 +0000
++++ audio-entropyd-1.0.1/error.c 2008-01-22 09:53:51 +0000
+@@ -9,13 +9,13 @@
+ #include <signal.h>
+ #include <syslog.h>
+ #include <regex.h>
+-#if defined(__GLIBC__)
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
+ #include <execinfo.h>
+ #endif
+
+ void print_trace(void)
+ {
+-#if defined(__GLIBC__)
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
+ void *array[MAX_BACKTRACE_LENGTH];
+ size_t size;
+
+@@ -39,7 +39,7 @@
+ printf("\n\n\nDebug information:\n");
+ if (errno) fprintf(stderr, "errno: %d=%s (if applicable)\n", errno, strerror(errno));
+
+-#if defined(__GLIBC__)
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
+ print_trace();
+ #endif
+