summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2009-12-11 10:46:36 +0000
committerChristoph Mende <angelos@gentoo.org>2009-12-11 10:46:36 +0000
commitffa1e717f87d82c6a27df7cbe6c133e7e6a0c91e (patch)
tree06b18f77a927df7e6059fe1e2a02571be834f33f /media-sound/ario
parentx11-libs/libdrm: fix build on !intel arches wrt atomic ops (see bug #296482) (diff)
downloadgentoo-2-ffa1e717f87d82c6a27df7cbe6c133e7e6a0c91e.tar.gz
gentoo-2-ffa1e717f87d82c6a27df7cbe6c133e7e6a0c91e.tar.bz2
gentoo-2-ffa1e717f87d82c6a27df7cbe6c133e7e6a0c91e.zip
Version bump (bug 295786)
(Portage version: 2.2_rc51/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/ario')
-rw-r--r--media-sound/ario/ChangeLog7
-rw-r--r--media-sound/ario/ario-1.4.1.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/media-sound/ario/ChangeLog b/media-sound/ario/ChangeLog
index 14adc4822dc9..253e77177795 100644
--- a/media-sound/ario/ChangeLog
+++ b/media-sound/ario/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/ario
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ario/ChangeLog,v 1.11 2009/11/04 21:24:23 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ario/ChangeLog,v 1.12 2009/12/11 10:46:36 angelos Exp $
+
+*ario-1.4.1 (11 Dec 2009)
+
+ 11 Dec 2009; Christoph Mende <angelos@gentoo.org> +ario-1.4.1.ebuild:
+ Version bump (bug 295786)
04 Nov 2009; Christoph Mende <angelos@gentoo.org> ario-1.3.ebuild,
+files/ario-1.3-unsupported-warnings.patch:
diff --git a/media-sound/ario/ario-1.4.1.ebuild b/media-sound/ario/ario-1.4.1.ebuild
new file mode 100644
index 000000000000..92c3b1bbf25f
--- /dev/null
+++ b/media-sound/ario/ario-1.4.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ario/ario-1.4.1.ebuild,v 1.1 2009/12/11 10:46:36 angelos Exp $
+
+EAPI=1
+inherit gnome2-utils
+
+DESCRIPTION="a GTK2 MPD (Music Player Daemon) client inspired by Rythmbox"
+HOMEPAGE="http://ario-player.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}-player/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="audioscrobbler dbus debug idle libnotify nls python taglib zeroconf"
+
+RDEPEND=">=dev-libs/glib-2.14:2
+ dev-libs/libunique
+ media-libs/libmpdclient
+ net-misc/curl
+ net-libs/gnutls
+ >=x11-libs/gtk+-2.16:2
+ audioscrobbler? ( net-libs/libsoup:2.4 )
+ dbus? ( dev-libs/dbus-glib )
+ libnotify? ( x11-libs/libnotify )
+ python? ( dev-python/pygtk
+ dev-python/pygobject )
+ taglib? ( media-libs/taglib )
+ zeroconf? ( net-dns/avahi )"
+DEPEND="sys-devel/gettext
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf \
+ --enable-libmpdclient2 \
+ --enable-search \
+ --enable-playlists \
+ $(use_enable audioscrobbler) \
+ $(use_enable dbus) \
+ $(use_enable debug) \
+ $(use_enable idle mpdidle) \
+ $(use_enable libnotify notify) \
+ $(use_enable nls) \
+ $(use_enable python) \
+ $(use_enable taglib) \
+ $(use_enable zeroconf avahi)
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}